2 things SOUND_CARD_IRQ, and errors in jack while running Ardour...

No replies
triplesquarednine
User offline. Last seen 3 years 39 weeks ago. Offline
Joined: 2008-03-22
Posts:

i have 2 questions if anyone is upto answering with thier wealth of knowledge!

1st im getting alot of xruns in ardour/jack.

and i think this is causing me issues in my kernel. i am running
Ubuntu Jaunty...2.6.28 PREEMPT-RT/gnome. i have jackdmp(1.9.2) Ardour 2.8
everything seems to work fine. i have a fast dell laptop and all the rest.
but i am having difficulty getting low latencies without lots of xruns, especially in Ardour..

what happens in jack with ardour

**** alsa_pcm: xrun of at least 0.011 msecs
JackAudioDriver::ProcessAsync: read error, skip cycle
alsa_driver_xrun_recovery
**** alsa_pcm: xrun of at least 0.011 msecs
JackAudioDriver::ProcessAsync: read error, skip cycle

this doesn't seem very healthy to me!

any ideas on a fix???

2nd: How do i set my SOUND_CARD_IRQ????? i cant find an answer anywhere,
i have found in the past that there are some pretty sharp people around the ardour forum,
and maybe someone has some insight for me???

this is an example of what happens... i can run realTimeConfigQuickScan.pl
this is it's output:

Checking for Ingo Molnar's Real-Time Preemption... found - good.
Checking for high-resolution timers... found - good.
Checking for IDE support... not found - skipping IDE checks.
Checking for 1000hz clock... found - good.
Checking for High Resolution Timers... found - good.
Checking filesystem types... ok.
Checking tmpfs mounted on /tmp.. ok.
Checking filesystem 'noatime' parameter... ok.
** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks
Checking the ability to prioritize processes with (re)nice... yes - good.
Checking whether you're in the 'audio' group... yes - good.
Checking for multiple 'audio' groups... no - good.
Checking access to the real-time clock... readable - good.
Checking sysctl settings:
- checking inotify max_user_watches... >= 524288 - good.
Checking for resource-intensive background processes... none found - good.

i figure that this must be atleast part of the problem...

any advice/fixes welcome,
thanx

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Download and install the deb package from here:
http://ftp.cs.pu.edu.tw/Linux/Ubuntu/ubuntu/pool/universe/r/rtirq/

The package is an automatic startup script that gives higher priority to you sound card. IT ONLY WORKS IN RT-KERNEL.

You must reboot for changes to take effect.

There is will be a configuration script for it in /etc/default/rtirq

Read it, maybe tweak it, depending on which soundcard you want to give higher priority.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

As for setting $SOUND_CARD_IRQ it won't fix your problems, it will just allow realTimeConfigQuickScan.pl to do more checks if I interpret "Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks" correctly.

To do that run cat /proc/interrupts to find out which IRQ you soundcard has and run export SOUND_CARD_IRQ=5 (assuming the IRQ is 5).