Ardour with LV2

17 replies [Last post]
Scary-Hallo
Scary-Hallo's picture
User offline. Last seen 30 weeks 4 days ago. Offline
Joined: 2009-02-13
Posts:

Hello

I have just compiled Ardour2.8 like

scons SLV2=1 FREESOUND=1
sudo scons install

and I have installed Calf
but I can't see any LV2 plugins in my Ardour.
in http://ardour.org/node/1647 I've read that I shoud check out LV2 from SVN. But what is the adress for the repos?
And how do I install it?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 5 days ago. Offline
Joined: 2008-02-27
Posts:

You'll have to install SLV2
http://drobilla.net/software/slv2/

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 5 days ago. Offline
Joined: 2008-02-27
Posts:

Oh, also your scons tag is wrong it's not SLV2=1 it should be LV2=1

But once you compile and install SLV2 you should then notice that LV2 will be enabled automatically when you type scons --help

GMaq
GMaq's picture
User offline. Last seen 16 min 10 sec ago. Offline
Joined: 2007-12-11
Posts:

Hi,

Joe is quite correct, however you will require both the latest slv2 and lv2core. Ubuntu has packages for this, I'm not sure what other distros do, I had to build both for myself in Debian.

lv2core: http://lv2plug.in/spec/

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 5 days ago. Offline
Joined: 2008-02-27
Posts:

Ah, yes, forgot that one. It is in repos but a bit outdated, might be better to install the one GMaq points to.

Scary-Hallo
Scary-Hallo's picture
User offline. Last seen 30 weeks 4 days ago. Offline
Joined: 2009-02-13
Posts:

That's what I did. I downloaded the tarball from http://lv2plug.in/spec/.
I installed it with

./waf configure
./waf

and finaly

sudo ./waf install

But still it says LV2 is disabled.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 5 days ago. Offline
Joined: 2008-02-27
Posts:

Ok, well that is LV2core you are still missing SLV2

http://drobilla.net/software/slv2/

(In total 2 packages LV2core and SLV2)

Scary-Hallo
Scary-Hallo's picture
User offline. Last seen 30 weeks 4 days ago. Offline
Joined: 2009-02-13
Posts:

OK, I'll give it a try this evening. I'm on work now.

packoman
User offline. Last seen 3 years 28 weeks ago. Offline
Joined: 2007-06-07
Posts:

Hi.
I recently did the same thing... took me a while so I wrote it down. This was on Ubuntu 9.04. As you see below I had a problem with the compilation and found a patch (got lucky...). If you should run into that problem, I can send you the patch (or you get from the homepage). The part on building with LV2 is below the error explanation. I'm actually not sure about the lv2core part, but I think I took those from the repos . Hope it helps...

Build Ardour with minimum requirements:
1. do >>sudo apt-get install scons
2. do >>sudo apt-get install liblrdf0-dev
3. do >>sudo apt-get install libgnomecanvas2-dev
4. do >>sudo apt-get install libjack-dev
5. do >>sudo apt-get install libsamplerate0-dev
6. do >>sudo apt-get install libfftw3-dev
7. do >>sudo apt-get install libaubio-dev
8. do >>sudo apt-get install liblo-dev
9. do >>sudo apt-get install libasound2-dev
10. do >>sudo scons

if the following error occurs:
[Code]
In file included from /usr/include/boost/dynamic_bitset.hpp:15,
from libs/ardour/ardour/session.h:32,
from libs/ardour/ardour/audio_diskstream.h:39,
from libs/ardour/audio_diskstream.cc:44:
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp: In member function ‘size_t boost::dynamic_bitset::count() const’:
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: ‘mode’ cannot appear in a constant-expression
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: template argument 1 is invalid
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: expected `>' before ‘*’ token
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: expected `(' before ‘*’ token
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: expected primary-expression before ‘>’ token
scons: *** [libs/ardour/audio_diskstream.os] Error 1
scons: building terminated because of errors.
[/Code]

Use the patch "dynamic_bitset.hpp.patch" and patch the file "dynamic_bitset.hpp.patch", the patch comes from:
https://bugzilla.redhat.com/show_bug.cgi?id=491537

Make a Backup of dynamic_bitset.hpp to dynamic_bitset.hpp_BKP and do:
>>patch dynamic_bitset.hpp_BKP -i dynamic_bitset.hpp.patch -o dynamic_bitset.hpp

Build with LV2 support:
1. download current SLV2 from http://drobilla.net/software/slv2/
2. install redland dependency: do >>sudo apt-get install librdf0-dev
3. do >>./waf configure
4. do >>./waf install

#### PROBABLY INCORRECT
Build for FREESOUND support:
1. install FLAC dependency: do >>sudo apt-get install libflac-dev

Scary-Hallo
Scary-Hallo's picture
User offline. Last seen 30 weeks 4 days ago. Offline
Joined: 2009-02-13
Posts:

Thanks joegiampaoli,

that was it. Compiled with LV2. But after all, I have the feeling that my Ardour is very unstable with LV2 plugins. I had 2 crashes in one hour.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 5 days ago. Offline
Joined: 2008-02-27
Posts:

Hmmm, that is strange, shouldn't really crash with LV2 plugins. Which are you using?, the CALF plugins are really sweet and stable ones, especially the Vitage Delay, Multichorus and Phaser, well I'm mostly a gitarist, so this are plugins I use quite a lot instead of recording them off my BOSS GT-8.

Open Ardour from term and fiddle around with the CALF or other LV2 plugins and if it crashes see if the term shows any errors.

Scary-Hallo
Scary-Hallo's picture
User offline. Last seen 30 weeks 4 days ago. Offline
Joined: 2009-02-13
Posts:

Strange, no more crashes now. But I got a warning while starting Ardour:

Warning: Unable to create "trees" RDF storage.
Performance can be improved by upgrading librdf.

I think I'm gonna get myself a new 'librdf'. Mine is from synaptic (Ubuntu Studio 8.04)
By the way, also I'm guitarist (using GT-6).

Thanks again for all your help (joegiampaoli, GMaq and packoman).

peder
User offline. Last seen 48 weeks 6 days ago. Offline
Joined: 2007-05-08
Posts:

That's a benign warning. You shouldn't have do do anything about it, just look away while it scrolls past :)

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 5 days ago. Offline
Joined: 2008-02-27
Posts:

peder is correct I'm also using librdf from repos, won't hurt to compile your own, but I don't think it's necessary.

triune
User offline. Last seen 2 years 10 weeks ago. Offline
Joined: 2009-05-26
Posts:

so how do we enable vst using waf then?

peder
User offline. Last seen 48 weeks 6 days ago. Offline
Joined: 2007-05-08
Posts:

so how do we enable vst using waf then?

Certainly not by hijacking a four months old thread about scons and LV2...

triune
User offline. Last seen 2 years 10 weeks ago. Offline
Joined: 2009-05-26
Posts:

Thanks Peder, but if you actually knew the answer and gave this response, you're quite lame.

peder
User offline. Last seen 48 weeks 6 days ago. Offline
Joined: 2007-05-08
Posts:

My "lameness" had two purposes:
1. To teach you a bit of netiquette
2. To make sure others with the same question got a properly entitled post to search (assuming you learned the implicit lesson in [1] and made a proper post) instead of having to delve into a completely unrelated question.

...and I saw you got the answer in that post...