Plugin weirdness v2 (disappearing plugins)

5 replies [Last post]
TheatreME
User offline. Last seen 27 weeks 2 days ago. Offline
Joined: 2007-04-12
Posts:

Hey,

The more I work with this software, the more I really like it. But I have noticed another plugin bug that could be potentially very annoying.

Sometimes I add a plugin pre fader on a channel and it doesnt seem to take. What I mean is I click on the plugin, but it doesnt appear in the channel strip though Ardour actually did add it (I can hear it working).

I also believe that once or twice an added plugin will disappear from the channel once added though I can still hear plugin on the channel.

Saving the session and reopening the session seems to fix the problem and all plugins can be seen again.

The plugin in question most often has been the bundled (dmg) version of Freeverb, though it has happened on a few others.

It has not been a huge problem so far, as I am not really stacking my plugins, but any help on the issue would be appreciated.

rozea
User offline. Last seen 16 weeks 5 days ago. Offline
Joined: 2008-09-23
Posts:

I have the same problem:

bug:0002640 in mantis

I hope this will be fixed in 2.8.1

TheatreME
User offline. Last seen 27 weeks 2 days ago. Offline
Joined: 2007-04-12
Posts:

Thanks I just wanted to check with other people before posting a bug report.

seablade
User offline. Last seen 2 hours 27 min ago. Offline
Joined: 2007-01-22
Posts:

Actually can both of you please put your setups on that bug report? Meaning, what distro is this, is theis a version from the distro repos or did you get it elsewhere, or did you build it yourself, etc. Thanks.

Seablade

macinnisrr
macinnisrr's picture
User offline. Last seen 4 days 12 hours ago. Offline
Joined: 2008-01-14
Posts:

I can confirm this bug on the paid OSX build. I assume that the first poster at least is also using some version of OSX as he installed the plugins with a DMG file. When this happens, the plugin is still there, if you double click the empty area where it's supposed to be, the plugin's window opens and the effect becomes visible on the channel strip, there doesn't seem to be any need to close and reopen the session, at least on my setup, which is:
ibookgG4
1.33ghz
1.5 gb ram
OSX 10.4 (all updates applied)
Ardour 2.8.1

seablade
User offline. Last seen 2 hours 27 min ago. Offline
Joined: 2007-01-22
Posts:

Would really help if you attached that info to the bug report instead of here. Developers won't see it here, they will see it on the bug report.

Seablade