How do I delete selection?

No replies
ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

How do I delete a selection without leaving an empty gap in the place where the removed audio segment used to be?

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

I don't think you can, meaning there's no function that automagically joins the right and left secions remaining after the deletion.

You can manually do that if you change the menu below the clock that probably says "Grid" to "Magnetic", change the menu to the right of it to "Region ends" and then use the mouse to drag the right part to the left one. When they meet you should feel a slight "edge resistance" when they meet.

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

Ok, thanks. I'll try that.

I have realized though, after hours of googling, that there ought to be this feature, ie. splice mode, but as of version 2.8 (which is what I'm currently running on my linux machine) the splice functions is broken. Is there some way for me to submit a bug report so that the developers will know about this?

paul
paul's picture
User offline. Last seen 1 day 8 hours ago. Offline
Joined: 2006-03-16
Posts:

Is there some way for me to submit a bug report so that the developers will know about this?

The button marked "Issue Tracker" up near the top right of this and every ardour.org page will get you there. Splice mode does actually do about 80% of what it is intended to do, but its misnamed. ProTools would call this "Shuffle mode".

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

You're correct, the splice mode should do what you want.

In Ardour 2.8 rev 5215 (svn) you can splice-select a range, right click it and select "Convert to region-in-place" and delete that and it'll autoslide the right part to the left.

According to this (vm-nice.stackingdwarves.net:8888/ardour-en/8-ARDOUR/22-ARDOUR/141-ARDOUR/33-ARDOUR/35-ARDOUR.html) it the splice problem seems to be known.

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

Ok, so I guess I am mistaken about what splice mode is supposed to do, and there really is no current way to have it automatically remove the blank space after I delete a section?

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

On a side note Paul, is there a reason why the spamfilter seems to trigger on all my posts lately? Of the three I made today all were trigggered and on the above I had to remove the http part from the URL to be able to post.

Oh, and this post also triggered...

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

In Ardour 2.8 rev 5215 (svn) you can splice-select a range, right click it and select "Convert to region-in-place" and delete that and it'll autoslide the right part to the left.

OK, so in splice mode, I select a region, right click on the region select the "convert to region in-place" option, then hit the delete key. All that happens is that the whitish box that shows what has been selected disappears but the actual audio that was in that region remains. This may sound silly, but could you explain to me how to delete? ;)

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

As you may have noticed I run a svn version that's later than the released 2.8 so it might work better in my version.

That said, I do just like you: in Splice Edit select the |<->| tool and draw a white box, convert it to R-i-p and it should turn blue, hit the Del key and it should be gone and everything slided to the left.

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

OK, it doesn't turn blue for me. I just stays the same shade of pallid white. So is the vsn version available to the public? If so, how do I get it? Or do I just wait a bit for a bug fix? Anyways, I'm using audacity for now, but I'd like to switch all my work over to ardour soon.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

It seem to be a locale problem (!). I tried the released 2.8 with my standard swedish locales and that didn't work. Just for the heck of it I switched over to english to see that I really had it in Splice mode, and all of a sudden it worked.
So, assuming you run it in another language, run this from a terminal:
export LANG=en_US ; ardour2

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

ok, I ran that command, nothing different. But my language is already en_US. So is my system language also. Any other ideas? Do you need to me to describe my problem better? Or could my OS play a role in this problem?

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

This might not help, but here's the other output that I got from that command:

[timothy@localhost ~]$ export LANG=en_US ; ardour2
WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with 'ulimit -l', and it
is normally controlled by /etc/security/limits.conf

/usr/libexec/ardour2: line 29: nm: command not found
/usr/libexec/ardour2: line 29: [: -gt: unary operator expected
Ardour/GTK 2.8
(built using 4918 and GCC version 4.4.0 20090328 (Red Hat 4.4.0-0.30))
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.

(ardour-2.8:2454): Gtk-WARNING **: Unable to locate theme engine in module_path: "ubuntulooks",
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/timothy/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/timothy/.ardour2/ardour.rc
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
ardour: [WARNING]: The ALSA MIDI system is not available. No ports based on it will be created
ardour: [WARNING]: No MMC control (MIDI port "default" not available)
ardour: [INFO]: Using SSE optimized routines
Warning: Unable to create "trees" RDF storage.
Performance can be improved by upgrading librdf.
ardour: [INFO]: looking for control protocols in /home/timothy/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
ardour: [ERROR]: No port called mcu. Add it to ardour.rc.
ardour: [INFO]: Control protocol Mackie not usable
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
ardour: [INFO]: Control protocol Tranzport not usable
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable

(ardour-2.8:2454): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(ardour-2.8:2454): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed
JACK COMMAND: /usr/bin/jackd -p 128 -T -d alsa -n 2 -r 48000 -p 1024 -d hw:0,0
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0,0|hw:0,0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
loading bindings from /etc/ardour2/mnemonic-us.bindings
Loading session /home/timothy/Regulative Principle of Worship using snapshot Regulative Principle of Worship (1)
Loading history from '/home/timothy/Regulative Principle of Worship/Regulative Principle of Worship.history'.

(ardour-2.8:2454): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(ardour-2.8:2454): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(ardour-2.8:2454): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

(ardour-2.8:2454): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

So you say that after you've converted the selection by right clicking and selecting "Convert to region in-place" the selection desn't switch from a white selection to a blue region.
This is how it looks for me when selected (the darn spam filter won't let me link the urls so you have to copy/paste) :
musikhuset.org/~peder/Ardour-Splice1-small.jpg

After right clicking on it and converting to r-i-p :
musikhuset.org/~peder/Ardour-Splice3-small.jpg

After hitting the Del button on the keyboard:
musikhuset.org/~peder/Ardour-Splice4-small.jpg

Other than that there's nothing I can think about to help you further, unfortunately.
You might try to rename your .ardour2 directory to get a new set of default settings in case you've changed them somehow.

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

Yep, when I select the region it turns white. When I convert to region in-place, it stays the that same white. And when I hit the delete key, the white selection box goes away but the audio remains the same.

Now, when I try and hit ardour, I get another error, though all I've done is reboot my system since the last time I've used it. I get:

Ardour could not start JACK

There are several possible reasons:

1) You requested audio parameters that are not supported..
2) JACK is running as another user.

Please consider the possibilities, and perhaps try different parameters.

I don't know if that is an ardour error or a system error. Maybe both? Because audacity still plays back audio fine.
Any ways, I hope we can get this cleared up soon.

Also, could you tell me how to install the latest ardour release that is available for download on the main site? I'm currently using what I downloaded from the repositories via command line. Might that make a difference?

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Hmm, your setup seems weird. According to your output Ardour/GTK 2.8 (built using 4918 and GCC version 4.4.0 20090328 (Red Hat 4.4.0-0.30)) seems to indicate you have an Ardour built for RedHat/Fedora but then you have Unable to locate theme engine in module_path: "ubuntulooks that seems to indicate you're running Ubuntu. You also have errors regarding 'nm' and 'gt'
Now, in theory, you can take a package from one distro and install on another but you are opening up a fairly large can of worms. I wouldn't be surprised if that's got something to do with your problems.

I guess the Jack errors are due to something else locking the sound card when you start Ardour. Make sure you don't have Audacity running, or a Youtube clip playing (or even active) or something else that plays through your sound card.
The "normal" thing is to first launch Jack (usually through QJackCtl) and then Ardour, but there's nothing wrong with having Ardour launch it.

I'm not sure if compiling Ardour would help, since I didn't have any problem (after switching to en_US) with 2.8 but if you indeed have cross-distro installed it compiling a fresh Ardour that is true-distro might fix things.

If you are running Ubuntu you should be able ro run apt-get build-dep ardour to get the packages needed for compiling, but do check this as well (ardour.org/building). Then download the tarball, and run tar -xjf ardour-2.8.1.tar.bz2 && cd ardour-2.8.1 && sudo mkdir /opt/ardour-2.8.1 && scons PREFIX=/opt/ardour-2.8.1 VST=0 && sudo scons install Now you should have Ardour installed as /opt/ardour-2.8.1/bin/ardour2. If you want you can create a link in /usr/local and your system should use that as the default: cd /usr/local/bin ; sudo ln -s /opt/ardour-2.8.1/bin/ardour2 .

As an other solution you might want to consider installing another distro, like AVLinux (bandshed.net/AVLinux.html). That has 2.8 precompiled and working (AFAIK). The 2r2 release with 2.8.1 should be rather imminent.

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

You're correct. I'm running the bleeding edge Fedora 11. Also, I'm testing various themes designed for ubuntu on it. Would that have anything at all to do with it? Also, I figured out the audio jack problem. Fedora had locked the jack because it was using it for system sounds, ie. when I close/open/minimize windows, login/logout, switch user, click buttons etc. I just had to go into setting and disable all that (I've no idea how it got enabled in the first place, since ardour was working fine for a while).
But now I've got another audio bug that I think I've traced down to Fedora's refusal to use any non open source packages. I really don't want to go hunting down all the codecs for sound and audio right now, so I'll take your advice and use a different distro of linux for my audio restoration/enhancing work. AVLinux looks good. I think I might actually try Ubuntu Studio though, as I have some experience with ubuntu and it's pretty solid, though not quite as stable as I would like.
I'll get back here once I install a new distro, and maybe that'll fix it.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

The themes shouldn't affect Ardour, but then again the language shouldn't either, go figure...

AVLinux is based on Debian (as is Ubuntu) so any previous experience should be applicable.
From what I hear there are problems with Ubuntu Studio, at least regarding real time and the 9.04 release, so I'd advice trying AV first (possibly awaiting the 2r2 release).

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

Ok, I have the 8.04.1 disk, not the 9.04. So I'll give that a try first since I already have it. If it doesn't work, I'll try AVlinux.

rozea
User offline. Last seen 16 weeks 5 days ago. Offline
Joined: 2008-09-23
Posts:

I recommend to add the 64studio repo's to your hardy installation, and install the 64studio RT kernel and up to date audio packages

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

@rozea what's the 64studio repo url?

ichwar
User offline. Last seen 4 years 35 weeks ago. Offline
Joined: 2009-07-09
Posts:

@peder AV linux seems to start loading fine when I try and install it, but then my monitor turns blank and gives me a "Signal out of range" message. Any suggestions on how to fix this???

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Do you get the error message during install or during the subsequent boot? Have you tried pressing a key to see if it comes alive?

If it has installed and rebooted and it happened during that reboot, try holding down <Ctrl> and <Alt> and press <F2> , if you see the login prompt there's something wrong with the monitor/GFX settings.

Do you have an old monitor or a flat screen? That error message is usually due to the refresh rate being set too high for the monitor or if the graphics card driver doesn't work with your card.
If you have a built-in card as well as a slot-in you could try connecting the monitor to the other card in case it has selected the wrong one.

You need to be much more specific about the problem and your hardware for anyone to be able to help you.