Stereo track and AU plugin

4 replies [Last post]
RogerJoensson
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2009-08-09
Posts:

Hi,

Most of my AU plugins does not work on stereo tracks in Ardour.

I can not imagine working without a good EQ (such as Eqium by Elemental Audio, now bought up sold under a new name). When trying Ardour to load a plugin on a stereo track Ardour refuse loading the plugin and returns:
"You attempted to add a plugin (Eqium). The plugin has 1 inputs but the at the insertion point, there are 2 active signal streams." ...

Splitting an acoustical A-B or X/Y recording in to two mono tracks and doing the EQ twice is not a good option for me. The plugin needs to be identical on both channels when setting up too.

All editors I tried, capable of using AU-plugins, handles this plug-in without problems on both mono and stereo tracks. Is there anyway go get this working in Ardour? Is it a known problem?

paul
paul's picture
User offline. Last seen 2 hours 13 min ago. Offline
Joined: 2006-03-16
Posts:

You apparently don't have stereo tracks - Ardour is telling you that the plugin would only receive a single input. It would be vastly easier to tackle this on IRC (#ardour-osx) but be patient with the timezones and people being there to assist. I'm there most of the day, US Eastern time.

AU I/O configuration is quite complex and its possible that Ardour has some issues with the way this particular plugin reports what it is capable of. I'd like to get it fixed.

RogerJoensson
User offline. Last seen 1 year 2 weeks ago. Offline
Joined: 2009-08-09
Posts:

The track must be stereo(?). I can see that there are two graphs inside the track, twin VUmeters beside the fader and I can hear that it is stereo, the master VU-meters indicates too that it is receiving stereo information. I can not add the Eqium plugin to the master fader either.

I can add the STTool (stereo wideness/phase manipulation/meter, by flux) and any of the apple AU plugins.
But the EQ plugins (about the only plugins I use and rely on), like Eqium and Trackplug (from Wavearts) fails with the message:
"You attempted to add a plugin (Eqium). The plugin has 1 inputs but the at the insertion point, there are 2 active signal streams. ..."

I will se what I can do about IRC, haven't used it before...

seablade
User offline. Last seen 11 hours 53 min ago. Offline
Joined: 2007-01-22
Posts:

Paul you misred what he wrote;) It is the other way around, the plugin has a single input, but there are two active streams(Stereo track).

To the OP, in 2.8.2 IIRC there is a link in the Help menu to "Chat". This will open up your web browser to the #ardour-osx chatroom, where you can chat with Paul(If he is around).

Seablade

paul
paul's picture
User offline. Last seen 2 hours 13 min ago. Offline
Joined: 2006-03-16
Posts:

Sorry I missed you on IRC. Bad time of day for me, often.

It would appear that this plugin probably has 1 input and 2 outputs. That means that we can't handle the case of 2in/2out tracks by just replicating "hidden instances" of the plugin, as we would if it had 1 input and 1 output.

Lets talk more on IRC.