...Get to listen to a track that is in recording mode?

6 replies [Last post]
GodLikeCreature
GodLikeCreature's picture
User offline. Last seen 3 years 38 weeks ago. Offline
Joined: 2009-01-26
Posts:

Hey!

I am having this little issue that I want to punch in on a track, but can´t hear the track sound before the punch. Is that possible? It is a very common feature on other DAWs, so I think it´s probably just me being blind about finding the right option to enable.

Thanks in advance

lowen
User offline. Last seen 43 weeks 1 hour ago. Offline
Joined: 2009-07-30
Posts:

For what it's worth, I've been doing punchin-out for a while with Ardour, and haven't had any issues with hearing the pre and post punch audio, once I learned to position the punch in and punch out markers (easiest way I found: go to range selection mode, select the punch range, then go to transport, punch, and turn the range into a punch range), and then select the punch in and/or punch out buttons (which are enable toggles, not the actual punch action).

Have found, however, that the display of the punched in audio during the punch is in the wrong place, displaying at the start of the track instead of at the punch point (AV Linux 2.0r2 Ardour 2.8.2) but haven't filed a bug report for it yet (wanting to get more information for a better bug report, and a screen capture of the behavior).

If you describe in more detail how you're using the punch someone might be able to figure out what's happening.

Pablo Fernández
User offline. Last seen 50 weeks 6 days ago. Offline
Joined: 2007-02-20
Posts:

Hi Godlikecreature,
I think you need Auto Input enabled (button or Transport menu) to listen to an armed track while ardour is just playing, like in your case before the punch. I would check that first.

Hi Iowen,
I select the range with the range tool, as you do, but then right click, and 'set punch from selection'. Then I push 'punch in' and 'punch out' buttons. You can enable punch in and out from the transport menu too, it's equivalent. I think you miss actually setting the punch range. It seems that if there is not a punch range selected the "punch range" results to be the whole session but I don't think this is a bug.

Regards, Pablo.

dsyd
User offline. Last seen 4 years 31 weeks ago. Offline
Joined: 2009-05-03
Posts:

By the way, instead of clicking on the range selection tool and then dragging, and then turning the selection into a punch, it may be more convenient to hold down the CTRL key while dragging along the "Loop/Punch Ranges" area at the top.

Also, if you use punch a lot, you could set a keybinding for the "Punch In/Out" menu item under the "Transport" menu so then you only have to press a single key and CTRL+drag to set up and enable the punch.

stratojaune
User offline. Last seen 15 hours 19 min ago. Offline
Joined: 2008-10-19
Posts:

Hi,

you can also set the punches points with Ctrl+L, then click the punches buttons, and roll.

If there's an hard punch and you need to do it several times, maybe nice to set a marker (Ctrl+L too), say 1 measure before punch in.

GodLikeCreature
GodLikeCreature's picture
User offline. Last seen 3 years 38 weeks ago. Offline
Joined: 2009-01-26
Posts:

Hey, thanks a lot for your comments and guidance!

I will check later today, but I am pretty sure Auto Input is disabled in my case, so that could be it.

Thanks again!

GodLikeCreature
GodLikeCreature's picture
User offline. Last seen 3 years 38 weeks ago. Offline
Joined: 2009-01-26
Posts:

...And yes, it worked!

You were completely right, and so I was... in that it was an easy one I had missed! ;-)

Thanks!!!