ardour skips while recording

4 replies [Last post]
Acratus
User offline. Last seen 4 years 28 weeks ago. Offline
Joined: 2007-03-08
Posts:

i'm using a Shure x2u USB connection. it records but after you play it back you notice skips in the recording. can anyone help? i've gone to other forums and read some feed back but the microphone i use is pretty good.

please help.

Acratus

tbonedude
User offline. Last seen 1 year 51 weeks ago. Offline
Joined: 2008-11-08
Posts:

Are the skips lots of xruns? (you can tell if you see a bunch of markers above your recording in some places, and they say xrun). If this is the case, set your latency to a higher setting in jack. This is typical in USB interfaces, to have to use higher latencey settings. Also, are you using the OS X version or linux? And if you're running in linux, are you using a real-time kernel?

stephenthemartyr
User offline. Last seen 2 years 36 weeks ago. Offline
Joined: 2011-06-21
Posts:

hey i am actually having the same problem with x-runs,i dont have a usb mic though but i do have the real time kernel.How could i get less x-runs?And how do I change the latency in jack?Thanks so much!

allank
allank's picture
User offline. Last seen 5 weeks 4 days ago. Offline
Joined: 2006-12-07
Posts:

@stephen

a) set your number of buffers to at least 3 (default I think is 2)
b) set your period to a higher amount
c) failing that change to a lower bit rate (if you are using 88.2 or 96 then drop to 48 of 44.1 Khz)

I you are using qjackctl then this is in the settings menu.. (soory at work on a windows machine so can't give an exact pointer but it's pretty easy to find...

If you are doing this from a commandline you will need settings something like the line below

jackd -R -d alsa -r 48000 -p128 -n3

(the "-R" specifies realtime operation
the -p and -n set your period and number of buffers the -r specifies the bit rate.. )

If you are using ardour to fire up jack it is the period and buffer settings.

gradually keep pushing these up until you stop getting xruns.

Other basic tips
Use a low resource intensive window manager (e.g. don't use KDE or Gnome - fluxbox, openbox e.t.c.. are excellent but require configuration - xfce and lxde are a good compromise ) .. If you are using a lower power cpu and less memory turn off unecssary bling..

Finally if all this fails.. get a better audio interface .. (2nd hand m-audio delta units can still be had on ebay pretty cheap and are highly recommended if you have a PCI bus, check out ffado.org for firewire.. not too sure about faster USB devices though)

paul
paul's picture
User offline. Last seen 6 hours 51 min ago. Offline
Joined: 2006-03-16
Posts:

@allank: all current versions of JACK do -R by default now. -r turns it off.