Ardour 2.8 & JAMin Export

32 replies [Last post]
kees
User offline. Last seen 2 years 49 weeks ago. Offline
Joined: 2010-01-07
Posts:

A quick update from the comments I got from Jamin developers and some tests I've done: it seems that the main cause of the problem was my Jack setting having less than 256 frames/period.

"The natural FFT window size for the signal processing component of jamin is 256 frames. If JACK is running with a smaller window size, then jamin needs to queue the processing to a lower-priority real-time thread so it has enough time to perform the FFT (which is computationally expensive) while still meeting the JACK audio processing deadlines." according to Jamin developer Jack O'Quin.

So I've tried several tests with 256 frames/period and I did not have the problem. Also, exporting with Jamin started with the -t flag seemed to solve the problem. A quick patch from Jack O'Quin running as if started with the -t flag in export (Jack freewheeling) mode and without otherwise, did not yet succeed, but that seems to be the direction of the definitive patch.

So, my problem seems to disappear when running with larger frames/period.

@mendred: could you try that too ? I have no 64bit machine to compile on, and would not advise to use my patch anyway, unless you have no other option. Compiling Jamin and installing yourself is really easy on Ubuntu. Besides that, what you describe, is exactly what I experience.

To quote Jamin developer Jan Depner: "There seems to be a lot of misunderstanding about when you need low latency. If you're not running live or trying to record new tracks while using software monitoring you don't really need low latency. JAMin wasn't designed for live work and it wasn't designed to be a plugin for a single track. It was designed for stereo audio mastering. The amount of processing involved is significant so it probably won't be able to keep up with small period sizes. Just kick it up to 2048 and
relax ;-) "

mendred
mendred's picture
User offline. Last seen 3 days 29 min ago. Offline
Joined: 2010-01-16
Posts:

@kees, starting jamin with as "jamin -t" works brilliantly :). Thanks...I am trying to setup jack when my machine starts, so really don't want to keep switching frames (currently using 64). to movw from low to high...I tried the -t both in regular mode (when i am playing ardour tracks...) and during export..and so far no issues..so will continue to use this..

As for Jan's comment..well i guess sometimes. we find new uses for things which they may not have been designed for...but nevertheless work very well..it seemed very logical to me use jamin as an insert on master...but I guess it all depends on your point of view.

Anyway this definitely works...so thanks again!

EDIT: Ah i see the downside to -t in realtime..a much larger no. of xruns...especially when u have a large no. of tracks..i guess then as u mention either use -t for export only purposes or use 256 frames...