Exporting no sound

18 replies [Last post]
jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Hello,

I'm new here. I use Ardour for a couple of months now, and it is a pretty nice program.

The problem I'm having is that my exports doesn't contain sound, which is a bit of a drawback, considering the fact that the sole purpose of using Ardour is to create music :)

Anyway I tried different types of exports (wav, aiff) but that didn't work. I have already set my exports sample rate to 44.1kHz and my sample format to 16 bit and I tried to set the channels from stereo to mono. This didn't work. After that I tried selecting all the tracks manually (using the button "specific tracks") and create an export after that, but that didn't work either.

The reason for exporting is that I want to create mp3's of my files, so that I can upload them :)

Some computer information:
I'm using Ubuntu 9.04, with the real-time kernel on a laptop with a 1.73 GhZ processor and 1 Gb of RAM.

I hope someone can help me, or point me in a right direction. I already tried Googling, but I wont stop with that :)

Thanks in advance.

Jackuss

Jamie
User offline. Last seen 4 years 25 weeks ago. Offline
Joined: 2009-10-02
Posts:

I'm not in front of my computer now but I believe in the export window you need to check "left" and/or "right in the "Output" window on the master track or you can specify tracks. Search the forum here, I'm sure this has been asked before.

Jamie

seablade
User offline. Last seen 9 hours 39 min ago. Offline
Joined: 2007-01-22
Posts:

In the export dialog, on the right hand side, you need to make sure that your Master_Out L is checked in the left hand column and the Master_Out R is checked on the Right hand column.

The below link is still very much a work in progress and should be considered as such, but it hsould give you an idea...

http://ardour.stackingdwarves.net/ardour-en/8-ARDOUR/289-ARDOUR/290-ARDOUR/18-ARDOUR.html

Seablade

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Thanks for the replies Jamie and Seablade.

Unfortunatly I already tried selecting both the Master Outputs, All Tracks without the Master Outputs AND all tracks with the Master Outputs, nothing worked for me.

The Wav file I exported should contain some information, since it is about 33 Mb big, but I don't hear a thing. What else can this be?

Thanks in advance again.

Jackuss

Erdie
Erdie's picture
User offline. Last seen 1 day 32 min ago. Offline
Joined: 2006-03-27
Posts:

Does the levelmeter on the masterbus move up an down while exporting?

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Hello Erdie,
Thanks for replying. When Ardour is exporting, I can't see anything moving (like a program 'freeze', I don't see a progressbar or something like that). Is there another way I can see something happening?

Thanks again for your reply and I must say... Nice picture :)

Erdie
Erdie's picture
User offline. Last seen 1 day 32 min ago. Offline
Joined: 2006-03-27
Posts:

Hi Jackuss,

thank you, the picture is my son, a few years ago in the bathtub. His name is Linus ;)

If nothing is moving, the export process does not start at all. Normaly you should see a progress bar and the VU display on certain tracks and buses are moving faster that in the regular play mode. Thats strange .. does it really hang or are you able to cancle the process?

-Erdie

seablade
User offline. Last seen 9 hours 39 min ago. Offline
Joined: 2007-01-22
Posts:

What version of Ardour are you using?

Seablade

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

@Erdie

I don't see anything moving, I can move the different windows who are in Ardour, but I can't cancel the operation.

@ Seablade

I use version 2.7.1 (this is the one who was in the repositories of Ubuntu 9.04). I also tried version 2.8.2, but that also didn't help :(

seablade
User offline. Last seen 9 hours 39 min ago. Offline
Joined: 2007-01-22
Posts:

Hmm, was this a package installed from Ubuntu's repos? If so you might want to try the ones at getdeb.net instead and see if that addresses the issue.

Seablade

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

@ Seablade:
The first package (2.7.1) was from the Ubuntu repos. The 2.8.2 I got from getdeb.net (great website btw :) ) Both didn't export correctly.

Anyone has got another idea what this can be? maybe my computer is too slow?

seablade
User offline. Last seen 9 hours 39 min ago. Offline
Joined: 2007-01-22
Posts:

Hmm the only other thing i could think of is if your version of Jack is having a problem. You are hearing the playback in Ardour right before you export right?

Seablade

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Seablade, thanks a lot for your time.

I tried to de-install and then re-install JACK, but this didn't help. I hear my audio when I play it in Ardour, but when I export it, I don't hear anything (other than my harddisk trying to take-off :) )

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Here I am again.

When I set Audacity to JACK and (by accident) opened my exported wav file in it, I could play the song (in Audacity). When I created an mp3 out of it, I couldn't play it in Exaile. Very strange, but I think it is no Ardour problem anymore, but a JACK --> ALSA problem, or something.

Although I don't think it is an Ardour problem anymore, maybe someone here can point me to some explanation on how this can happen?

Thanks again everyone.

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Well, I find some sort of workaround (or maybe a definitive solution) for this. When I don't start JACK (or terminate it) and change the settings of the "Audio Setup" to "Dummy", I can hear music in my export :)

This does mean that I must restart Ardour everytime when I want to export something. Isn't there anything else I can do?

Again everyone, thanks a lot for your help, i really appreciate it

Matt Francomb
Matt Francomb's picture
User offline. Last seen 11 hours 3 min ago. Offline
Joined: 2006-09-12
Posts:

This is beginning to sound to me as though there is not in fact any problem.
I don't know all the applications that you mention, but if you have Jack running
and then try to use an audio application that isn't aware of jack, you won't get any
audio output because the interface is already in use. You've demonstrated
that the export actually does produce output, but that your problem is that
you can't hear it when you try to play it in a different app, unless I've
misunderstood.

So, to summarise, to hear the exported audio, you either have to stop
jack before you try to play it, or use a jack-aware application to play it.

alex stone
User offline. Last seen 3 years 17 weeks ago. Offline
Joined: 2008-03-02
Posts:

I'd share Matt's view here, and suggest you make sure your playback app is in fact jack capable.

I'm on Gentoo, with fluxbox here, and 2 jack capable apps that spring to mind in my custom built environment include Amarok, and Rezound. These will both use Jack as the output option. (Rezound is my default.)

Not trying to teach you to suck eggs here, but a bit of research into jack, and components that, when added, enhance the jack capable setup, could prove fruitful. I'll also add i use native 64bit, and run a dedicated music rig that doesn't include a big desktop, pulseaudio, or "domestic entertainment" applications. (I use a text web browser for most of my online research, as a quick example.

However, some things remain common across distros.

1.) The limits described in the posts above, are related to using PAM in your setup. (For other options, rtirq, or rlimits provide this capability.)
This is set in /etc/security/limits.conf for most distros.
Here's my particular /etc/security/limits.conf setup as an example

@audio - rtprio 99
@audio - memlock 2911812 (I have 4gb of ram installed, so i set this to run a large audio setup, but leave enough ram for the system to run in stable fashion as well.)
@audio - nice -19
@audio - nofile 8192

2.) The .asoundrc file is yours to setup as you want, and is usually housed in your home directory. In this file you can set all sorts of card, and setup related parameters. Do a search on the interlink for examples, but one in particular, in my experience, does a good job of helping most apps be "jack compliant". This is the JACK plugin, and can be found in the alsa-plugins package. Install this, and then browse for .asoundrc setup in the alsa wiki, with the focus on using the jack plugin.

Here's my .asoundrc file as an example:

# pcm type jack
pcm.!default {
type plug
slave { pcm "jack" }
}
pcm.jack {
type jack
playback_ports {
0 alsa_pcm:playback_1
1 alsa_pcm:playback_2
2 alsa_pcm:playback_3
3 alsa_pcm:playback_4
4 alsa_pcm:playback_5
5 alsa_pcm:playback_6
6 alsa_pcm:playback_7
7 alsa_pcm:playback_8
8 alsa_pcm:playback_9
9 alsa_pcm:playback_10
}
capture_ports {
0 alsa_pcm:capture_1
1 alsa_pcm:capture_2
2 alsa_pcm:capture_3
3 alsa_pcm:capture_4
4 alsa_pcm:capture_5
5 alsa_pcm:capture_6
6 alsa_pcm:capture_7
7 alsa_pcm:capture_8
8 alsa_pcm:capture_9
9 alsa_pcm:capture_10
10 alsa_pcm:capture_11
11 alsa_pcm:capture_12
}
}

ctl.mixer0 {
type hw
card 0
}

This is for a Delta 44 card (ice1712 alsa module), and routes any alsa based apps that run, through the jack plugin. A highly useful addition, and it takes care of most audio challenges by default.

3.) Check the preferences for any app you choose to use. Most, with the exception of audacity it seems, have a jack capable audio option (as a selectable default output device), at least in up to date versions. Late versions of Rezound, in my humble experience, work well, and it is my default audio editor for good reason, as you not only have a plethora of editing, and sound shaping options, but also solid playback, and a variety of sound conversion components, including re-sample. Check your distro for versions, and ask in the distro based audio forum for distro based options, if the build requires some additional dependencies, as distros vary in their requirements.

2 roubles worth,

Alex.

jrigg
User offline. Last seen 2 weeks 4 days ago. Offline
Joined: 2007-01-04
Posts:

This sounds like the same problem I've been getting with Ardour 2.8.2 and 2.8.3 (on Debian 5.0.3 amd64). The export dialog window disappears as soon as the export is started. The export file is created but contains no audio. The workaround is to try again. It will say the file exists, so overwrite it. This usually works on the second attempt, but sometimes takes three or four attempts. When you see the progress bar moving, it's working.

I've been too busy to investigate the cause of this, but at least it's possible to work around it in the meantime.

jackuss
jackuss's picture
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2009-10-09
Posts:

Hello again.

First of all, I want to thank everybody who helped and replied here.

I can say that the problem is more or less solved. I downloaded the newest version of UbuntuStudio and installed it. This solved the problem for me.

Everyone thanks again and good luck creating music :)

Jackuss