Ardour could not start JACK

8 replies [Last post]
skarychinezeguie
User offline. Last seen 4 years 28 weeks ago. Offline
Joined: 2009-10-10
Posts:

There are several possible reasons:

1) You requested audio parameters that are not supported..
2) JACK is running as another user.

Please consider the possibilities, and perhaps try different parameters.

-----------------------------------------------------

I am totally new to linux. i am using ubuntu. I installed ardour through the synaptic package manager. Ran it from the applications toolbar, added a name to the new session field and hit "new" and got this error. I also opened up the jack control and hit start and got this

-----------------------------------------------------

02:43:38.522 Patchbay deactivated.
02:43:39.544 Statistics reset.
02:43:39.617 ALSA connection graph change.
02:43:40.751 ALSA connection change.
02:44:33.078 Startup script...
02:44:33.081 artsshell -q terminate
sh: artsshell: not found
02:44:33.483 Startup script terminated with exit status=32512.
02:44:33.484 JACK is starting...
02:44:33.484 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p1024 -n2
no message buffer overruns
02:44:33.498 JACK was started with PID=13999.
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1210673472, from thread -1210673472] (1: Operation not permitted)
cannot create engine
02:44:33.571 JACK was stopped successfully.
02:44:33.572 Post-shutdown script...
02:44:33.573 killall jackd
jackd: no process killed
02:44:33.980 Post-shutdown script terminated with exit status=256.
02:44:35.619 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

---------------------------------------------------------

i normally work with loops but also create quite a bit of original stuff using acid/reason rewired. I read this is about as pro as it gets with patch bays, and i'd like to get it working. I'm a power user for windows and i've already dove in X a bit but got a lot of ground to make up. Any help with getting this running would be appreciated. depending on whether or not i end up using it, i may make a donation, or at the very least put some banner ads on my websites.

skarychinezeguie
User offline. Last seen 4 years 28 weeks ago. Offline
Joined: 2009-10-10
Posts:

i just checked out LMMS. it's the fruity loops of linux. not what i was looking for, but it will get used for sure. can it be patched to work with ardour?

roaldz
User offline. Last seen 1 year 40 weeks ago. Offline
Joined: 2008-11-12
Posts:

search ubuntuforums for setting up ubuntu for realtime audio performance. Search terms:

/etc/security/limits.conf
realtime kernel (linux-rt)
alsa

paul
paul's picture
User offline. Last seen 5 hours 38 min ago. Offline
Joined: 2006-03-16
Posts:

lmms does not appear to work very reliably with JACK, which is how you would have to use it to connect it to other applications. that doesn't mean it doesn't work at all, but at the very least you tend to need large JACK latency settings (frames/period of 2048 or so).

the C.L.A.
the C.L.A.'s picture
User offline. Last seen 2 weeks 4 days ago. Offline
Joined: 2006-12-03
Posts:

If I remember correctly I saw somebody writing that the problems with LMMS when using JACK would go away if you compile LMMS without VST support. I haven't tested it myself, but it could be worth a try.

skarychinezeguie
User offline. Last seen 4 years 28 weeks ago. Offline
Joined: 2009-10-10
Posts:

cool. well. could you describe how to compile it without VST support while i'm trying to figure out the suggestion from roaldz? it appears from what i'm reading i might have to recompile the kernel or something because ubuntu isn't normally set up for audio editing/recording compared to other distros. I have compiled stuff in windows visual studio, but have very little DOS or terminal experience.

BTW does anyone know if the newest ubuntu due out will contain these audio features?

nickmurtagh
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2007-01-22
Posts:

What you need is a kernel with the realtime patches. You should be able to install this on ordinary Ubuntu.

Open a terminal (Applications > Accessories > Terminal)

Type "sudo apt-get install linux-rt"

Enter your own password and press Enter

This will install the new kernel. You will then need to reboot and choose the realtime kernel from GRUB (the bootloader).

The realtime kernel is probably not as stable as the normal kernel. If it doesn't work for you, try using the normal kernel with a larger frames/period setting in jack.

nickmurtagh
User offline. Last seen 1 year 15 weeks ago. Offline
Joined: 2007-01-22
Posts:

If you are looking for a linux distribution optimised for music, try 64studio.

http://www.64studio.com/

The current release is based on Debian and then next release will be based on Ubuntu Hardy LTS.

Pablo Fernández
User offline. Last seen 50 weeks 6 days ago. Offline
Joined: 2007-02-20
Posts:

Even if the ubuntu generic kernel is not optimised for audio work, I think one newcomer to ubuntu linux may want, first, have jack running with the realtime option so that they can try ardour and other jack-aware applications, and then, if their system is not good enough for their needs, try to optimise it, either by getting better hardware, and/or by installing a linux-rt kernel, trying specialised distros, further tweaking their system... If they want a superb linux audio system from the very beginning they should know that it is going to be a steep slope in the very first steps (just what most users who chose ubuntu as their first Linux tried to avoid).

So going back to the original issue... If you turn off the realtime option, jack could start (at least you won't have the realtime scheduling error) but the performance will be very poor. To have jack running with the realtime option you need to: (see http://jackaudio.org/faq)

1) Be in the 'audio' group. Check it by typing 'groups' in a terminal. If there is no 'audio', add yourself (you as a user) to this group: 'sudo adduser yourloginname audio'
2) Give members of the audio group realtime priority and memlock unlimited (or high enough). From a terminal: 'gksudo gedit /etc/security/limits.conf' . Add at the end of the file:

@audio - rtprio 99 #Some people suggest 95 or 90.
@audio - memlock unlimited #Some people suggest 50% or 80% of your memory, in kb. For example I have 'memlock 1500000' in a box where I have 2GB of RAM

These changes need a reboot to take effect. This should be enough to start with ardour even if the performance can be improved a lot with further tweaks. You need these lines in the limits.conf even if you install a linux-rt kernel.

A great resource for "linux musicians": www.linuxmusicians.com

Cheers! Pablo