Seemingly random loss of signal to master track when plugin activated

5 replies [Last post]
tedde
User offline. Last seen 4 years 15 weeks ago. Offline
Joined: 2009-11-06
Posts:

It seems that sometimes I will lose all signal the master track when I have some plugins activated. It also appears that certain tracks with plugins activated show no signal during playback. If I deactivate the plugins on those tracks, the sound comes back.

Oddly enough, I can reactivate plugins one-by-one and they will work okay, although not always. Another thing I have done that had good outcomes is to stop playback, go forward to the end of the song, go back to the start, then play the song (though this does not always work).

I am only using CAP plugins and gVerb.

At this point, I can get signal back with all tracks except the one using gVerb.

Any ideas as to what the underlying issue is and what steps I can take to get signal back?

paul
paul's picture
User offline. Last seen 15 hours 36 min ago. Offline
Joined: 2006-03-16
Posts:

Its a bug in at least one of the CAPS plugins that causes it to overwrite memory in Ardour, somewhat randomly. There may be a newer version of the CAPS plugin set that has fixed this, but I am not sure.

lowen
User offline. Last seen 42 weeks 5 days ago. Offline
Joined: 2009-07-30
Posts:

The version in the Ardour 2.8.3 OS X build is 0.3.0 if I remember correctly. This version also apparently creates issues with Mixbus, but in that instance all four Mixbusses lose signal. Restarting a random number of times seems to work; when it works it stays working until another session is loaded (that's assuming that I'm hitting the same problem; rather serendipitous that this subject should cross the forum the same day that I reported the issue occurring in Mixbus). This happens whether I've manually copied the plugins over into the Mixbus.app/Contents/Plugins folder or installed the standalone CAPS .dmg that is available (but hidden) on the ardour.org site. Both are CAPS 0.3.0

In Tim's changelog for the CAPS suite, I find the following item under version 0.4.0's section:

* actual activate() call is deferred to first run() after activate()
in order to prevent inadvertent parameter smoothing sweeps during the first
block of audio after activation, this should fix all problems with ardour
(except those caused by denormals or invalid audio input)

The current version is 0.4.3 and apparently has some 'untested' Mac OS X build bits. Gonna try a build....

[EDIT: Built the current 0.4.3 version on OS X 10.6. Had fun with the build bits; LADSPA stuff is pretty easy, but Snow Leopard stuff isn't. Short form kludge: use the configure.py provided, then edit defines.make to add '-arch i386' to both _CFLAGS and _LDFLAGS. Built fine; did a manual install of caps.so into /Library/Audio/Plug-Ins/LADSPA and caps.rdf into /Library/Audio/Plug-Ins/LADSPA/rdf and started Mixbus on some sessions. The configure.py needs modifying to detect Snow Leopard and adjust for -arch i386 accordingly (or Ardour/Mixbus won't load it, since 64-bit LADSPA plugins aren't currently supported). Problem gone after opening several sessions successfully; previously, it wouldn't open more than two or three in a row without the 'clicks' and no audio to either the four mixbusses or the master.

So, in short: Build 0.4.3 CAPS; it fixed this problem for me on Mixbus.]

tedde
User offline. Last seen 4 years 15 weeks ago. Offline
Joined: 2009-11-06
Posts:

I am running OS X 10.5, and managed to compile CAPS 0.4.3 with the additional step of adding '-arch i386' to the 'strip' call in the Makefile, but that did not see to solve the loss of signal issue for me.

This does raise another question for me which perhaps should be a separate forum topic, but I will raise it here first:

Is there a list of field-tested LADSPA plug-ins recommended for Ardour?

I have looked at the plug-ins page on the site and noticed some listed there, but I'm assuming those are the cream of the crop and there are bound to be others that people like which work well.

I am specifically looking for recommendations as to good band EQ (preferably a 10-band EQ) and compression.

lowen
User offline. Last seen 42 weeks 5 days ago. Offline
Joined: 2009-07-30
Posts:

You may have to remove the CAPS plugins from the Ardour.app/Contents/Plugins folder for Ardour to pick up the new plugin; make a backup of your Plugins folder first, of course. In the Mixbus case, there aren't any plugins in Mixbus.app/Contents/Plugins by default, so putting them in the global location works.

Did I mention making a backup of your Plugins before removing any? To get Finder to go there you use "Show Package Contents"; please be careful, and make sure you have a backup of the whole Ardour.app folder.....

I really like the sound of the CAPS plugins; use them all the time on Linux with Ardour. Only using OS X for Mixbus, since a Linux version of Mixbus isn't available yet. When one is available..... :-)

Paul may update the OS X install with reliable CAPS plugins at some point; don't know.

ahmed1211
User offline. Last seen 4 years 23 weeks ago. Offline
Joined: 2009-11-07
Posts:

You may have to remove the CAPS plugins from the Ardour.app/Contents/Plugins folder for Ardour to pick up the new
شات
شات صوتي