Mute button does not work from main window

22 replies [Last post]
rpatros
rpatros's picture
User offline. Last seen 1 year 10 weeks ago. Offline
Joined: 2008-05-30
Posts:

Hello,

I am running Ardour 2.8.7 and it seem that the "m" for mute button on the tracks does not work. Although it does work from the mixer window. The "s" for solo works fine. Might be a code issue there. Has anyone seen this before. I doubt it's a setting.

Rony P.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Right-click on the "m" and make sure everyting is checked.

seablade
User offline. Last seen 12 hours 18 min ago. Offline
Joined: 2007-01-22
Posts:

It is exactly a setting actually, and I bet you are running Ubuntu aren't you? I think some other distros did this but Ubuntu seems to be the most common report for obvious reasons.

Seablade

AK65
User offline. Last seen 52 weeks 12 hours ago. Offline
Joined: 2006-12-15
Posts:

Hi

I also had this problem. It seems to be an Ubuntu Studio problem.

I have reported this as an Ubuntu Studio bug and it is receiving action.

https://bugs.launchpad.net/ubuntustudio/+bug/581786

The fix is mentioned in this thread:

http://ardour.org/node/3559

Hopefully, the update will come from Ubuntu to fix the problem. And, it should be fixed in the next release of Ubuntu Studio...

Hope this helps!

AK

rpatros
rpatros's picture
User offline. Last seen 1 year 10 weeks ago. Offline
Joined: 2008-05-30
Posts:

Guys....I am running Ubuntu 10.04 I will check the thread by AK65.

Thank you
Rony P.

rpatros
rpatros's picture
User offline. Last seen 1 year 10 weeks ago. Offline
Joined: 2008-05-30
Posts:

@AK65
I implemented the suggested changes to the ardour.rc file in the .ardour2 directory but that did not help:

rony@ubuntu:~/.ardour2$ fgrep mute ardour.rc

rony@ubuntu:~/.ardour2$

I also uninstall ardour using apt-get remove and install the latest SVN version using scons and it still the mute button does not work.
ardour 2.8.8
(built from revision 7167)

I am running Ubuntu 10.04
rony@ubuntu:~/.ardour2$ uname -a
Linux ubuntu 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux

rony@ubuntu:~/.ardour2$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid

Any other suggestion?

Rony P.

rpatros
rpatros's picture
User offline. Last seen 1 year 10 weeks ago. Offline
Joined: 2008-05-30
Posts:

Ok got it done...as suggested by peder, I had to right click on the "m" button and select all the options. Thank you Peder.

Shouldn't this option be enabled by default on the "m" button?

Rony P.

seablade
User offline. Last seen 12 hours 18 min ago. Offline
Joined: 2007-01-22
Posts:

It is enabled by default, except for some reason the Ubuntu Build seems to change this, we have no idea why. It also seems to change this in strange ways that prevent the normal fixes from applying on occasion apparently(Or so we have been told.)

So the end result is, we just tell people to avoid the Ubuntu Builds, they cause us a LOT of headache.

Seablade

DLC11
User offline. Last seen 39 weeks 3 days ago. Offline
Joined: 2008-07-26
Posts:

It isn't just Ubuntu. I have seen the same issue on Fedora 11.

rpatros
rpatros's picture
User offline. Last seen 1 year 10 weeks ago. Offline
Joined: 2008-05-30
Posts:

well it seems that the changes of ardour.rc file under ~/.ardour2 where changes the values for the mute settings from 0 to 1 will only take affect with new sessions.

Existing session will need to be done with right clicking on the "m" and enabling the 4 options on each track.

Rony P.

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

well it seems that the changes of ardour.rc file under ~/.ardour2 where changes the values for the mute settings from 0 to 1 will only take affect with new sessions.

Existing session will need to be done with right clicking on the "m" and enabling the 4 options on each track.

That is correct and can confirm that since it happened to me also before, EVEN on self compiled versions of Ardour!

seablade
User offline. Last seen 12 hours 18 min ago. Offline
Joined: 2007-01-22
Posts:

@joegiampaoli

Yes there was a version of Ardour with a bug that caused this, that was fixed a few versions ago. But why it is continuing to persist in repos is the question I can't answer.

Seablade

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

@ seablade:

Actually it happened to me with current 2.8.7 last time I compiled it, editing my .ardour/ardour.rc file fixed it .
I just had the doubt right now, so I deleted my .ardour2 folder to test again. Started a new session and the ardour.rc file was recreated with "0" values for all the mute sections....

I think this is probably the fault of a compile package in the ubuntu repos... It's just strange some people have this issue and some don't, it doesn't really affect me, I mean just open a file and change a couple of zeros to ones and you're good to go.

But I can see an endless array of posts by new users with the same question.

paul
paul's picture
User offline. Last seen 1 day 4 hours ago. Offline
Joined: 2006-03-16
Posts:

@joegiampoli: see /etc/ardour2/ardour.rc or /etc/ardour2/ardour_system.rc .... it has the file-based initial defaults.

GMaq
GMaq's picture
User offline. Last seen 3 days 10 hours ago. Offline
Joined: 2007-12-11
Posts:

Hi,

For the record this issue also exists on Debian Squeeze/Sid and AV Linux, the Debian pkg-multimedia team is aware of it and working on a patch. To be fair Ubuntu isn't the only one with this particular issue.

@paul

How about a nice Ardour 2.8.8 release to put this misery behind us... ;-b

seablade
User offline. Last seen 12 hours 18 min ago. Offline
Joined: 2007-01-22
Posts:

@GMaq

How about a nice Ardour 2.8.8 release to put this misery behind us... ;-b

THAT one I can answer;) It is because he asked me to test it and I tend to find things broken in very bad ways... So blame me:)

All that being said, I don't think 2.8.7 had this issue, I could look back if people wanted and find the commit from the last version that should have had this issue, as Paul noted, you need to make sure your system wide .conf files are fixed manually or else installing Ardour will likely result in the same behavior as it regenerates the local .conf files from these system files.

Seablade

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

@ paul:
/usr/local/etc/ardour2/ardour_system.rc has the following lines (I had to take out the <> at beginning and end of each line):

Option name="mute-affects-pre-fader" value="yes"/
Option name="mute-affects-post-fader" value="yes"/
Option name="mute-affects-control-outs" value="yes"/
Option name="mute-affects-main-outs" value="yes"/
Option name="solo-latch" value="yes"/

So there it is all enabled, strange.... but recreating my .ardour2 folder in home the ardour.rc file is recreated with these values disabled.

In /usr/local/etc/ardour2/ I have no ardour.rc file, does this matter?

Thanks!

macinnisrr
macinnisrr's picture
User offline. Last seen 4 days 22 hours ago. Offline
Joined: 2008-01-14
Posts:

I can confirm this bug. Of course, it's trivial to fix, which is why I haven't officially reported it on Mantis. Nonetheless, the default rc file in the source has been broken (to the effect that we're talking about) since at least 2.8.5 (maybe even earlier, I can't say because that is when I started building my own binary). For a couple versions, the rc file used true or false instead of 1 or 0, which seemed to not register with Ardour (1 would work, but true would not). 2.8.7 seems to understand 1 or 0, but the rc file that comes with source will not enable all mutes by default.

For Ubuntu users: search this forum for my Dream repository and add it. You'll find an up-to-date version of Ardour which not only fixes this by default, but which also has themes that match Ubuntu.

For anyone building from source: check the ardour.rc file and make sure that all mutes are set to "1" before you build.

DickMacInnis.com

the C.L.A.
the C.L.A.'s picture
User offline. Last seen 2 weeks 3 days ago. Offline
Joined: 2006-12-03
Posts:

@macinnisrr: The bug allready had been reported on mantis some time ago - main report is here: http://tracker.ardour.org/view.php?id=2832

For me this behaviour (~/.ardour2/ardour.rc gets created with wrong settings) still persists with the most recent 2.0-ongoing (rev. 7202) on Arch Linux. Easy to fix by hand, but confusing to new users.

mthed
User offline. Last seen 2 years 28 weeks ago. Offline
Joined: 2010-10-04
Posts:

this bug is SO frustrating. let me add to the ridiculousness. somehow my ardour.rc keeps getting reset to "no, no, no" values on these mute options. how the heck is that happening? everything will work fine for a while, then suddenly it gets reverted. ubuntu really screwed this one up.

seablade
User offline. Last seen 12 hours 18 min ago. Offline
Joined: 2007-01-22
Posts:

@mthed

Should be noted, this bug was fixed some time ago(About 6 months ago from that report), and if you build the most recent version of Ardour you will merely have to move your ~/.ardour2 folder out of the way to let it be recreated and you shouldn't have this problem again.

Seablade

paul
paul's picture
User offline. Last seen 1 day 4 hours ago. Offline
Joined: 2006-03-16
Posts:

@mthed: the only ridiculousness at this point is that anyone should be stuck using a version of Ardour in which this bug is still present.

mthed
User offline. Last seen 2 years 28 weeks ago. Offline
Joined: 2010-10-04
Posts:

oh, i totally know! the ridiculousness is all on ubuntu!