Recovering from the mute bug ...

Although Ardour 2.8.9 no longer suffers from the subtle bug that caused the mute button(s) to no longer work by default, many users of Ardour will not see the situation change until they remove their ~/.ardour2/ardour.rc file. This probably contains default settings for mute like this:

    <Option name="mute-affects-pre-fader" value="yes"/>
    <Option name="mute-affects-post-fader" value="yes"/>
    <Option name="mute-affects-control-outs" value="yes"/>
    <Option name="mute-affects-main-outs" value="yes"/>

If your version of this file has value="no" for those options, you should either edit it by hand (its just a text file) so that it says value="yes" instead or just remove the file entirely. Editing is preferable, but removing the file will not hurt. Note that the following values y,Y,1,yes,Yes,YES are all equivalent to "yes" and similarly n,N,0,no,No,NO are all equivalent to "no".

You should also check the file /etc/ardour2/ardour_system.rc, or a related location if you installed Ardour somewhere non-standard) for the same issue, though it is less likely to be seen there. Do NOT remove this file - if it contains "no" as the settings for these options, you should edit the file.

Here it still remains buggy.

Here it still remains buggy. At first it seemed to work (no changes to rc-files), new project.
Today it didn't work anymore (new project again).

This is my setup:
* ardour 2.8.10 out of revision 7288
* compiled from svn into /usr/local/ardour2
* rm -rf ~/.ardour2/
* Checked /usr/local/ardour2/etc/ardour2/ardour_system.rc. Contains only "yes" for all options mentioned above

Keep up the good work
Nudge

From IRC: < adi > lorenzosu:

From IRC:


< adi > lorenzosu: Don't forget to create a new project if you wanna test it. At least I think so. For existing projects, either edit the save file or change the mute values in the mixer.
< lorenzosu > adi, Great! Works with a new project... so that is the chip I was missing :)