Silent Tracks...

20 replies [Last post]
Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

While using Ardour recently Jack crashed after having two simultaneous sessions open at once.
After closing the sessions I reloaded them and they are now both silent...
The tracks play and there is visual peaks on the Master and Audio channel... but no sound.
My first question is has anyone else ran into this problem? and also is there a way to select either multiple files or tracks and copy them to a new session?
Exporting doesn't work because it won't leave the spaces between the audio files... Thank you for your kind responses in advance

Zeelox

macinnisrr
macinnisrr's picture
User offline. Last seen 5 days 19 hours ago. Offline
Joined: 2008-01-14
Posts:

Is your master track connected to your system outputs?

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

it was.. how do I make sure it still is?

Thanks

seablade
User offline. Last seen 11 hours 15 min ago. Offline
Joined: 2007-01-22
Posts:

@Zeelox

http://en.flossmanuals.net/Ardour/UnderstandingRouting

Check to make sure your tracks are routed into your master bus as well obviously.

Seablade

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

Thanks for all your help. Although, the problem still persists. I've compared my setup with other songs and they are they exact same..
Other songs play just fine. The problem seems to be with the Master track.
There is no levels moving at all... This is quite puzzling
But my other question.. is there a way to copy and paste multiple files into a new session? Thanks again everyone, I hope I can fix this problem

paul
paul's picture
User offline. Last seen 1 hour 35 min ago. Offline
Joined: 2006-03-16
Posts:

@zeelox: if you are using plugins turn them all off and then turn them back on one by one.

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

OK, so I did that and now the Master track is showing movement on the track volume but still no sound.
I deactivated all the plugins.. no change
But what about my previous question... is there a way to copy and paste multiple tracks into a new session. I don't mind doing that.. I will just have to change the volumes for each track. I have too may tracks to just export and I want to be able to master and adjust volumes as I'm listening to them. Is there a solution to copying the sound files to another session without losing the space between the tracks?

Thanks

Zeelox

runaway
runaway's picture
User offline. Last seen 36 weeks 6 days ago. Offline
Joined: 2009-10-01
Posts:

@zeelox: I'm not an expert by any means but desperate times require desperate measures. I have an idea that might be worth trying so if you want to email me your ardour file (no media) and if it works it works - no harm in trying.

At the very least it should be like "copying the sound files to another session without losing the space between the tracks"

info at aatranslator dot com

seablade
User offline. Last seen 11 hours 15 min ago. Offline
Joined: 2007-01-22
Posts:

@Zeelox

I am fairly confident in saying one of two things is the case with your session. The less likely thing is that a plugin on a track(Possibly the master bus) has killed all sound due to a bug in it. The more likely thing is that your routing is screwed up somewhere, and there is a disconnect. The final possible thing is you have a mute or solo toggled and forgot about it, or something else basic like that that everyone has happen to them at one point or another. I personally would concentrate on your routing, make sure all track outputs are connected to your Master Bus Input, and that your Master Bus Output is connected to your sound card. Also obviously make sure the volume is up on your soundcard as well:)

You may want to get on IRC for help in troubelshooting your routing if you know none of the other issues are the cause.

Seablade

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

Well guys I appreciate all the help your sending my way.
One thing I can rule out for sure is the muting/soloing possibility. None are set to solo and none are muted.
As far as the routing thing goes I'm not very good at this. Is there a way to send me a screenshot of what my connection looks like. I've compared the settings from other sessions and they look identical... Could you explain in detail how to make sure it is routed properly?
Runaway, do you want the .bak file in the sessions folder? or is it a different file?
I have a feeling it is either a bug with the master track or one of the plugins.. is it possible to delete the master track and insert a new one? Or would it make any difference to delete the plugins? I tried deactivating them with no success. Thanks a lot guys

paul
paul's picture
User offline. Last seen 1 hour 35 min ago. Offline
Joined: 2006-03-16
Posts:

@zeelox: you can get a snapshot of the routing with this command, in a terminal window: jack_lsp -c

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

Here's the info:

system:capture_1
ardour:Audio 3/in 1
system:capture_2
system:playback_1
ardour:click/out 1
ardour:auditioner/out 1
system:playback_2
ardour:auditioner/out 2
ardour:master/in 1
ardour:Audio 12/out 1
ardour:Audio 11/out 1
ardour:Audio 10/out 1
ardour:Audio 9/out 1
ardour:Audio 8/out 1
ardour:Audio 7/out 1
ardour:Audio 6/out 1
ardour:Audio 5/out 1
ardour:Audio 4/out 1
ardour:Audio 3/out 1
ardour:Audio 2/out 1
ardour:Audio 1/out 1
ardour:master/in 2
ardour:Audio 12/out 2
ardour:Audio 11/out 2
ardour:Audio 10/out 2
ardour:Audio 9/out 2
ardour:Audio 8/out 2
ardour:Audio 7/out 2
ardour:Audio 6/out 2
ardour:Audio 5/out 2
ardour:Audio 4/out 2
ardour:Audio 3/out 2
ardour:Audio 2/out 2
ardour:Audio 1/out 2
ardour:master/out 1
ardour:master/out 2
ardour:auditioner/out 1
system:playback_1
ardour:auditioner/out 2
system:playback_2
ardour:Audio 1/in 1
ardour:Audio 1/out 1
ardour:master/in 1
ardour:Audio 1/out 2
ardour:master/in 2
ardour:Audio 2/in 1
ardour:Audio 2/out 1
ardour:master/in 1
ardour:Audio 2/out 2
ardour:master/in 2
ardour:Audio 3/in 1
system:capture_1
ardour:Audio 3/out 1
ardour:master/in 1
ardour:Audio 3/out 2
ardour:master/in 2
ardour:Audio 4/in 1
ardour:Audio 4/out 1
ardour:master/in 1
ardour:Audio 4/out 2
ardour:master/in 2
ardour:Audio 5/in 1
ardour:Audio 5/out 1
ardour:master/in 1
ardour:Audio 5/out 2
ardour:master/in 2
ardour:Audio 6/in 1
ardour:Audio 6/out 1
ardour:master/in 1
ardour:Audio 6/out 2
ardour:master/in 2
ardour:Audio 7/in 1
ardour:Audio 7/out 1
ardour:master/in 1
ardour:Audio 7/out 2
ardour:master/in 2
ardour:Audio 8/in 1
ardour:Audio 8/out 1
ardour:master/in 1
ardour:Audio 8/out 2
ardour:master/in 2
ardour:Audio 9/in 1
ardour:Audio 9/out 1
ardour:master/in 1
ardour:Audio 9/out 2
ardour:master/in 2
ardour:Audio 10/in 1
ardour:Audio 10/out 1
ardour:master/in 1
ardour:Audio 10/out 2
ardour:master/in 2
ardour:Audio 11/in 1
ardour:Audio 11/out 1
ardour:master/in 1
ardour:Audio 11/out 2
ardour:master/in 2
ardour:Audio 12/in 1
ardour:Audio 12/out 1
ardour:master/in 1
ardour:Audio 12/out 2
ardour:master/in 2
ardour:click/out 1
system:playback_1

This is when the session is open and the jack is running obviously.
For some more info I am using an Edirol UA-25

Does this look normal?

seablade
User offline. Last seen 11 hours 15 min ago. Offline
Joined: 2007-01-22
Posts:

Uh can you surround that with CODE tags please? Otherwise your formatting gets lost which is important so we can see what are port names and what are connections. Thanks.

Seablade

EDIT: Looking at that even without the formatting I am pretty dang certain your Master Outs are NOT connected to your soundcard, which is likely the cause of your problem. See the link I posted above, and if needed reference this page to find the Output button...
http://ardour.stackingdwarves.net/ardour-en/8-ARDOUR/23-ARDOUR/365-ARDOUR/366-ARDOUR.html

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

How's this?

system:capture_1
ardour:Audio 3/in 1
system:capture_2
system:playback_1
ardour:click/out 1
ardour:auditioner/out 1
system:playback_2
ardour:auditioner/out 2
ardour:master/in 1
ardour:Audio 12/out 1
ardour:Audio 11/out 1
ardour:Audio 10/out 1
ardour:Audio 9/out 1
ardour:Audio 8/out 1
ardour:Audio 7/out 1
ardour:Audio 6/out 1
ardour:Audio 5/out 1
ardour:Audio 4/out 1
ardour:Audio 3/out 1
ardour:Audio 2/out 1
ardour:Audio 1/out 1
ardour:master/in 2
ardour:Audio 12/out 2
ardour:Audio 11/out 2
ardour:Audio 10/out 2
ardour:Audio 9/out 2
ardour:Audio 8/out 2
ardour:Audio 7/out 2
ardour:Audio 6/out 2
ardour:Audio 5/out 2
ardour:Audio 4/out 2
ardour:Audio 3/out 2
ardour:Audio 2/out 2
ardour:Audio 1/out 2
ardour:master/out 1
ardour:master/out 2
ardour:auditioner/out 1
system:playback_1
ardour:auditioner/out 2
system:playback_2
ardour:Audio 1/in 1
ardour:Audio 1/out 1
ardour:master/in 1
ardour:Audio 1/out 2
ardour:master/in 2
ardour:Audio 2/in 1
ardour:Audio 2/out 1
ardour:master/in 1
ardour:Audio 2/out 2
ardour:master/in 2
ardour:Audio 3/in 1
system:capture_1
ardour:Audio 3/out 1
ardour:master/in 1
ardour:Audio 3/out 2
ardour:master/in 2
ardour:Audio 4/in 1
ardour:Audio 4/out 1
ardour:master/in 1
ardour:Audio 4/out 2
ardour:master/in 2
ardour:Audio 5/in 1
ardour:Audio 5/out 1
ardour:master/in 1
ardour:Audio 5/out 2
ardour:master/in 2
ardour:Audio 6/in 1
ardour:Audio 6/out 1
ardour:master/in 1
ardour:Audio 6/out 2
ardour:master/in 2
ardour:Audio 7/in 1
ardour:Audio 7/out 1
ardour:master/in 1
ardour:Audio 7/out 2
ardour:master/in 2
ardour:Audio 8/in 1
ardour:Audio 8/out 1
ardour:master/in 1
ardour:Audio 8/out 2
ardour:master/in 2
ardour:Audio 9/in 1
ardour:Audio 9/out 1
ardour:master/in 1
ardour:Audio 9/out 2
ardour:master/in 2
ardour:Audio 10/in 1
ardour:Audio 10/out 1
ardour:master/in 1
ardour:Audio 10/out 2
ardour:master/in 2
ardour:Audio 11/in 1
ardour:Audio 11/out 1
ardour:master/in 1
ardour:Audio 11/out 2
ardour:master/in 2
ardour:Audio 12/in 1
ardour:Audio 12/out 1
ardour:master/in 1
ardour:Audio 12/out 2
ardour:master/in 2
ardour:click/out 1
system:playback_1

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

Oh geez, you were right Seablade
I changed the output destination to "out 1+2" and it works now..
question though, how would this get reset after a crash and also why would it work before on the default settings? Thanks soo much for your help I thought I was going to have start over.. wow, im soo happy!! :)

Zeelox

seablade
User offline. Last seen 11 hours 15 min ago. Offline
Joined: 2007-01-22
Posts:

Well for the record I still lost the formatting somehow there;)

Crashes do strange things, not sure I can answer why it would work before a crash and why you would have to reconnect it after. I would just suggest reporting a crash so that we can fix it and so we can avoid crashes in the future;)

And yea the default will route the Master Outputs to the first two outputs of your soundcard unless you change it, so it should work fine there.

Seablade

Zeelox
User offline. Last seen 3 years 45 weeks ago. Offline
Joined: 2010-06-07
Posts:

Yeah, that's strange. But I'm glad I got the problem fixed. I have no idea how to make a bug claim.. Something I'll look into. Thanks again for all your help, take care.
But for the future does Ardour have a copy paste feature to a new session? What was your idea Runaway?

seablade
User offline. Last seen 11 hours 15 min ago. Offline
Joined: 2007-01-22
Posts:

But for the future does Ardour have a copy paste feature to a new session?

Not really what you are looking for no.

Seablade

runaway
runaway's picture
User offline. Last seen 36 weeks 6 days ago. Offline
Joined: 2009-10-01
Posts:

@zeelox: Along the lines of a copy paste to a new session - I was going to import your original ".ardour" file and export it to a new one. Sure you would lose fx, plugins etc but it would put your clips/regions etc into a new 'basic' session.

We sometimes do that with some daw formats to 'clean' them eg Logic has trouble reading its own OpenTL files - things like that.

Anyway it was just a thought....

Just thinking about that before I hit send - With AATranslator we have an 'append session' feature which allows you to join any 2 sessions from any or the same daw. I haven't implemented it for Ardour yet but will try & do that before I send out v3.2

paul
paul's picture
User offline. Last seen 1 hour 35 min ago. Offline
Joined: 2006-03-16
Posts:

and as a footnote, ardour3 has an "import from session" feature, allowing you to selectively import material and settings from an existing session. not yet released, of course.

runaway
runaway's picture
User offline. Last seen 36 weeks 6 days ago. Offline
Joined: 2009-10-01
Posts:

I guess great minds think alike ;-)