2.8.10 crashes and quits

3 replies [Last post]
audiodef
User offline. Last seen 6 days 2 hours ago. Offline
Joined: 2009-08-29
Posts:

I've been trying to record to Ardour using OpenOctave as the MIDI master. While recording, two things happen. Shortly after hitting play in OO, which starts record in Ardour, everything freezes for a few seconds, then resumes. After several more seconds, Ardour simply quits. All it leaves behind in a terminal is this:


[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
Programming error: ControlProtocolManager::teardown() called for Mackie, but it was not found in control_protocol_info
MackiePort::connect_any already connected
MackiePort::connect_any already connected
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]
[f8] MackiePort::handle_midi_any needs 3 bytes, but received [f8]

This goes on for quite a while so I didn't copy the entire terminal output here. But it shows nothing other than this.

audiodef
User offline. Last seen 6 days 2 hours ago. Offline
Joined: 2009-08-29
Posts:

Whoops. After hitting enter in terminal after Ardour quits, I see


[1]+ Segmentation fault ardour2

And that's REALLY it this time! :-P

paul
paul's picture
User is online Online
Joined: 2006-03-16
Posts:
seablade
User offline. Last seen 9 hours 42 min ago. Offline
Joined: 2007-01-22
Posts:

Hmm well based off this it looks almost like you are routing OO into the Mackie port for Ardour for some reason I don't understand, do you have a Mackie attached at all, and if not why even have the protocol enabled? Beyond this, yes do what las posted;)

Seablade