XRuns when connecting to Jack

4 replies [Last post]
tnasty
tnasty's picture
User offline. Last seen 3 years 34 weeks ago. Offline
Joined: 2009-12-23
Posts:

I am getting xruns (several per minute) no matter what settings I use for frames per period, sample rate, and periods per buffer. I am running ubuntu studio 10.4 x64 on a dell studio 1555 with 4gb ram and a 2.4 ghz core 2 duo.

-Any suggestions on how to reduce my xruns?
-What exactly is an xrun? is there a difference between an xrun and an xrun callback?
-What does the period per buffer setting do?

Thank you

David

Scary-Hallo
Scary-Hallo's picture
User offline. Last seen 30 weeks 2 days ago. Offline
Joined: 2009-02-13
Posts:

Hello tnasty,
I had a similar problem. I had to change the cpu-frequency-scaling from 'ondemand' to 'performance'.
Have a look here
http://www.linuxmusicians.com/viewtopic.php?f=27&t=2798
There is a small script to check your system

tnasty
tnasty's picture
User offline. Last seen 3 years 34 weeks ago. Offline
Joined: 2009-12-23
Posts:

@Scary-Hallo
Thanks alot for you suggestion; I ran the scripts and made sure that the script said everything was good, but I am still getting a large amount of xruns, and now, Ardour and Hydrogen will periodically stop and say that they cant keep up with Jack. I am getting about an xrun per 5 minutes running at 44100 Hz and with 512 frames/ period, and every about 10 minutes Ardour and Hydrogen disconnect from Jack. Any one have any suggestions?
Thanks
David

jackass
User offline. Last seen 13 weeks 6 days ago. Offline
Joined: 2011-12-09
Posts:

Hi,

had a similar problem and was short of shooting the damn beep-box, tried every suggestion on the net ... xruns no end. I finally started playing with my BIOS-settings CPU (don´t remember what) and AGP (Prefetchwhatshallmacallit disabled) and voila: got latency under 4ms no xruns ever again.

AMD x2 5200, 4GB RAM, Asrock AM2NF3-VSTA, Lexicon Omega

jackass
User offline. Last seen 13 weeks 6 days ago. Offline
Joined: 2011-12-09
Posts:

Hey, wow,

just had the same success with another machine I´ve been fiddeling with for some time. I changed some CPU settings (disabled everything that didn´t make imediate sense to me: prefetchsomething, secure virtualtheother ...) and bingo 5.1ms latency without a single xrun so far. Before I had one every 5sec

By the way: OpenSuse 11.3 Trace-Kernel