so slow...

3 replies [Last post]
frisio
User offline. Last seen 3 days 22 hours ago. Offline
Joined: 2010-02-14
Posts:

After recording several tracks it now comes to editing. And Ardour turns up to be very slow while moving multiple regions forth and back in the editor window. I checked my Mac's system preferences: I turned off the automatic graphic mode while running the Mac on battery in order to have always the full "graphic power". I checked Ardour>Menu>Options>Performance but none of the tried options seems to have any significant impact. Funny: after restarting Ardour performance is very much better for a while but then it becomes very slow again.

Any ideas?

Cheers
frisio
-
MacBook Pro 2.53 Ghz Intel Core i5
Mac OS X 10.6.3
Ardour 2.8.11
JackOSX.0.85
MIO Console 5
Metric Halo 2882 2d expanded

paul
paul's picture
User offline. Last seen 1 hour 42 min ago. Offline
Joined: 2006-03-16
Posts:

@frisio: its likely to be an issue with the size of the history list. Check in Preferences and see how large your settings are. This has all be redesigned from scratch for a future release. For now, particularly on machines with less memory, its wise to set the history limits (there are two) rather small.

Benjamin Scherrer
User offline. Last seen 23 hours 51 min ago. Offline
Joined: 2006-07-27
Posts:

Hi,

try setting the undo history to a smaller number, as well as the saved undo history.

You are probably running into a problem which has been adressed in Ardour 3.
http://tracker.ardour.org/view.php?id=2982

For the moment, you should avoid having too many regions at a time. Bouncing some things might help.

Best
Benjamin

UncleWaldo
User offline. Last seen 3 years 33 weeks ago. Offline
Joined: 2010-08-26
Posts:

Granted, I'm a week late on this post, but three things come to mind:

1. Are you editing on the same disc that your software is installed on? I've found that if I keep my files on a separate hard drive, it frees up cpu to actually let the software perform.

2. Do you have Bluetooth on? That will rob you of cpu power.

3. Do you have Airport on? Another cpu thief.

Last thought... I'm assuming you don't have iTunes running at the same time?