Compilaton problem with ardour 2 on mandriva.

8 replies [Last post]
linuxforever
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-05
Posts:

Hi everybody,
I have a problem with the compilation of ardour 2.

this is the scons return :

g++ -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -DARCH_X86 -mmmx -m3dnow -march=i686 -msse -mfpmath=sse -DBUILD_SSE_OPTIMIZATIONS -Wall -DENABLE_NLS -D_REENTRANT -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DPACKAGE=\"libardour\" -DLIBSIGC_DISABLE_DEPRECATED -DDATA_DIR=\"/usr/local/share\" -DCONFIG_DIR=\"/usr/local/etc\" -DLOCALEDIR=\"/usr/local/share/locale\" -DHAVE_JACK_CLIENT_OPEN -DHAVE_JACK_RECOMPUTE_LATENCIES -DHAVE_WORDEXP -DHAVE_SYS_VFS_H -Ilibs/pbd3 -Ilibs/midi++2 -Ilibs -Ilibs/sigc++2 -I/usr/include -Ilibs/ardour -Ilibs/soundtouch -I/usr/include/libxml2 -c -o libs/ardour/audioengine.o libs/ardour/audioengine.cc
libs/ardour/ardour/audioengine.h: In member function 'jack_nframes_t ARDOUR::AudioEngine::transport_frame() const':
libs/ardour/ardour/audioengine.h:80: error: 'jack_get_current_transport_frame' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'int ARDOUR::AudioEngine::start()':
libs/ardour/audioengine.cc:122: error: 'jack_set_thread_init_callback' was not declared in this scope
libs/ardour/audioengine.cc:128: error: 'jack_set_freewheel_callback' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'int ARDOUR::AudioEngine::process_callback(jack_nframes_t)':
libs/ardour/audioengine.cc:302: error: 'jack_set_freewheel' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'int ARDOUR::AudioEngine::freewheel(bool)':
libs/ardour/audioengine.cc:851: error: 'jack_set_freewheel' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'int ARDOUR::AudioEngine::connect_to_jack(std::string)':
libs/ardour/audioengine.cc:895: error: 'jack_options_t' was not declared in this scope
libs/ardour/audioengine.cc:895: error: expected `;' before 'options'
libs/ardour/audioengine.cc:896: error: 'jack_status_t' was not declared in this scope
libs/ardour/audioengine.cc:896: error: expected `;' before 'status'
libs/ardour/audioengine.cc:901: error: 'options' was not declared in this scope
libs/ardour/audioengine.cc:901: error: 'status' was not declared in this scope
libs/ardour/audioengine.cc:901: error: 'jack_client_open' was not declared in this scope
libs/ardour/audioengine.cc:905: error: 'JackServerFailed' was not declared in this scope
libs/ardour/audioengine.cc:913: error: 'JackServerStarted' was not declared in this scope
libs/ardour/audioengine.cc:917: error: 'JackNameNotUnique' was not declared in this scope
libs/ardour/audioengine.cc:918: error: 'jack_get_client_name' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'int ARDOUR::AudioEngine::reconnect_to_jack()':
libs/ardour/audioengine.cc:1019: error: 'jack_set_thread_init_callback' was not declared in this scope
libs/ardour/audioengine.cc:1025: error: 'jack_set_freewheel_callback' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'int ARDOUR::AudioEngine::request_buffer_size(jack_nframes_t)':
libs/ardour/audioengine.cc:1062: error: 'jack_set_buffer_size' was not declared in this scope
libs/ardour/audioengine.cc: In member function 'void ARDOUR::AudioEngine::update_total_latencies()':
libs/ardour/audioengine.cc:1073: error: 'jack_recompute_total_latencies' was not declared in this scope
scons: *** [libs/ardour/audioengine.o] Error 1
scons: building terminated because of errors.

Please help me.
Thanks.

sampo
User offline. Last seen 10 weeks 1 day ago. Offline
Joined: 2006-03-16
Posts:

You probably just need a newer version of jackd to get that working.

Also, you need the development package for jackd, but I suspect you have that installed already.

linuxforever
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-05
Posts:

This is not the problem, I have compiled the lastest version of jack.

$ jackd -v
jackd 0.101.1

Thanks for your help.

taybin
User offline. Last seen 39 weeks 6 days ago. Offline
Joined: 2006-03-15
Posts:

The latest version of jack is 0.102.20

linuxforever
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-05
Posts:

Yes, on subversion.
I test that and I will say you.

linuxforever
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-05
Posts:

Arf, I have the same error, however I have the lastest version of Jack.

taybin
User offline. Last seen 39 weeks 6 days ago. Offline
Joined: 2006-03-15
Posts:

Are you sure you've removed all of the old jack from your system? It is easy to confuse the build system with multiple versions. We've all done that at some point.

linuxforever
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-05
Posts:

Yes, it's that.
Thanks.

compilator
User offline. Last seen 5 years 18 weeks ago. Offline
Joined: 2008-12-07
Posts:

#define UseJackExactName "0.95.1"

in the file /src/qtractorAudioEngine.cpp

but i still receive error: 'jack_client_open'

what was that?