Ardour doesn't fit my screen

11 replies [Last post]
2handband
User offline. Last seen 4 years 21 weeks ago. Offline
Joined: 2009-09-26
Posts:

I'm using the latest version of Ardour on a desktop box with 1024x768 resolution. Ardour overlaps the screen horizontally. Is there anything I can do about this?

paul
paul's picture
User offline. Last seen 4 hours 41 min ago. Offline
Joined: 2006-03-16
Posts:

@2handband: in Preferences, change the font scaling. We don't have control over the *actual* font sizes on various linux distributions, and the choices we make work on some distributions and not on others.

2handband
User offline. Last seen 4 years 21 weeks ago. Offline
Joined: 2009-09-26
Posts:

Tried that. The fonts get really tiny, but the window size doesn't change. I'm using Slackware, BTW.

paul
paul's picture
User offline. Last seen 4 hours 41 min ago. Offline
Joined: 2006-03-16
Posts:

@2handband: a before & after screenshot would help. you should also specify what you consider the "latest Ardour" to be ....

2handband
User offline. Last seen 4 years 21 weeks ago. Offline
Joined: 2009-09-26
Posts:

Sorry, I'm using 2.8.11. I'll upload some screenshots this evening (gotta take the kid trick-or-treating right now).

2handband
User offline. Last seen 4 years 21 weeks ago. Offline
Joined: 2009-09-26
Posts:

I guess we can call this one solved... I cranked it up today and it fit just fine. ???

fkaluza
fkaluza's picture
User offline. Last seen 4 years 29 weeks ago. Offline
Joined: 2006-10-23
Posts:

2handband what did you did to fit it ?? I am starting to get angry with the same problem. Ardor widow is to big for my screen (resolution: 1366x768). I use ubuntu studio and ardour 2.8.11 (revision 7387).When i push F11 track actualy fit the screen but normal maximization working wrong

Pablo Fernández
User offline. Last seen 2 years 12 weeks ago. Offline
Joined: 2007-02-20
Posts:

Hi fkaluza,

What Paul said:

Window -> Preferences -> Misc -> Font scaling.

Decrease 10 points or so. 90 could do the trick.

Close ardour and open it again.

gkhouri
User offline. Last seen 4 weeks 16 hours ago. Offline
Joined: 2012-12-10
Posts:

I'm having a similar "window doesn't fit on the screen" problem, specifically in the "export to audio window/dialog" when I expand the "time span and channel options." I'm using Ardour 3.5.403 on my laptop with a 1366x768 display. If I change the font scaling down to ~55 from the default 80 (now found in Preferences->GUI), the expanded window will fit but the font for the rest of the Ardour interface becomes minuscule and impractical. Not a problem with most other windows otherwise, but if I have several tracks and I want to export selectively, I can't get to the entire list. Thanks.

LeatusPenguin
User offline. Last seen 2 weeks 4 days ago. Offline
Joined: 2010-12-16
Posts:

@gkhouri, the export dialog in Ardour's master branch has the 'time span' and 'channels' options broken out into their own tabs. This makes it much more practical and it will easily fit on smaller screens. In the meantime, and until that is released, you can use ALT + left click and drag on the window to move it upwards. This way you will have access to the entire list.

gkhouri
User offline. Last seen 4 weeks 16 hours ago. Offline
Joined: 2012-12-10
Posts:

@LeatusPenguin - thanks much. I guess I've missed the ALT + left click feature if it's documented somewhere. I agree having separate time span and channel tabs is a worthwhile feature.

LeatusPenguin
User offline. Last seen 2 weeks 4 days ago. Offline
Joined: 2010-12-16
Posts:

Just to clarify, ALT + left click and drag is a feature of your window manager. It has nothing to do with Ardour, but it does come in handy sometimes :)