Ardour crashes when loading existing session

10 replies [Last post]
2handband
User offline. Last seen 3 years 7 weeks ago. Offline
Joined: 2009-09-26
Posts:

When I try to load an existing session I get a segmentation fault and Ardour crashes. I filed a bug report and was told that this is a known bug and what i had to do was fix my instant.xml file so that zoom was around 256. It worked... the first time. But since then it's been getting worse and worse, to the point at which existing sessions almost never load regardless of the zoom setting. Ardour, at this point, is essentially unusable on my computer. Is there anything i can do about this?

seablade
User offline. Last seen 4 hours 2 min ago. Offline
Joined: 2007-01-22
Posts:

Would need much more information in order to even begin to help you. There are a few things in older versions of Ardour that could be done that would cause crashes, such as you already found, Zoom state, duplicate named sends, etc.

So to start with, what your console says and a crash report when Ardour crashes would be a good starting point, what version of Ardour you are opening with and what version of Ardour created the session, etc.

Seablade

2handband
User offline. Last seen 3 years 7 weeks ago. Offline
Joined: 2009-09-26
Posts:

I'm using Ardour 2.8.11, which was used to create all of the sessions in question. Here's the terminal output from startup right until the moment it crashes:

gene@lemon:~$ ardour2
WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with 'ulimit -l', and it
is normally controlled by /etc/security/limits.conf

Ardour 2.8.11
(built using 7387 and GCC version 4.5.1)
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
loading default ui configuration file /usr/local/etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/gene/.ardour2/ardour2_ui.conf
Loading ui configuration file /usr/local/etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /usr/local/etc/ardour2/ardour_system.rc
loading user configuration file /home/gene/.ardour2/ardour.rc
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: looking for control protocols in /home/gene/.ardour2/surfaces/:/usr/local/lib64/ardour2/surfaces/
ardour: [INFO]: Control protocol Tranzport not usable
ardour: [INFO]: Control surface protocol discovered: "Mackie"
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
loading bindings from /usr/local/etc/ardour2/mnemonic-us.bindings

(ardour-2.8.11:12824): Gtk-WARNING **: EnableTranslation: missing action EnableTranslation
Session writable based on /home/gene/Ardour/Jeffery's Song/
Segmentation fault

paul
paul's picture
User offline. Last seen 8 hours 40 min ago. Offline
Joined: 2006-03-16
Posts:
@2hanband: this is a bad sign to start with:
WARNING: Your system has a limit for maximum amount of locked memory! This might cause Ardour to run out of memory before your system runs out of memory. You can view the memory limit with 'ulimit -l', and it is normally controlled by /etc/security/limits.conf
What is the output of this command: ulimit -l
2handband
User offline. Last seen 3 years 7 weeks ago. Offline
Joined: 2009-09-26
Posts:

gene@lemon:~$ ulimit -l
64

paul
paul's picture
User offline. Last seen 8 hours 40 min ago. Offline
Joined: 2006-03-16
Posts:

That is a super-crazy-low and unacceptable value. Its the reason why Ardour is crashing, and its why it tried to warn you as it started up. The value should either be "unlimited" or something exceeding 75% of your physical RAM. Units are in kilobytes.

2handband
User offline. Last seen 3 years 7 weeks ago. Offline
Joined: 2009-09-26
Posts:

I don't have an etc/security/limits.conf file. Is there any other way I can reset this value?

nowhiskey
User offline. Last seen 5 weeks 1 day ago. Offline
Joined: 2006-09-30
Posts:

hallo,
in some distros the value is written in

/etc/security/limits.d/audio.conf

cheers,
doc

paul
paul's picture
User offline. Last seen 8 hours 40 min ago. Offline
Joined: 2006-03-16
Posts:
2handband
User offline. Last seen 3 years 7 weeks ago. Offline
Joined: 2009-09-26
Posts:

Rats... I realy did not want to install pam. I may have to... but I'm gonna look around for options first.

peder
User offline. Last seen 49 weeks 5 days ago. Offline
Joined: 2007-05-08
Posts:

PAM is your friend, but since you're running Slackware I'm guessing you don't want friends ;)

The internets suggested putting, say, 'ulimit -l 512000' in /sbin/initscript , /etc/profile or /etc/bashrc . This will obviously raise the limit for all users on your computer, but since we've already established that you don't have any friends, that could have accounts there, it's a no-issue.