ADAT in/out on RME Digi 96/8 PAD

3 replies [Last post]
second_soul
User offline. Last seen 7 years 32 weeks ago. Offline
Joined: 2006-09-13
Posts:

Hi - I'm 95% there with my setup. AMD Sempron 2800+, 1GB RAM, Ubuntu, Ardour, Jack, RME Digi 96/8 PAD. Recording analog in/out is perfect, works a treat.

But (and the problem here is not actually with Ardour, so maybe I'm in the wrong place, but would appreciate a point in the right direction :-)) I want to record 8 channels of simultaneous ADAT using my Behringer ADA8000.

Jack however will only start up with the config input = ADAT, output = ADAT. This in itself is OK, because I can record the simultaneous channels, but it causes high CPU every time I add a track, as many connections are created for each input to each output ... a bit of a mess, with lots of delay errors and a few xruns. I had 60% CPU with 8 tracks open and armed, not even recording!

I need ADAT in, Analog out, where all inputs are routed to the stereo out. But if I try this, Jack doesn't start, and gives the error "Cannot set hardware parameters for playback - cannot load alsa module". I tried experimenting with different settings in qjackctl, to no effect. I can only start up jack successfully with adat in, adat out.

Has anyone seen this before, or have a solution where I can use the rme 96/8 pad adat input/analog output?

Thanks,
Matt.

Solv
User offline. Last seen 4 years 41 weeks ago. Offline
Joined: 2006-03-27
Posts:

Have you tried this page?

http://alsa.opensrc.org/index.php?page=rme96

Cheers,
Andy

Reuben
User offline. Last seen 4 years 32 weeks ago. Offline
Joined: 2006-03-30
Posts:

I need ADAT in, Analog out, where all inputs are routed to the stereo out.

You cannot do this. The ADAT and Stereo subdevices use the same controller. As such, you can only use one subdevice at a time. When ADAT is in use the Stereo device is unavailable and vice versa.

You CAN however, use the monitor feature to listen to the output of any two ADAT channels through the Analoge output.

it causes high CPU every time I add a track, as many connections are created for each input to each output

In the Ardour settings you can configure it so that no connections are automatically made when creating new tracks/buses. But, you should not have this much CPU usage. I use an Athon-XP 2100+ and ADAT sessions barely do anything to my CPU. (I use the exact same sound card)

Part of it may have to do with your setup. Ubuntu is nice and easy to use, but it's not really tuned for low latency. I'm an a Gentoo system with a kernel patched with the realtime-preempt patchset. If you have you Jack latency set at extreamly low levels, that also can cause problems.

second_soul
User offline. Last seen 7 years 32 weeks ago. Offline
Joined: 2006-09-13
Posts:

Hi Andy and Reuben, thanks for the replies. I checked out that link, but I think Reuben hit the nail on the head... You definitely cannot do what I was suggesting. I chose the monitor feature, and could get it working nicely. So far so good!

I think the rest is down to my individual setup. I'd be interested to know what the CPU figures are with you Reuben, and if its worth me installing Gentoo or Fedora/planetccrma. I made 32 empty audio tracks (no inputs connected) and CPU goes to about 10-11% just idling. When I select inputs 1-8 for tracks 1-8, ADAT 1-8 (as if to record a drumkit), the CPU goes to ~30%, stays at ~30% while recording. When I disconnect the inputs afterwards, the CPU drops back to 10%. Everything continues to run fine, no delay messages or xruns. I'm not sure if this % figure is unusually high or normal... So far it doesn't seem to have an adverse affect.

Cheers,
Matt