Conecting two m-audio delta 1010lts

11 replies [Last post]
lotone
User offline. Last seen 3 years 15 weeks ago. Offline
Joined: 2009-01-30
Posts:

I just connected the second card and it works but the one under doesn’t seem to work, alsa picks it up but when I go to ardour it says that I only have 12 inputs and I should 16. 1-8 of the 12 inputs work, when I try input 9 which should be the first input on the seconded card I get no sound, any pointers, thank you

paul
paul's picture
User offline. Last seen 1 day 13 hours ago. Offline
Joined: 2006-03-16
Posts:
@lotone: did you google? did you read this? http://www.ilovemyjournal.com/?action=view_entry&eid=4773
lotone
User offline. Last seen 3 years 15 weeks ago. Offline
Joined: 2009-01-30
Posts:

thank you for the link it sounds really promising their are just a few things I don't understand, on the site he talks about starting envy24control twice one for one card and one for the other, he said something like -c2 and -c3 , how do I do that? thank you

lotone
User offline. Last seen 3 years 15 weeks ago. Offline
Joined: 2009-01-30
Posts:

thank you for the link it sounds really promising their are just a few things I don't understand, on the site he talks about starting envy24control twice one for one card and one for the other, he said something like -c2 and -c3 , how do I do that? thank you

lokki
User offline. Last seen 3 weeks 18 min ago. Offline
Joined: 2008-02-07
Posts:

you do that in the commandline.

there you type envy24control -c2 (enter) or envy24control -c3 (enter) depending on which card you want to control.

hope this helps

lotone
User offline. Last seen 3 years 15 weeks ago. Offline
Joined: 2009-01-30
Posts:

Cool I figured that out, now what I'm having a problem with is the asoundrc file, i really don't know how to set it up which is kinda sad I know but please bare with me, I'm using AV linux if that helps thank you.

gastric_bass
User offline. Last seen 2 weeks 6 days ago. Offline
Joined: 2007-11-16
Posts:

you have to generate a .asoundrc file either in your home directory or in /etc/asound.conf . Generate the file (nano ~/.asoundrc or any other editor) and copy the section under "Below is the configuration which can be found here as well (with the hw parameters tweaked to my sound-card set up)" from the article, to which Paul pointed you into this file.

After restarting (I guess) Linux will see both cards as one device (under Jack)

Benjamin Scherrer
User offline. Last seen 7 hours 52 min ago. Offline
Joined: 2006-07-27
Posts:

Hi,

there are some problems with 2 ice1712 cards and Jack2 (http://trac.jackaudio.org/ticket/173) and people told me to use alsa_in and alsa_out instead, but I don't know how to get this really working, since I'm getting some odd delay messages and Ardour does not show more channels.
Is there an explicit howto for this alsa_in command and 2 M-Audio Delta1010LTs?

Thanks
Benjamin

etcetera
User offline. Last seen 2 years 29 weeks ago. Offline
Joined: 2008-08-17
Posts:

Hi,

I've got two M-Audio cards running in chain here, using the same .asoundrc file as quoted in the article - though I got it from this site: (http://www.jrigg.co.uk/linuxaudio/ice1712multi.html).
In the JACK setup dialog you have to choose the new .asoundrc configuration. When I added my new .asoundrc file it didn't show up in JACK - not even in the drop-down box - so I had to select the "input device" and "output device" fields and type the words "multi_capture" and "multi_playback" respectively into the fields to make JACK pick it up.

Another important thing is, that you have to make card number 2 the slave of card number one. Physically connect the SPDIF out of card number one with SPDIF of card number two, and use the second envy24control to make card 2 sync to SPDIF input. Now the dual card setup should be working. A screen dump of my routing with this setup can be found here: (http://www.etcetera-music.eu/public/instruments/LinuxMusic/JACK_MAudio1010_multicapture.png)

Frank

GMaq
GMaq's picture
User offline. Last seen 3 hours 25 min ago. Offline
Joined: 2007-12-11
Posts:

Hi,

I have this working on my own system and have done a guide here, It's for AV Linux but the info should be relevant to most other distros:
http://www.remastersys.com/forums/index.php?topic=1208.0

stagekraft
User offline. Last seen 2 years 6 weeks ago. Offline
Joined: 2011-03-08
Posts:

hey all,

I just got my system up and running using two delta 1010lts....

just thought I'd share a link to a thread I have going on the Ubuntu Studio forum;

http://ubuntuforums.org/showthread.php?t=1675400

It may a different distro, but the concept is the same......

hope some of this helps..

regards, John

stagekraft
User offline. Last seen 2 years 6 weeks ago. Offline
Joined: 2011-03-08
Posts:

hey all,

I just got my system up and running using two delta 1010lts....

just thought I'd share a link to a thread I have going on the Ubuntu Studio forum;

http://ubuntuforums.org/showthread.php?t=1675400

It may a different distro, but the concept is the same......

hope some of this helps..

regards, John