Need some help to understand console output

9 replies [Last post]
stratojaune
User offline. Last seen 12 hours 21 min ago. Offline
Joined: 2008-10-19
Posts:

Hi there,

In the actual session, when run "ardour2" from terminal, always have this in the output at ~ the same locator point (the break of this song, some regions disappears and some comes):

(You probably know the understanding wanted here is the last GThread-ERROR thing, so go to the end of this post !)

Many thanks if you find some time to increase my poor 2 years of Ardour knowledge and support,
Fred

####################################################################
:~$ ardour2
Ardour 2.8.11
(built using 7387 and GCC version 4.4.3)
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
Chargement du fichier de configuration de l'ihm par défaut /usr/local/etc/ardour2/ardour2_ui_default.conf
Chargement du fichier utilisateur de configuration l'ihm /home/f/.ardour2/ardour2_ui.conf
Loading ui configuration file /usr/local/etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour sera limité à 1024 fichiers ouverts
chargement du fichier de configuration système /usr/local/etc/ardour2/ardour_system.rc
chargement du fichier de configuration utilisateur /home/f/.ardour2/ardour.rc
ardour: [INFO]: Using SSE optimized routines
librdf error URI file:///home/f/.lv2/bundles/manifest.ttl - file '/home/f/.lv2/bundles/manifest.ttl' open failed - Aucun fichier ou dossier de ce type
VST_PATH not set, defaulting to /home/f/vst:/usr/local/lib/vst:/usr/lib/vst
DSSI_PATH not set, defaulting to /home/f/.dssi:/usr/local/lib/dssi:/usr/lib/dssi
RemoteVSTClient: executing /usr/local/lib/dssi/dssi-vst/dssi-vst-scanner /tmp/rplugin_qry_mADpcY
/usr/local/lib/dssi/dssi-vst/dssi-vst-scanner: line 36: exec: wine : non trouvé
DSSIVSTPlugin: Error on plugin query: Plugin scanner timed out on startup.
ardour: [INFO]: recherche des protocoles de contrôle dans /home/f/.ardour2/surfaces/:/usr/local/lib/ardour2/surfaces/
powermate: Opening of powermate failed - Aucun fichier ou dossier de ce type
ardour: [INFO]: Protocole de contrôle powermate inutilisable
ardour: [INFO]: Protocole de surface de contrôle trouvé : « Wiimote »
ardour: [INFO]: Protocole de contrôle Tranzport inutilisable
ardour: [INFO]: Protocole de surface de contrôle trouvé : « Mackie »
ardour: [INFO]: Protocole de surface de contrôle trouvé : « Generic MIDI »

(ardour-2.8.11:2722): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.HalVolumeMonitor is not supported
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkWidget::cursor-color' of type `GdkColor' from rc file value "((GString*) 0xab362c0)" of type `GString'
loading bindings from /home/f/.ardour2/ardour.bindings

(ardour-2.8.11:2722): Gtk-WARNING **: EnableTranslation: missing action EnableTranslation
Session writable based on /mnt/lennyhome/lmvm/
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkWidget::cursor-color' of type `GdkColor' from rc file value "((GString*) 0xac5feb0)" of type `GString'
underrun for choeur
underrun for choeur
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkWidget::cursor-color' of type `GdkColor' from rc file value "((GString*) 0xac602c0)" of type `GString'
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0xac5ff20)" of type `GString'
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkWidget::cursor-color' of type `GdkColor' from rc file value "((GString*) 0xac602c0)" of type `GString'
Found UI http://invadarecords.com/plugins/lv2/tube/stereo at index 0 in:
/usr/lib/lv2/invada.lv2/inv_tube_gui.so

Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::even-row-color' of type `GdkColor' from rc file value "((GString*) 0xcb306d0)" of type `GString'
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkWidget::cursor-color' of type `GdkColor' from rc file value "((GString*) 0xc4b9780)" of type `GString'

GThread-ERROR **: file /build/buildd-glib2.0_2.24.1-1-i386-84Pp4V/glib2.0-2.24.1/gthread/gthread-posix.c: line 171 (g_mutex_free_posix_impl): error 'Périphérique ou ressource occupé' during 'pthread_mutex_destroy ((pthread_mutex_t *) mutex)'
aborting...
Abandon

###################################################################

linuxdsp
linuxdsp's picture
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2009-02-04
Posts:

@stratojaune: my guess is that the GThread ERROR "device or resource busy" during 'pthread_mutex_destroy' is telling you that something is trying to destroy a mutex which is held by another thread. A mutex is used as a method of ensuring that threads don't try and access the same resources simultaneously (resulting in possible data corruption). In simple terms, if you want to access some data from a thread, and you don't want other threads accessing the same data while this is happening, you would use 'pthread_mutex_lock (pthread_mutex_t *mutex)' to hold a mutex while you access the data, then pthread_mutex_unlock to release the lock afterwards. Any other thread that attempts to get the lock by using pthread_mutex_lock on the same mutex will have to wait until the lock becomes free, thereby ensuring that the data is protected from being accessed by two threads simultaneously. When you no longer need the mutex, it can be destroyed by pthread_mutex_destroy, however, a problem may result if one thread tries to destroy a mutex that is being held by another thread, and I suspect this might be the reason you get a 'device or resource busy' error, although from the information its difficult to be specific about what two things are in contention

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Try running 'LANG=C ardour2 -d' to disable plugins (and have error messages in english).

You seem to be running a VST-enabled A2 but it can't find wine (line 36: exec: wine : non trouvé), though I'm not sure it that's the acctual problem.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

@linuxdsp : I'm pretty sure he wasn't asking from a coding philosophy POV. Probably more of a "Which damn button do I press to get this thing working" :)

linuxdsp
linuxdsp's picture
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2009-02-04
Posts:

@peder: Well, maybe - but he specifically asked what the GThread ERROR meant and I guess that's what it means :) The rest of it just seems to be some GTK stuff which may or may not be fatal - and I guess the most likely cause of the problem is plugin related..

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

@linuxdsp : I'm sure he'll name his first born after you for explaning that to him ;)

linuxdsp
linuxdsp's picture
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2009-02-04
Posts:

@Peder: I think really the point is that, that's what I think the error message means, sure, it doesn't help much, but then there's not much else in that console output that does :)

stratojaune
User offline. Last seen 12 hours 21 min ago. Offline
Joined: 2008-10-19
Posts:

@Peder & Linuxdsp: Men, just don't try to think what the problem is, or could be : just ask me !!!!!

Means, what more do you want as info ?

Wow, forget to say happy new year, done now !

paul
paul's picture
User offline. Last seen 4 hours 2 min ago. Offline
Joined: 2006-03-16
Posts:

@peder: its not ardourvst, its ardour loading the DSSI-VST plugin ...

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

@stratojaune : As I said in my first post : Try running 'LANG=C ardour2 -d' to disable plugins (and have error messages in english).