Odd Interference

4 replies [Last post]
Skcorps
User offline. Last seen 3 years 14 weeks ago. Offline
Joined: 2011-01-08
Posts:

I just got Ardour, and it looks like a wonderful program. For some reason, however, when I try to record audio I tend to get loud and rather ear-piercing screeches at regular intervals; similar to what happens if you hold two microphones right next to each other. Is there some obvious feature I'm skipping with Jack's configuration or something?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

Some things you might want to consider:

1.- Check your connections, you might have some track or bus that is causing feedback.
2.- Did you insert any plugins that might be causing this? Disable all plugins and see if the problem still persists.
3.- Do you get xruns when these loud noises happen? If so there might be a problem with your setup.
4.- Are you by any chance clipping when these noises happen? Check all your levels.

A bit more info on system and hardware would help a lot more.

Skcorps
User offline. Last seen 3 years 14 weeks ago. Offline
Joined: 2011-01-08
Posts:

1. No idea how do do this.
2. No plugins to my knowledge, I literally just got the program, so nothing but the bare basics I guess.
3. As I understand, Xruns are buffer under/overflows. I also have no idea how to check if I'm getting them though.
4. Nope, just recording to one track through my built-in mic as a test. Every noise, even something like light clapping, will set off the interference.

I've got a MacBook. Here are my specs, tell me if you need any more specifics.

Processor Name: Intel Core 2 Duo
Processor Speed: 2.26 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 2 GB
Bus Speed: 1.07 GHz

seablade
User offline. Last seen 1 hour 51 min ago. Offline
Joined: 2007-01-22
Posts:

4. Nope, just recording to one track through my built-in mic as a test. Every noise, even something like light clapping, will set off the interference.

Turn down your speakers or plug in headphones. You are getting acoustic feedback, essentially what is happening is y our built in mic is picking up the sound of your speakers, and then putting that sound through your speakers again, and picking it up again, and putting it through your speakers again, causing a feedback loop which is that sound you are hearing. This is one of many reasons that people don't record with the built-in mic on laptops.

Seablade

nixcamic
User offline. Last seen 38 weeks 1 day ago. Offline
Joined: 2011-01-19
Posts:

Or, disable monitoring in Ardour, Go in the Options menu > Monitoring > and check Audio Hardware Does Monitoring. If you're recording with the built in Microphone you probably don't need monitoring, if you do, do as seablade says and use headphones.