Problem with Ardour

9 replies [Last post]
tony
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-18
Posts:

I installed ardour, JACK, and qjackctl on linux today. I tried running qjackctl as non-root and ardour as the same non-root but after starting, ardour says jack is not running. When I do the exact same thing with muse, it works just fine. Any ideas?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Did you compile any of those components yourself? It sounds as if ardour was compiled against a different version of jackd than what you're running.

tony
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-18
Posts:

I am using the following packages...

ardour 0.99.3-2: http://archlinux.org/packages/5695
jack 0.101.1-1: http://archlinux.org/packages/3920
qjackctl 0.2.20-1: http://archlinux.org/packages/3934

Are those not compatible?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Difficult to say whether they are compatible or not. They are from the same repository, so I would assume they are but you never know.

Jack applications are quite picky about which version of jack they run on. I've noticed that 99% of the time, the application will only work with the version of jackd it was compiled against.

You should first make sure you are really running both jackd and ardour as the same user, and make sure that jackd is really running (try the command line tool "jack_lsp" to see jack ports)

If all this fails, try one of these:

1. Ask the maintainer of the repository whether that package of ardour was compiled against the packaged jackd.
2. Find a new repository
3. Compile it yourself http://www.ardour.org/building

tony
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-18
Posts:

some more info

tony
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-18
Posts:

I appreciate all the help. I did some research and found these are all the latest stable versions. I should mention that ultimately, I'm looking to run both qjackctl and ardour as non-root. I find if I'm not running qjackctl, jack_lsp gives "JACK server not running." If I am, I get...

alsa_pcm:capture_1
alsa_pcm:capture_2
alsa_pcm:playback_1
alsa_pcm:playback_2
alsa_pcm:playback_3
alsa_pcm:playback_4
alsa_pcm:playback_5
alsa_pcm:playback_6

Whether or not I have jackd running as root does not seem to make a difference. I also find that if I have qjackctl running as non-root and I run ardour as non-root, ardour loads up but I get this error...

ardour:Log
[ERROR]: cannot activate JACK client

If, however, I don't have qjackctl running but I try to start ardour anyway, it fails and I get this message...

ardour:unplugged
Ardour could not connect to JACK.

Again, whether or not I have the jackd daemon running does not seem to make a difference. Any ideas?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

As you know, both jackd and the jack clients (for example Ardour) should be running as the same user. Just to verify this, when you have jackd running (any way you want to use it), run:

ps -Leo pid,user,cmd

And see as which user jackd is running as.

tony
User offline. Last seen 7 years 30 weeks ago. Offline
Joined: 2006-09-18
Posts:

I ran "ps -Leo pid,user,cmd" as you suggested." When running qjackctl and ardour as the non-root user, I do see qjackctl, jackd, and ardour running all as the same non-root user. But I still get the error: "cannot activate JACK client."

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Then it seems that the build of Ardour you have in your system is not compiled against the build of jack you have installed.

You need to ether find a new repository, get the repository maintainer fix the packages or compile ardour yourself.

Erdie
Erdie's picture
User offline. Last seen 1 day 2 hours ago. Offline
Joined: 2006-03-27
Posts:

Sampo,

does it matter if jackd and Ardour are compiled with different gcc major versions?
I recompiled both gcc4.1.1 and after I figured out an error (which was posted here) I had to recompile Ardour with gcc 3.4. .
So far it seems to work but I would like to avoid some hidden risks.

thanks
Erdie