Ardour and Soundblaster

10 replies [Last post]
7Maverick
User offline. Last seen 3 years 12 weeks ago. Offline
Joined: 2011-01-26
Posts:

Hy guys!
My problema consists in the fact that Ardour doesn't recognize my external Soundblaster!

The program only sees the internal audio of my laptop, but for recording i want to use the soundblaster because it's better.

Any ideas?

paul
paul's picture
User offline. Last seen 21 hours 35 min ago. Offline
Joined: 2006-03-16
Posts:

Ardour isn't interested in your audio hardware in any way. Interactions with your audio hardware are solely the concern of JACK. When you run JACK, you choose which audio hardware you want to use it with. How do you start JACK? From Ardour itself? From a separate JACK control program such as QJackctl or JackPilot? What platform are you on (Linux? OS X?)

7Maverick
User offline. Last seen 3 years 12 weeks ago. Offline
Joined: 2011-01-26
Posts:

Ok paul, thank you for the explanation.

Now, when i start ardour i don't start jack. not manually...isn't it automatic?
do i have to start first jack and then ardour?

and finally...in jack...how can i set my soundblaster as the input and output?

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

@7Maverick : If it's a USB2 Soundblaster, chances are it won't work in Linux. Most USB2 don't.

The easiest way to deal with JACK is through QJackCtl. There you have a GUI for setting all kinds of stuff relate to audio, like sample rate and which hardware (soundcard) to use.

Start QjackCtl first, set it up to your liking and click the Start button. Then start Ardour.

7Maverick
User offline. Last seen 3 years 12 weeks ago. Offline
Joined: 2011-01-26
Posts:

ok, now with qjackctl i set soundblaster as the input and output hardware.
In fact, now when i speak on the microphone, i see the soundwaves on ardour.

problem is that i don't have output. if i wanna hear what i registered...i hear nothing.

on jack i have the same setting on input and output...HW 1,0, that is the code for soundblaster. jack sees it.

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

There are two ways to hear what you record: either let the soundcard (if it's capable) do it or have Ardour do it. To use the latter you have to set Options -> Monitoring -> Ardour does monitoring

More about this here : http://www.ardour.org/files/manual/sn-monitoring.html

Also, please read the manual : http://en.flossmanuals.net/ardour?q=flossmanual

7Maverick
User offline. Last seen 3 years 12 weeks ago. Offline
Joined: 2011-01-26
Posts:

Ok, now i have this situation.

Soundblaster runs. I say that because, with jack off, i can listen to music from Rhytmbox. So the soundblaster is not the problem.

now, if i turn on jack, the sound quits immediately. rhytmbox continues to run, but without audio. i start ardour, i speak to the microphone and i see the soundwave, but if i try to hear what i recorded, nothing sounds.

i close everithing, shut down jack, and magically i can hear again music.

HELP!

In jack setup panel, at the voice "input device" i set 1, because 1 is for soundblaster.
at the voice output device, i set also 1.

where am i wrong?

7Maverick
User offline. Last seen 3 years 12 weeks ago. Offline
Joined: 2011-01-26
Posts:

New discovery!

if i set jack on playback only, sound magically appears! rhytmbox is playing with jack!

i'm going crazy

7Maverick
User offline. Last seen 3 years 12 weeks ago. Offline
Joined: 2011-01-26
Posts:

New discovery!

if i set jack on playback only, sound magically appears! rhytmbox is playing with jack!

i'm going crazy

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

JACK probably hasn't connected the master out to your Soundblaster.
Click the Connections button in QJackCtl and see where the master_outs are connected.

For more help you should go to the IRC channel (click the text "the main channel" on http://www.ardour.org/support) and see if there's anybody there that can be of assistance.

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

Setting JACK to playback only (I didn't even know you could do that) has noting to do with Rythmbox playing.
It's probably that the first time you started RB before JACK, so RB played its sounds through ALSA or PulseAudio. If you have JACK started before RB it probably defaults to using JACK before any of the others.