US-122 in Ardour 2.8.11

19 replies [Last post]
dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

running ubuntu 10.10 x64, ardour 2.8.11 (built from revision 7387)

I am trying to record audio via my ancient tascam us-122 on my laptop.

I figured out how to get the device working it would seem as. the green USB light on us-122 is on

but,

1. in pulse audio i can see us-122 as input device, but no sound is registered when guitar is played

2. in sound preferences i can see us-122 as a hardware device, and input device, but again no input level response

jack starts up fine

ardour starts up fine

i add an audio track
arm it for recording
click to edit the audio input
there is no option for the us-122
only system capture 1 and 2 give any input level response (the internal mic on the laptop)

any help would be greatly appreciated, would much rather work with this system then have to go to cakewalk.

thanks

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

Is JACK using the USB soundcard (the us-112) as its interface?

Run qjackctl and check the settings. Select the proper inteface and optionally the input/output device.

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

thanks, did not see that option.

now my problem is xrun every second. guess it is the generic kernel i am using.

will loading the preemt patch fix this?

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

does not seem to be the kernel.

loaded up 2.6.32-24-lowlatency-2.6.32-24.41 and still have the xruns.

any suggestions?

GMaq
GMaq's picture
User offline. Last seen 2 days 23 hours ago. Offline
Joined: 2007-12-11
Posts:

Hi,

I have a US-122 and they actually work better with a generic Kernel, they are not going to give you great low latency performance with Linux. I suggest 512 or 1024 fpp, 44100 Sample rate and A Periods/Buffer of 3. If I recall 256fpp was about as good as they got on Windows but it's been many years since I've done that.

All that said if you aren't obsessed with low latency they are a great little unit with some handy features, mine will run all day long without issue with the settings above.

linuxdsp
linuxdsp's picture
User offline. Last seen 15 hours 33 min ago. Offline
Joined: 2009-02-04
Posts:

What are your jack audio buffer settings (the -n and -p switches if you start it from the command line?)

From the jackd man page:

For USB audio devices it is recommended to use -n 3

linuxdsp
linuxdsp's picture
User offline. Last seen 15 hours 33 min ago. Offline
Joined: 2009-02-04
Posts:

@GMaq: I need to learn to type faster..

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

thanks GMaq and linuxdsp,

but troubles continue

1. i am back in generic kernel
2. made sure that memory wasn't locked as per: http://ubuntu-virginia.ubuntuforums.org/showthread.php?t=1637399 as i was getting a prompt at ardour startup about memory
3. set up jack as per GMaq's post
4. get this jack output:
15:18:43.522 Patchbay deactivated.
15:18:43.541 Statistics reset.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
15:18:43.556 ALSA connection graph change.
15:18:43.849 ALSA connection change.
15:18:46.372 Startup script...
15:18:46.373 artsshell -q terminate
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
sh: artsshell: not found
15:18:46.774 Startup script terminated with exit status=32512.
15:18:46.774 JACK is starting...
15:18:46.774 /usr/bin/jackd -r -dalsa -dhw:0 -r44100 -p512 -n3 -D -Chw:1,0
15:18:46.781 JACK was started with PID=3029.
no message buffer overruns
no message buffer overruns
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in non-realtime mode
audio_reservation_init
Acquire audio card Audio1
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:1,0|512|3|44100|0|0|nomon|swmeter|-|32bit
Using ALSA driver HDA-Intel running on card 0 - HDA Intel at 0xf0700000 irq 46
configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 3 periods for playback
alsa_driver_xrun_recovery
**** alsa_pcm: xrun of at least 0.050 msecs
JackAudioDriver::ProcessAsync: read error, skip cycle
alsa_driver_xrun_recovery
**** alsa_pcm: xrun of at least 0.040 msecs
15:18:49.003 Server configuration saved to "/home/dysonsphere/.jackdrc".
15:18:49.004 Statistics reset.
15:18:49.014 Client activated.
15:18:49.028 JACK connection change.
15:18:49.032 JACK connection graph change.
JackAudioDriver::ProcessAsync: read error, skip cycle
alsa_driver_xrun_recovery
**** alsa_pcm: xrun of at least 0.039 msecs
JackAudioDriver::ProcessAsync: read error, skip cycle
JackPosixMutex::Unlock res = 1
15:18:50.001 XRUN callback (1).
alsa_driver_xrun_recovery
**** alsa_pcm: xrun of at least 0.039 msecs
JackAudioDriver::ProcessAsync: read error, skip cycle
15:18:51.019 XRUN callback (2).
JackPosixMutex::Unlock res = 1
15:18:51.052 XRUN callback (1 skipped).
15:18:51.671 Client deactivated.
15:18:51.672 JACK is stopping...
jack main caught signal 15
Released audio card Audio1
Released audio card Audio0
audio_reservation_finish
15:18:51.757 JACK was stopped successfully.
15:18:51.758 Post-shutdown script...
15:18:51.758 killall jackd
jackd: no process found
15:18:52.171 Post-shutdown script terminated with exit status=256.

linuxdsp
linuxdsp's picture
User offline. Last seen 15 hours 33 min ago. Offline
Joined: 2009-02-04
Posts:

@dysonsphere:

Using ALSA driver HDA-Intel running on card 0 - HDA Intel at 0xf0700000 irq 46

I wouldn't necessarily expect to see that message relating to what seems to be the onboard audio card if you are using a USB interface.

GMaq
GMaq's picture
User offline. Last seen 2 days 23 hours ago. Offline
Joined: 2007-12-11
Posts:

Agree with linuxDSP,

If you have you onboard soundcard enabled it should be hw:0 or card 0 and the Tascam USB should be hw:1, are you sure you selected the US-122 in Qjackctl-->Setup-->Interface ?

Mind you I don't use Gnome or Pulseaudio so it may have a different way of assigning a default soundcard. If you aren't married to Ubuntu AV Linux 4.2 has OOTB US-122 support, if you can't get it running on Buntu.

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

in jack setup the only config i can get jack to start in is if i pick (default) for the interface.
the input is set for US-X2Y Audio #0
output is (default)

i guess the HDA-Intel is used for output. i guess somehow i must get that disabled?

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 2 days ago. Offline
Joined: 2008-02-27
Posts:

@linuxdsp:

@GMaq: I need to learn to type faster..

Then you must have some latency issue. Check your settings...

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

@dysonsphere : Here's the culprit of your xrun problems:

JACK server starting in non-realtime mode

If you configured rtprio along with memlock you should tick the Realtime box in qjackctl

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

this is what i get with sudo aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC272 Digital [ALC272 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: USX2Y [TASCAM US-X2Y], device 0: US-X2Y Audio [US-X2Y Audio #0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

ticking the Realtime box in qjackctl doesn't fix it

peder
User offline. Last seen 49 weeks 3 days ago. Offline
Joined: 2007-05-08
Posts:

What does 'ulimit -r' say? If it's "0" you haven't manage to enable rtprio (or you haven't logged out/in or rebooted for it to take effect).
What does the JACK log say about realtime?

Here's the JACK realtime info : http://jackaudio.org/linux_rt_config

linuxdsp
linuxdsp's picture
User offline. Last seen 15 hours 33 min ago. Offline
Joined: 2009-02-04
Posts:

I looks to me as though you have jackd configured to use hw1 (the USB device) for capture but hw0 (the intel HDA onboard audio) for playback. I would expect this to cause you problems (especially using jack1) try starting jack from the command line by typing:

jackd -d alsa -p512 -n3 -dhw:1

and see if that works any better.

dysonsphere
User offline. Last seen 3 years 11 weeks ago. Offline
Joined: 2007-06-12
Posts:

@peder

dysonsphere@SYS76-Ubuntu:~$ ulimit -r
95

@linuxdsp
dysonsphere@SYS76-Ubuntu:~$ jackd -d alsa -p512 -n3 -dhw:1
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:1|hw:1|512|3|48000|0|0|nomon|swmeter|-|32bit
Using ALSA driver USB US-X2Y running on card 1 - TASCAM US-X2Y (1604:8007 if 0 at 002/003)
configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 3 periods for playback
ALSA: cannot set hardware parameters for playback
ALSA: cannot configure playback channel
Cannot initialize driver
JackServer::Open() failed with -1
Failed to start server

let's see:
in sound preferences (hardware tab) i have 3 sound hardware devices set up as following
1. Internal Audio (Analog Stereo Duplex)
2. RV710/730 (Digital Stereo (HDMI) Output)
3. US-122 Audio/Midi Interface (Analog Stereo Duplex)
the input tab has US-122 selected as the device, but the input level is unresponsive
the output tab has US-122 selected as the output device, testing speakers gives silence.

i also have the pulseaudio manager, but have no idea what it is telling me.
it shows a line under sinks with "alsa_output.usb-1604_8077-00-USX2Y.analog-stereo", with a thread that lists #47 to #55, each with a seperat line and a description of "button-pressed".

not sure what this all means.

thanks for all your prompt and thoughtful replies so far.

dysonsphere@SYS76-Ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC272 Digital [ALC272 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: USX2Y [TASCAM US-X2Y], device 0: US-X2Y Audio [US-X2Y Audio #0]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

linuxdsp
linuxdsp's picture
User offline. Last seen 15 hours 33 min ago. Offline
Joined: 2009-02-04
Posts:

@dysonsphere: At least trying to start jackd with -dhw:1 is now selecting your USB interface, but it looks as though it failed to start because one of the other parameters (or a default) was incompatible with the USB interface (or its drivers) capabilities, you could try some different sample rates and see if that helps (I can't be very specific because I don't have a similar interface to experiment with) but perhaps 44100 might be better e.g.

jackd -d alsa -p512 -n3 -dhw:1 -r44100

Also check the man pages for jack for a description of the available config options e.g.

man jackd

and there's a FAQ being assembled on the jack website:

http://www.jackaudio.org/

GMaq
GMaq's picture
User offline. Last seen 2 days 23 hours ago. Offline
Joined: 2007-12-11
Posts:

Hi,

That is odd, those parameters should be good. I'm not using JACK2 though and haven't actually tested the US-122 with it. It's a longshot but JACK2 can be run asynchronously or not so perhaps the '-S' parameter could be added to your command...no guarantees just a stab in the dark....

jackd -d alsa -p512 -n3 -S -dhw:1 -r44100