Creating Ardour Starter in Xubuntu's Multimedia Menu

5 replies [Last post]
babarosa
babarosa's picture
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: 2009-09-04
Posts:

Hi there,

I am using Xubuntu 10.04 LTS and compiling and installing ardour 2.8.11 works perfectly. I only have one small "cosmetic" problem: no starter for ardour is created automatically in the multimedia menu, so I create one by myself using usr/locl/bin/ardour2.

Does someone have an idea which dependency is missing for autocreating a starter? My thanks in advance and my dependency list for compiling ardour (I yet have installed more audio related libs, because I compile a lot of other audio progs):

sudo apt-get build-dep ardour

sudo apt-get install scons build-essential libjack-dev libasound2-dev libglib2.0-dev liblrdf0-dev libboost-dev liblo-dev liblo7 libgnomecanvas2-dev libgnomecanvas2-0 libsamplerate0 libsamplerate0-dev libaubio-dev lv2core libslv2-dev liblv2dynparamplugin1-0 liblv2dynparamhost1-1 cl-fftw3 root-plugin-fftw3 libfftw3-dev

Regards, Michael

lokki
User offline. Last seen 3 weeks 3 days ago. Offline
Joined: 2008-02-07
Posts:

i don't think you miss any dependency. it's just not very common for a self-compiled program to generate a starter.

babarosa
babarosa's picture
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: 2009-09-04
Posts:

That is defintiley not true in my case (and in general too, I think).

Ffado, QJackCtl, QTractor, QSynth, Calf, Rakarrack, Swami, Kluppe, Audacity, Abiword, Gnumeric, JackMixer, QMidiCtl, Muse, VMPK, .... do create a starter automatically when being self-compiled.

In the case of Ffado, I had to install some gtk-related libs additionally to have its starter installed automatically, that's why I thought some libs are missing (especially concerning gtk-stuff there are hundreds of possibilities).

But, as mentioned in my first post, it's just a cosmetic problem. So, let's close this topic.

chrisg
User offline. Last seen 22 hours 25 min ago. Offline
Joined: 2006-03-27
Posts:

There is a flag when building that may do what you want. I think it is --freedesktop, but check the --help for more details, that may only associate session files with the app itself.

babarosa
babarosa's picture
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: 2009-09-04
Posts:

@chrisg,

thank you for the hint. It didn't help - I use the GTK=yes option anyway.
Maybe it is a xfce/Xubuntu specific problem. Please don't bother anymore (installing from ppa's generates the starter, but for better performance and stability I prefer to compile).

Greetings, Michael

joegiampaoli
joegiampaoli's picture
User offline. Last seen 23 weeks 1 day ago. Offline
Joined: 2008-02-27
Posts:

You can make a starter yourself can't you? The command is ardour2 and the icon is located in /usr/local/share/ardour2/icons

Just edit (Please make a backup of this file before editing it)

/etc/xdg/xfce4/desktop/menu.xml

and follow this sample:

app name="Name in menu" cmd="Command to run" term="false" icon="iconfile" snotify="false" visible="true" /

Which means yours should be something like this I believe:

app name="Ardour2" cmd="ardour2" term="false" icon="/usr/local/share/ardour2/icons/ardour_icon_48px.png" snotify="false" visible="true" /

You will have better stability if self compiled and you were able to do it.

I am totally against PPA or repos especially for these type of things.

EDIT:

Then I didn't read your first post well before my whole biblic explanation, and noticed you were able to create your own starter, so what is the main problem?

When I compile and install it doesn't do it either for me and I'm in Gnome......