connecting ardour to jack

3 replies [Last post]
waffle
User offline. Last seen 10 years 42 weeks ago. Offline
Joined: 2006-08-27
Posts:

Further issues on FC5 x86 64

I'm not getting any input from my jack connections (using freebob). I've been having a hell of a time finding any software that will let me run it, to check and see if it's a jack issue.

further to this, I don't see any kind of edit cursor within ardour, and nothing i import wants to play. any ideas?

--Waffle

sampo
User offline. Last seen 22 weeks 1 day ago. Offline
Joined: 2006-03-16
Posts:

Are you able to start ardour alright? Does ardour see the jack ports for the freebob device?

jemies
User offline. Last seen 9 years 6 weeks ago. Offline
Joined: 2006-09-21
Posts:

I got the same problem on Ubuntu 6.06. No curser, no way to get any sounds out, but I can import wav-files. When I start from shell, I got the following report:

Ardour/GTK 0.99.2
(built using 1.3.0 with libardour 0.906.1 and GCC version 4.0.3 (Ubuntu 4.0.3-1ubuntu2))
Copyright (C) 1999-2006 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Loading UI configuration file /etc/ardour/ardour_ui.rc
cannot write to jackstart sync pipe 4 (Bad file descriptor)
jackd: wait for startup process exit failed
jackd 0.100.0

...

JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 1024 frames, buffer = 2 periods
Note: audio device hw:0 doesn't support a 32bit sample format so JACK will try a 24bit format instead
Note: audio device hw:0 doesn't support a 24bit sample format so JACK will try a 16bit format instead
nperiods = 2 for capture
Note: audio device hw:0 doesn't support a 32bit sample format so JACK will try a 24bit format instead
Note: audio device hw:0 doesn't support a 24bit sample format so JACK will try a 16bit format instead
nperiods = 2 for playback
ardour: [INFO]: JACK server started
Loading system configuration file /etc/ardour/ardour_system.rc
Loading user configuration file /home/jemies/.ardour/ardour.rc
ardour: [INFO]: No H/W specific optimizations in use
ardour: [WARNING]: Your system generates "Mod2" when the NumLock key is pressed. This can cause problems when editing so Ardour will use Mod3 to mean Meta rather than Mod2

This even if I unlock the NumLock before starting ardour. (it is locked by default from a script-package called Automatix)

I'm afraid I already mixed up all jack-patching-settings by trying somehow using missing intuition: wihtout any positive effect.

The commands dpkg-reconfigure jack or ardour just do prompt the answer, that both packages aren't installed, though they surely are.

Any ideas?

Thanks and greetings
jemies

waffle
User offline. Last seen 10 years 42 weeks ago. Offline
Joined: 2006-08-27
Posts:

Update: Ardour starts fine, and runs fairly well when jack is started with the alsa backend, which leads me to believe that my problem lies with jack and/or the freebob backend. I'm hoping this isn't simply a matter of waiting for the next release of freebob...

--Waffle