Mixbus 1.5 on Linux now?

17 replies [Last post]
geeheeb
User offline. Last seen 21 weeks 3 days ago. Offline
Joined: 2008-02-06
Posts:

http://www.harrisonconsoles.com/mixbus/Mixbus_Install_QuickStart.pdf

According to this PDF, yes?

seablade
User offline. Last seen 2 hours 1 sec ago. Offline
Joined: 2007-01-22
Posts:

Yes it now runs on Linux as well.

Seablade

psychonain
psychonain's picture
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-07-25
Posts:

what ?
Where can i buy this version ?
is it suitable for ubuntu studio 10.04 ?
thx ;-)

psychonain
psychonain's picture
User offline. Last seen 10 weeks 3 days ago. Offline
Joined: 2006-07-25
Posts:

ok thats awesome just buy it on harrisson consoles !!!

Edward Diehl
User offline. Last seen 1 day 19 hours ago. Offline
Joined: 2007-02-01
Posts:

I believe you can buy it from http://www.harrisonconsoles.com or if you want to support AVLinux from here: http://sites.fastspring.com/harrisonconsoles/product/mixbus15?source=bandshed (also there is a nice Linuxdsp bundle available).

I got it and its working on AVLinux 4.2. A few comments: It does not seem to like existing Ardour2 sessions (crashes), but one can start a new one. The installation script said this:

!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency. You have two choices:
(1) turn it off, e.g. by chosing the 'performance' governor.
(2) Use the HPET clocksource by passing "-c h" to JACK
(this second option only works on relatively recent computers)

I tried the -c h Jack option - got message that I did not have permission to use the 'realtime clock' (/dev/rtc). I tried to fix that with the instructions from here: http://wiki.linuxmusicians.com/doku.php?id=system_configuration to create a filecalled /etc/udev/rules.d/40-timer-permissions.rules. Did that, rebooted, but Jack is still not happy with the "-c h" option. Qjackctl messages say:
This system has no accessible HPET device (Device or resource busy)

Any ideas about that? Don't know how important it really is.

UPDATE: Ok, I have no HPET device (see below). I have followed GMaq's advice (below). Thanks for the input

Edward Diehl
User offline. Last seen 1 day 19 hours ago. Offline
Joined: 2007-02-01
Posts:

More feedback: IR 1.2 and 1.3 crash Mixbus when loading an impluse file. IR works fine in Ardour 2.8.11 rev7387.

GMaq
GMaq's picture
User offline. Last seen 3 days 21 hours ago. Offline
Joined: 2007-12-11
Posts:

@Edward,

The CPU frequency thing has snuck up on us in Debian Squeeze and LXDE doesn't have a graphical CPU tool but I have a solution here at the AV Linux forum for now in the 4th post:
http://www.remastersys.com/forums/index.php?topic=1265.0

Some really good CPU info for Debian users here as well: http://forums.debian.net/viewtopic.php?f=30&t=50710

paul
paul's picture
User offline. Last seen 1 day 15 hours ago. Offline
Joined: 2006-03-16
Posts:

@Edward: /dev/rtc has absolutely nothing to do with the HPET timer. You device has no HPET timer, so -c h will not work for you. You shoul dfollow the suggestions that GMaq made about this issue.

seablade
User offline. Last seen 2 hours 1 sec ago. Offline
Joined: 2007-01-22
Posts:

@Edward

For the record it is probably much better to make a new comment to reply to someone, it gets a bit confusing to follow edits in the thread;)

Seablade

youki
User offline. Last seen 6 weeks 19 hours ago. Offline
Joined: 2008-07-03
Posts:

Hi.

The easiest way i found to put the CPU frequency on performance at the boot (on Debian at least) is to edit the file /etc/init.d/cpufrequtils at the line 43 replace "ondemand" by "performance" :

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="0"
MIN_SPEED="0"

I also have a few aliases in the /root/.bashrc to change the CPU freq when i need it using the terminal in root :

alias performance='cpufreq-set -c 0 -g performance & cpufreq-set -c 1 -g performance & cpufreq-set -c 2 -g performance & cpufreq-set -c 3 -g performance'
alias conservative='cpufreq-set -c 0 -g conservative & cpufreq-set -c 1 -g conservative & cpufreq-set -c 2 -g conservative & cpufreq-set -c 3 -g conservative'
alias ondemand='cpufreq-set -c 0 -g ondemand & cpufreq-set -c 1 -g ondemand & cpufreq-set -c 2 -g ondemand & cpufreq-set -c 3 -g ondemand'

But it's probably possible to add cpufreq-set in the sudoers file to allow the user to do it with sudo, but i didn't try.

I hope it'll help.

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

hello youki,

the debian way would be to have these variables in /etc/default/cpufrequtils
If you look at the init script, a bit below the script defaults, you see:


if [ -f /etc/default/cpufrequtils ] ; then
. /etc/default/cpufrequtils
fi

so the init script would overwrite its own defaults if it found the /etc/default/cpufrequtils file.

GMaq
GMaq's picture
User offline. Last seen 3 days 21 hours ago. Offline
Joined: 2007-12-11
Posts:

@Thorgal

I agree, changing it like youki is the first thing I tried and it was overridden on the next boot because of the defaults, from the article in my post above it is also possible to add echo performance >/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor' to /etc/rc.local and then autoload the performance module at boot by adding 'cpufreq_performance' (without quotes) to /etc/modules.

Of course a separate '"echo" path would need to be added for additional cores by changing /cpu0/ to /cpu1/ etc etc.

If setting it in /etc/defaults/cpufrequtils/ does the trick then that is the easiest by far.

I will certainly be adding a manual section on this to the AV Linux manual for the next release, however I do think the Mixbus install script is pointing something out that many users would not have noticed in performance otherwise especially with multi-core machines. However definitely useful info for those without graphical CPU tools.

youki
User offline. Last seen 6 weeks 19 hours ago. Offline
Joined: 2008-07-03
Posts:

Hello Thorgal.

Thanx, it's more clean indeed. The /etc/default/cpufrequtils file have to be created "by hand".

I put back the /etc/init.d/cpufrequtils on it's default "ondemand" and created /etc/default/cpufrequtils containing this :

ENABLE="true"
GOVERNOR="performance"
MAX_SPEED="0"
MIN_SPEED="0"

Then i restarted cpufrequtils and it works. :)

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

I was surprised the default file did not exist. Probably a mistake or miss from the cpufrequtils packager. I added this file by hand quite some time ago because I think that it IS the debian way, any init script needing configuration variables should have their defaults in /etc/default so that users may change them without searching like you did. I should have reported the miss through a debian bug report but I am sooo busy since the birth of my son (one year old now!!!) and we expect a second one some time during the summer ... It feels like my years fiddling around with music creation have been part of another life ... and I was not even half done ...

youki
User offline. Last seen 6 weeks 19 hours ago. Offline
Joined: 2008-07-03
Posts:

That's a pity, i remember that you were so enthusiastic about your music. Maybe in the future? But being a daddy could change the priorities indeed...

About /etc/default/cpufrequtils, the fact that it's missing was reported a few times already but :

> Package: cpufrequtils
> Version: 007-1
> Severity: wishlist
>
> It would be appreciated if cpufrequtils would let you specify governors and
> speed limitations in /etc/default/cpufrequtils, rather than the init.d script
> itself. This would ease upgrades somewhat.

Have you tried creating /etc/default/cpufrequtils or even reading
/usr/share/doc/cpufrequtils/README.Debian ? :)

also, in the init.d script you can see:

if [ -f /etc/default/cpufrequtils ] ; then
. /etc/default/cpufrequtils
fi

The fact that the package doesn't provide a default configuration file
is to ease upgrades (at least on the maintainer side) not having to deal
with just another configuration file that is likely to be customized by
users.

Thanks!
--
mattia
:wq!

and somewhere else

nothing stops you from creating your own to override the package
defaults. It just won't be handled by the package manager.

Thanks!
mattia
:wq!

But i guess in the case of AVLinux, it can be done at the install, isn't it?

GMaq
GMaq's picture
User offline. Last seen 3 days 21 hours ago. Offline
Joined: 2007-12-11
Posts:

@youki

In AV Linux I've now created one as default for the next version and put up a HowTO based on the helpful info from you and Thorgal for current users. I agree with you that a /etc/default/cpufrequtils file should be generated by the cpufrequtils package in Debian, hopefully future versions will. Thanks for the info!

thorgal
User offline. Last seen 1 year 21 weeks ago. Offline
Joined: 2007-08-03
Posts:

@youki,

Oh but I am still very thrilled by my seemingly never ending project and I will pick it up again when time allows. With the recent developments in the plugin space, mixbus for linux, A3 almost out, I'm getting quite frustrated these days (thus my presence here, to remember the good old days ... :) )

GMaq
GMaq's picture
User offline. Last seen 3 days 21 hours ago. Offline
Joined: 2007-12-11
Posts:

@thorgal

Getting totally OT here...but whatever

Sincerest congrats on your growing family...

While my comment will betray my advanced years...enjoy those precious little ones while they are young and make as many memories as you can because they don't stay little for long...if you are lucky when they get older you can enjoy and share music with them and in my experience there is no greater joy.

All the best!

Now I'll hand the microphone back to the amazing Mixbus 1.5!!