Problem with plugins in Ardour

22 replies [Last post]
kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

Hi,
so I'm running ardour on the latest ubuntu studio version, everything is set with jack and rt-kernel with no problem and a good latency with no xruns. So far, everything fine. But yesterday I recorded about 10 tracks and I tried to insert a plugin for every track.
With the first 8 tracks it works fine, but when I added two more plugins there was a crackling noise everytime I played the tracks together. I tried many different plugins, but it doesn't change anythng, there's alway this crackling noise when I use more than 8 plugins.
Please help :)

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

What does your DSP reading say at the bottom of the window?

Seablade

paul
paul's picture
User offline. Last seen 6 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

(top of the window on linux)

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

@Paul

Bah its been a while:)

Seablade

kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

It's between 75% and 80 % DSP

paul
paul's picture
User offline. Last seen 6 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

@kasstaka: you need a more powerful CPU. DSP loads at this level are always where things start to fall apart. Put simply, you just don't have enough CPU power to run this much DSP. Another cheaper option is to freeze each track (right click on track -> Freeze) one at a time as you add plugins, which will render the track and disable the plugin. however, then you can't mess around with the plugin settings any more.

kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

But my CPU isn't used to capacity at all. I looked at my system monitoring and when I use more or less plugins, but there's no change in the CPU usage.

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

That is because DSP and CPU are two different things.

DSP usage is how much of the available time is used for each Jack Callback, in other words each time audio is processed, you have X amount of time to use for processing, and DSP is the measurement of how much time is used. The lower the Jack buffer settings used the less time available for processing audio in realtime. The higher the settings, the more latency, but it is also a bit easier to keep up with processing larger DSP loads.

Ardour2 currently does all processing on a single 'core'. This means that especially if you are using a multi-core CPU, you may not see a change in CPU usage linerally as plugins are added or removed. Ardour does use the other cores, but not for DSP processing at this time. It uses them to draw the GUI, handle control protocols, etc. As a result these stay pretty lightweight compared to the DSP processing in most cases.

Ardour3 is adding the ability to use any number of cores for DSP processing, and you will be able to set this(IIRC set it on the fly even) in the settings of A3.

Seablade

kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

so my problem will hopefully be solved with ardour 3?

paul
paul's picture
User offline. Last seen 6 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

@kassatka: if you multiple cores, then yes, ardour3 will help with this issue once it is released.

kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

excellent :) than I'll just be waiting for ardour 3. I'm looking forward to it.
thanks for the help :)

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

@kassatka

I gotta ask, what CPU are you using, Jack Buffer Settings, and what DSP are you inserting that only 8 of them takes you into the 80% range? It is EXCEEDINGLY likely that there is probably a better way to do this, as not to many well designed processors take up that much CPU and those that do tend to be routed differently than what you have described for that and other reasons.

Seablade

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

For comparison, I have a seven track session with 4 EQs, 8 C* Plate reverbs, 3 Compressors and a Maximizer running with a DSP load of about 45% on a single core AMD Athlon XP 2000+ (that's a nine year old CPU!) and a jack latency of 5.8ms (11.6ms roundtrip; 256 f/p, 2 p/b 44.1KHz sr)

I also tried exchanging all the C* Plates to Calf Reverbs and ended up with about 65% DSP

kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

I've got an AMD Athlon II x4, so quite new compared to peder's one ;)
My buffer is set to 128, period 2 and 48000hz, latency 5,33 ms in jack
When jack is running alone with no ardour connected my DSP is around 2-4 %, but just when I start ardour it goes up to 65%, even there's nothing playing. I don' get it.....

paul
paul's picture
User offline. Last seen 6 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

@kassatka: just FYI: the DSP load generated by Ardour is not very dependent on whether its playing or not. there is constantly a signal passing through the program whether the transport is rolling or not. Does it jump to 65% even in a session with no plugins? Sounds as if you might be facing issues with denormals.

kassatka
User offline. Last seen 3 years 4 weeks ago. Offline
Joined: 2011-03-20
Posts:

when I load the session with plugins it's going up to 65 %
and when I delete all the inserted plugins the DSP is at 15 %
when I play the session the DSP is at 26 %

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

@kassatka

Well your buffer settings are quite low, my first question would be whether such low latency is actually needed or not.

Aside from that though, to answer your other observation, the way many realtime DAWs work is they are ALWAYS processing audio, even if transport is not running in them. In these cases they are processing silence, or in some cases they are still processing the inputs to tracks or busses, all depending on the DAW and the routing. So when you have any plugins loaded, they will always be running.

Seablade

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

@seablade
The latency is low, but just one notch lower than in my example (aside from 44.1 vs 48kHz), and I'm using a standard 2.6.37-kernel.

@kassatka
Do you have the possibility to install something other than Ubuntu Studio, like for instance AVLinux [http://bandshed.net/AVLinux.html] or kxstudio [kxstudio.sourceforge.net] ?
From what I've read over the years it seems, despite its name, Ubuntu Studio haven't been that sucessful in packaging Ardour/Jack/whatnot to provide an optimally working DAW.

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

@peder
True, but my point is still the same, the lower the latency the higher the DSP, so if buffer settings can be increased it will consequently lower the DSP load. However this of course still doesn't answer exactly what those plugins are, if this is the same session where only 8 plugins are being inserted.

The packaging by the distro has come up in many ways, but increased DSP load is not a typical symptom. I wouldn't expect changing distros to help to much with this to be honest.

Seablade

paul
paul's picture
User offline. Last seen 6 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

for the sake of posterity, kassatka came to #ardour on IRC, and it turned out that the plugin in question was the CALF reverb. we gave him various advice on what to do, which came down to some combination of (a) don't use 1 reverb per track - route to a bus and put the reverb there (b) if you have to use 1 reverb per track, play with each track settings and then freeze it (c) consider ardour3 on a multi-processor system and/or a more powerful CPU.

seablade
User offline. Last seen 8 hours 59 min ago. Offline
Joined: 2007-01-22
Posts:

I figured something like that may have been happening;)

Seablade

RickBrock
User offline. Last seen 2 years 17 weeks ago. Offline
Joined: 2011-12-20
Posts:

Paul,
how do i route to a bus please?
i just can't see the button i would press on a 'real' mixer.
thanks
Rick

Edward Diehl
User offline. Last seen 2 hours 31 min ago. Offline
Joined: 2007-02-01
Posts:

There are at least 2 ways to do this on Ardour2

1. In the bus mixer strip below the name of the bus is the input selector which probably has "-" in it. Click on that and select "Edit". This brings up a panel named Bus X input. Select the inputs to the chanel(s) of the bus from the Available connections. In this case the bus gets the sound from the track post-fader, which has means the bus volume is controlled both by the track fader and bus fader.

2. Insert a "send" in the track pre-fader plugin area (right-click and select "New Send"). Set the outputs of the send to be the inputs of the bus. With this method the bus volume is only affected by its fader which is more flexible.