Alsa, Jack, Ardour and Alesis IO 2 soundcard

7 replies [Last post]
dererik
User offline. Last seen 3 weeks 1 day ago. Offline
Joined: 2011-06-13
Posts:

Hello

trying to run Ardour, but I fail with my soundcard (USB Alesis IO 2), here is the error log from Jack audio Connection Kit:

ACK server starting in non-realtime mode
control device hw:1
control device hw:1
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:1|hw:1|256|3|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
Using ALSA driver USB-Audio running on card 1 - Alesis io|2 at usb-0000:00:1a.0-1.1, full speed
configuring for 44100Hz, period = 256 frames (5.8 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 3 periods for playback
ALSA: could not start playback (Broken pipe)
Cannot start driver
JackServer::Start() failed with -1
control device hw:1
Released audio card Audio1
audio_reservation_finish
control device hw:1
Failed to start server
13:25:54.197 JACK wurde angehalten mit Rückgabewert = 255.

I tried a lot with the preferences etc but..

regards

erik stunkat

awwaiid
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-04-18
Posts:

I have an IO2 Express that works quite well.

The device is hard-wired to 24bit and 48000. I see you are using 44100, so maybe try changing that, though I'm not sure that is your problem.

At some point I create an .asoundrc to deal with non-24bit-apps, but I don't think that has anything to do with it. But just in case, it is at http://vir.homelinux.org/blog/archives/24-Alesis-IO2.html

Also, for a while I had an issue where jackd would only start if the io2 was the _only_ usb device currently plugged in. But I think a newer version of jackd fixed it.

--Brock

dererik
User offline. Last seen 3 weeks 1 day ago. Offline
Joined: 2011-06-13
Posts:

It is the DUPLEX mode

Thank you very much for your ideas.

What I found now, is that the Alesis doesn´t work in duplex mode - it is ok with just playback or just recording.

Any ideas?

awwaiid
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-04-18
Posts:

Mine works in full-duplex. Here is the relevant output, perhaps it will help. I'm using qjackctl to set and save all the params.

19:40:20.087 JACK is starting...
19:40:20.088 /usr/bin/jackd -t5000 -dalsa -r48000 -p256 -n3 -D -Chw:io2 -Phw:io2
jackd 0.120.2
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
19:40:20.110 JACK was started with PID=13834.
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:io2|hw:io2|256|3|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 256 frames (5.3 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 3 periods for playback
dererik
User offline. Last seen 3 weeks 1 day ago. Offline
Joined: 2011-06-13
Posts:

Thank you very much for your help!

I tried to check with your settings, @awwaid - but I get these error messages:

jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in non-realtime mode
control device hw:1
control device hw:1
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:1|hw:1|256|3|48000|0|0|nomon|swmeter|-|32bit
control device hw:1
Using ALSA driver USB-Audio running on card 1 - Alesis io|2 at usb-0000:00:1a.0-1.1, full speed
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'defaults.namehint.extended'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM hw:1
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'defaults.namehint.extended'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM hw:1
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
Cannot initialize driver
JackServer::Open() failed with -1
Failed to start server

Any more ideas?

regards
erik

jdessi2
jdessi2's picture
User offline. Last seen 2 years 32 weeks ago. Offline
Joined: 2011-09-09
Posts:

I also have problems with Alesis IO / 2.
When I plug, I don't see it in the Qjackctl audio connections panel.
I only see it in the Qjackctl Midi and Alsa connections panel.

Can you help?

awwaiid
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-04-18
Posts:

I plug my io2 in _before_ I start running jackd, jdessi2.

dererik - not sure what else to tell you... maybe yours has a different interface name. I got my settings by playing around with qjackctl.

dererik
User offline. Last seen 3 weeks 1 day ago. Offline
Joined: 2011-06-13
Posts:

In the meantime I got a cakewalk UA-2 EX, works much better.

regards
erik