Jack and ardour doing somin wierd

3 replies [Last post]
stephenthemartyr
User offline. Last seen 2 years 36 weeks ago. Offline
Joined: 2011-06-21
Posts:

Memory locking is unlimited - this is dangerous. You should probably alter the line:
@audio - memlock unlimited
in your /etc/limits.conf to read:
@audio - memlock 1540092
no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|128|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 128 frames (2.9 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
00:22:38.039 Server configuration saved to "/home/owner/.jackdrc".
00:22:38.041 Statistics reset.
00:22:39.244 Client activated.
00:22:39.248 JACK connection change.
00:22:39.273 JACK connection graph change.
00:23:12.903 XRUN callback (1).
delay of 7166.000 usecs exceeds estimated spare time of 2838.000; restart ...

I have been getting massive x-runs and i went to linux musicians cuz thats where I was directed cuz i am super duper newbie confused but this came up and i really dont know how to fix it or what it means ,sorry to sound so pathetic

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

You're running jack with a very low latency setting (128 frames). Try increasing it to 2048 try again. If the works you can lower it in steps until you start getting xruns again.

Also read http://jackaudio.org/linux_rt_config to see how you configure your system to be able to handle low latencies (real-time).

stephenthemartyr
User offline. Last seen 2 years 36 weeks ago. Offline
Joined: 2011-06-21
Posts:

so if the frames is 256 do i need to change anything else to accomadate the 256 and it had only 4 x-runs in about 10 minutes which is wayway less but i wonder if 11.6 ms is gunna mess up the music.Could ya help me?

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

If you still get xruns, even just one every other minute, you should increase the frames setting (and thereby the latency).
If you were using your linux box with a MIDI keyboard to play a softsynth, say yoshimi or calf monosynth, you'd want as low a latancy as possible, otherwise you'd notice a delay between when you press the key and when you hear the sound. But just for recording audio and running Hydrogen a slightly high latency isn't a problem.

I'm assuming you have made the limits.conf change (from http://jackaudio.org/linux_rt_config) and if you run ulimit -r in a terminal you'll get "99" (or whichever value you set the rtprio value to). You also need to tick the Realtime box in the Setup panel in QjackCtl and set the Priority value (I usually set it slightly lower than my rtprio value).
And note that if you're using a built in soundcard you probably can't get really low latencies anyway.