Ardour 3 vs OS10.6 doesn't work

4 replies [Last post]
nik0
User offline. Last seen 2 years 41 weeks ago. Offline
Joined: 2006-04-01
Posts:

Hello

I tried to use the last version or Ardour on my 10.6 macbook pro but it doesn't work

Yes I installed X11 before
Yes I lanched X11 before
Yes I installed Jack before
Yes I launched Jack before

Yes I allready tried Ardour with my old 10.4 macbook and it worked but now, with my 10.6 mac I have this message:

Thanks for answers

------------------------------------------------------

Process: Ardour2.bin [373]
Path: /Applications/Ardour.app/Contents/MacOS/Ardour2
Identifier: org.ardour.Ardour2
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [118]

Date/Time: 2011-06-25 11:35:56.584 +0200
OS Version: Mac OS X 10.6.7 (10J869)
Report Version: 6

Interval Since Last Report: 469933 sec
Crashes Since Last Report: 8
Per-App Crashes Since Last Report: 4
Anonymous UUID: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /usr/local/lib/libjack.0.dylib
Referenced from: /Applications/Ardour.app/Contents/MacOS/Ardour2.bin
Reason: no suitable image found. Did find:
/usr/local/lib/libjack.0.dylib: stat() failed with errno=13
/usr/local/lib/libjack.0.dylib: stat() failed with errno=13

Binary Images:
0x8fe00000 - 0x8fe4162b dyld 132.1 (???) /usr/lib/dyld

Model: MacBookPro7,1, BootROM MBP71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.62f6
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.131.36.9)
Bluetooth: Version 2.4.0f1, 2 service, 12 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HTS545025B9SA02, 232,89 GB
Serial ATA Device: HL-DT-ST DVDRW GS23N
USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8507, 0x24600000
USB Device: Internal Memory Card Reader, 0x05ac (Apple Inc.), 0x8403, 0x26100000
USB Device: USB O2, 0x0763 (M-Audio), 0x0115, 0x04100000
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06600000
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8213, 0x06610000
USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x06500000
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0237, 0x06300000
FireWire Device: unknown_device, Unknown
FireWire Device: unknown_device, Unknown
FireWire Device: unknown_device, Unknown

peder
User offline. Last seen 48 weeks 5 days ago. Offline
Joined: 2007-05-08
Posts:

Hmm, the title says Ardour3 but you seem to be running Ardour2.

So, assuming it's A2 you're having trouble with, from your error log it seems that Ardour tries to load /usr/local/lib/libjack.0.dylib and doesn't find it.
Perhaps you need to reinstall jack.

seablade
User offline. Last seen 33 min 56 sec ago. Offline
Joined: 2007-01-22
Posts:

First things first, you arent running ardour 3. Ardour 3 has not been distributed for the mac and I can count on one hand the amount of programmers that have even compiled it for mac successfully, much less run it. As was mentioned above you are running Ardour2.

Second thing, based off your description of installing Jack etc. I am betting you installed Macports and installed Jack etc. through that. This is not supported at all for various reasons I wont go into here, but not the least of which is that it is more difficult than the official method, which is to download the installer for JackOSX and install it, then download and run Ardour2. However now that you have installed Jack via macports, things become much more difficult. Hopefully you can just do a port uninstall jackd and be able to do what I mentioned above, but that is dependant on your particular system and if you have questions on this you should ask them on IRC, keeping in mind what I said about Macports not being supported.

Finally, X11 has not been required or recommended for many years, you dont need it in any way shape or form for Ardour on OS X.

Seablade

nik0
User offline. Last seen 2 years 41 weeks ago. Offline
Joined: 2006-04-01
Posts:

Thank you for your answers.

You wer right, i downloaded a 2.8.11 mac intel version.

I didn't use Macport. I got last version of Jack : JackOSX.0.88_64-32bits and just run the installer.

The question now is witch version of Ardour run properly under Mac OS 10.6?

seablade
User offline. Last seen 33 min 56 sec ago. Offline
Joined: 2007-01-22
Posts:

All of them. Seriously, I run Ardour on 10.6 and it has been supported for some time.

At this point you should get on IRC and get some help there, I should be back starting tomorrow around a fair amount during the daytime EST, but others there will be able to help you. There is something fundamentally wrong with your system or Jack install that is breaking things.

Seablade