Crashes while launching

11 replies [Last post]
dn3s
dn3s's picture
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2011-06-29
Posts:

I'm running 64-bit Fedora 14 with the CCRMA realtime kernel. Ardour has been working fine. I recently compiled the Calf plugins from git. Now, when I try to launch Ardour, it crashes. here is the command-line output:

$ ardour2
WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with 'ulimit -l', and it
is normally controlled by /etc/security/limits.conf

Ardour 2.8.11
(built using 7387 and GCC version 4.5.1 20100924 (Red Hat 4.5.1-4))
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
theme_init() called from internal clearlooks engine
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:80: error: unexpected identifier `colorize_scrollbar', expected character `}'
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/dn3s/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/dn3s/.ardour2/ardour.rc
ardour: [INFO]: Using SSE optimized routines
VST_PATH not set, defaulting to /home/dn3s/vst:/usr/local/lib/vst:/usr/lib/vst
Segmentation fault (core dumped)

any advice?

dn3s
dn3s's picture
User offline. Last seen 1 year 38 weeks ago. Offline
Joined: 2011-06-29
Posts:

I just uninstalled the CALF plugins, and now Ardour runs fine. while this is a relief, it means I cannot continue work on my project, which I need the CALF Multiband Compressor to finish.

peder
User offline. Last seen 49 weeks 4 days ago. Offline
Joined: 2007-05-08
Posts:

Try changing your GTK theme. See http://ardour.org/node/4451

Or see if you can use the release version of CALF. It might be a bug/incompatibility in the git version.

paul
paul's picture
User offline. Last seen 1 day 15 hours ago. Offline
Joined: 2006-03-16
Posts:

@dn3s: you appear to be using a VST build of Ardour on a 64 bit system. Unless Ardour was specially constructed for this purpose, this isn;t going to work. Where did you get Ardour from?

CALF plugins work fine for many other users, including myself on 64 bit Fedora 13.

JP
User offline. Last seen 2 years 24 weeks ago. Offline
Joined: 2011-10-31
Posts:

Hello!
I have exatly the same problem.
My system is ubuntu studio 11.04 and Ardour came allready installed with the system.
But couple of days ago I decided to upgrade CALF plugins (I've found that they have cool GUI) , and installed their latest version from git. After that Ardour bagan to crash=(

Ardour 2.8.11
(built using 7387 and GCC version 4.5.1)
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
theme_init() called from internal clearlooks engine
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/pupkovem/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
ardour: [INFO]: Ardour will be limited to 4096 open files
loading system configuration file "/etc/ardour2/ardour_system.rc"
ardour: [INFO]: No H/W specific optimizations in use
VST_PATH not set, defaulting to /home/pupkovem/vst:/usr/local/lib/vst:/usr/lib/vst
Segmentation fault

Libs.that I had to install to compile CALF:
libglade2-dev (1:2.6.4-1build1)
dssi-dev (1.1.0-3+customdata1~natty1)
liblash-dev (0.6.0~rc2-5build1)
uuid-dev (2.17.2-9.1ubuntu4)
libglobus-libtool (1.2-6)
libglobus-libtool-dev (1.2-6)
libltdl-dev (2.2.6b-2ubuntu3)
libtool (2.2.6b-2ubuntu3)
libtoolkit-perl (0.0.2-1)
libgconf2-dev (2.32.2-0ubuntu2)
libidl-dev (0.8.14-0.1ubuntu1)
liborbit2-dev (1:2.14.19-0ubuntu2)
orbit2 (1:2.14.19-0ubuntu2)

Does this error response this information:
http://www.archlinux.org/news/ardour-loses-lv2-support/
?

azmeuk
User offline. Last seen 21 weeks 6 days ago. Offline
Joined: 2011-10-31
Posts:

Hi, I have the same problem with fedora 16 64bits and gnome3. I tried to run ardour as root, and everything I've got is from fedora repositories.

Any tip ?

azmeuk@localhost:~$ ardour2
Ardour 2.8.12
(built using 10144 and GCC version 4.6.1 20110908 (Red Hat 4.6.1-9))
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
theme_init() called from internal clearlooks engine
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:80: error: unexpected identifier `colorize_scrollbar', expected character `}'
Chargement du fichier de configuration de l'ihm par défaut /etc/ardour2/ardour2_ui_default.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour sera limité à 4096 fichiers ouverts
raptor_new_uri_for_rdf_concept called with Raptor V1 world object
raptor_general.c:240:raptor_init: fatal error: raptor_init() failedAbandon (core dumped)
azmeuk@localhost:~$

seablade
User offline. Last seen 2 hours 1 min ago. Offline
Joined: 2007-01-22
Posts:

@azmeuk The problem is in the RDF libs you are using on your system, I would recommend you try the bundle from this website, I don't think you will see that problem.

@jp I would recommend the same thing though your problem is likely different. Ubuntu's packaging history has left much to be desired.

Seablade

DLC11
User offline. Last seen 39 weeks 4 days ago. Offline
Joined: 2008-07-26
Posts:

You should definitely file a bug with Fedora's bugzilla.

Cut and paste this URL:
https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora

JP
User offline. Last seen 2 years 24 weeks ago. Offline
Joined: 2011-10-31
Posts:

I've reinstalled all from
http://download.librdf.org/binaries/debian/unstable/
And now I've got this message:
raptor_sequence.c:385: (raptor_sequence_get_at) assertion failed: object pointer of type raptor_sequence is NULL.

=(

seablade
User offline. Last seen 2 hours 1 min ago. Offline
Joined: 2007-01-22
Posts:

@jp...

Did you take my advice and download the binary from here yet? There is a specific API problem between libraptor and librdf that you need specific combinations of the two to work, which is also why Ardour is moving away from them as a solution.

Seablade

paul
paul's picture
User offline. Last seen 1 day 15 hours ago. Offline
Joined: 2006-03-16
Posts:
@jp: you will not fix this issue by messing around with your system libraries like that (and you may break other software in the process). The problem, as correctly described by Seablade, is a bug with the system versions of two libraries, one of which is incompatible with the other. The solution is either to get updates from your distro (this has been fixed by now on most distros), or do as Seablade said and get the ready-to-run bundle from http://ardour.org/download which will not have this problem. Please stop messing around with your system in this way - its dangerous.
pat1
User offline. Last seen 2 years 22 weeks ago. Offline
Joined: 2011-11-05
Posts:

Bug reported to fedora team:
https://bugzilla.redhat.com/show_bug.cgi?id=751056

and ardour team:
http://tracker.ardour.org/view.php?id=4437

Paolo