Jack will not load

5 replies [Last post]
PorpoiseSeeker
User offline. Last seen 2 years 41 weeks ago. Offline
Joined: 2011-05-30
Posts:

I am trying to get Ardour going in a MacBookPro with OSX 10.6.8; successfully downloaded and installed
JackOSX.0.87_64-32bits.pkg.

I set up an aggregate device with internal audio.

Ardour cannot start Jack. I can start Jack separately, but Ardour will not run then either.

I have followed cryptic instructions involving a restart, but that is to no avail.

I'm out of airspeed and ideas -- to quote a pilot friend.

What do to next?

Thanks

Gary

seablade
User offline. Last seen 1 hour 10 min ago. Offline
Joined: 2007-01-22
Posts:

So out of curiosity, what is the chance you have installed either MacPorts or Audacity?

But aside from the answer to that(Which are two shot in the dark situations with similar symptoms) jump on IRC and ask on there, I should be around again starting on the 5th daytime EST for a while I suspect. But go ahead and post the answer to the above here as well just in case in the meantime;)

Seablade

PorpoiseSeeker
User offline. Last seen 2 years 41 weeks ago. Offline
Joined: 2011-05-30
Posts:

Thanks

Audacity 1.3.13-beta (Unicode) is installed as well as native Garage Band. So far I have not seen any adverse interactions between GB and Audacity. Have never attempted to use JACK before. Am not familiar with IRC so don't know where to jump.

I sometimes use a Line 6 recording box that employs GearBox which seems to be required between CoreAudio and Audacity -- why is a mystery as I use this same MacBook (and either Audacity or GB) with a Mackie 1640i with no intervening app.

So Gearbox is installed but is not running

seablade
User offline. Last seen 1 hour 10 min ago. Offline
Joined: 2007-01-22
Posts:

Do me a favor and give me the output of this command in terminal surrounded by CODE tags...


ls -lta /usr/local/

There has been a problem that I suspect comes from Audacity's plugin installers in as far as permissions, one that I don't think doing a repair permissions will fix, it has to be fixed manually. But it comes up every now and then, essentially they are installed with the wrong permissions in the same location Jack is normally installed to, and as a result accessing Jack can be a pain. If this is indeed the problem it may be a quick fix, but if not Ill see you on IRC;)

No clue about GearBox though, have never heard that one.

Seablade

jfick
User offline. Last seen 2 years 34 weeks ago. Offline
Joined: 2011-08-21
Posts:

Hello,

I have the same issue here and I do have audacity as well. Here is the terminal print out...

ls -lta /usr/local/
total 0
drwxr-xr-x 5 root wheel 170 Aug 21 10:05 .
drwxr-xr-x 47 root wheel 1598 Aug 21 10:05 bin
drwxr-xr-x 43 root wheel 1462 Aug 21 10:05 lib
drwxr-xr-x@ 13 root wheel 442 Jul 31 10:32 ..
drwxrwxr-x 3 bradrobin admin 102 Apr 13 10:13 include

still have that fix as repair permissions did not help me out?

thanks

seablade
User offline. Last seen 1 hour 10 min ago. Offline
Joined: 2007-01-22
Posts:

Hmm that doesn't look wrong there, so my suggestion is going to be to get on IRC (See the Support tab above) and catch me or someone else there, as this could be tricky to sort out what is going on.

In the meantime however, can you start Jack manually? And Ardour cannot connect to it in such a situation? Or if you can't start Jack, can you open a console (Applications>Utilities>Console.app) and press Clear and attempt to start Jack, then copy and paste the text there to here within PRE tags? Thanks.

Seablade