Very strange problem with Mulitface II

11 replies [Last post]
Erdie
Erdie's picture
User offline. Last seen 4 days 20 hours ago. Offline
Joined: 2006-03-27
Posts:

I am using the Multiface on a cardbus adapter since years without issues. Long ago, i used it with PCI at a desktop, too.
Now i got a new desktop for recording an mixing in my home studio because I still have the PCI card. I build the system with same architecture (amd64) as on the laptop. Everything worked at first..

Because the Multiface is build in a case, it was painful to switch the cables between cardbus and PCI usage. Therefore i build an firewire extension with Neutrik connector where the Multiface was connect with 1m cable internally. Because the length is critical I tested with both cards:

On cardbus it works like everytime. On PCI the firmware was loaded (yellow lights blinking) but I cant start hdspmixer (1.0.23), it crashes with buffer overflow - although I can use the card, start jack, record, everything ! - but hdspmixer doesnt work anymore.
Therefore i switched back to the old hardware config, with means, i connected to firewire cable directly to the Multiface .. but the hdspmixer issue still exists !!!

Afterthat i upgraded alsa-tools to 1.0.24. Trying again, hdspmixer says: "uninitialized RME card found" use hdsploader and so on. hdsploader says "Hwdep ioctl error on card hw:1" which normally means, the firmware wasn´t loaded, but it was ! I can start jack, i can use Ardour and I can record but i cant start hdspmixer, which is a showstopper, as you now, because the Multiface keeps silent :(

Does anybody has an idea what this could be? I am already thinking about an hardware issue. When struggling with the cables i accidently unplugged the firewire cable while the computer was running, could this have been damaged my PCI card?

Thanks
Erdie

cajmere
User offline. Last seen 23 hours 15 min ago. Offline
Joined: 2009-04-30
Posts:

What distribution is it?

I also having problems(debian amd64 testing/unstable) since i upgraded to 1.0.24.

Check
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=641351

i'm going to try build from daily snapshot.

cajmere
User offline. Last seen 23 hours 15 min ago. Offline
Joined: 2009-04-30
Posts:

i've juist build it from git, and it works again :).

If you don't have git installed on your system, install it :).
on commandline just do(in case of a debian-based(debian, ubuntu etc system)

$ sudo apt-get install git

if git is installed:

$ git clone git://git.alsa-project.org/alsa-tools.git alsa-tools
$ cd alsa-tools/hdspmixer/
$./gitcompile --prefix=/usr
$ sudo make install

it will overwrite your existing hdspmixer binary.
If you'll get an update for alsa-tools-gui you'll probably will have to reinstall it, unless it's alsa-tools-gui 1.0.25 :).

Erdie
Erdie's picture
User offline. Last seen 4 days 20 hours ago. Offline
Joined: 2006-03-27
Posts:

Hi,
i am using Gentoo, where everything will be build from source.So if I downgrade and upgrade again, it is fresh builded everytime. Why should it stop working if nothing was changed on the software? My guess is that it is not a software problem, but I could be wrong .. I will try the git version.

Erdie
Erdie's picture
User offline. Last seen 4 days 20 hours ago. Offline
Joined: 2006-03-27
Posts:

It is unbelievable - THE GIT VERSION WORKS !
Oh my god, i had never believed that this could be the reason since i cant remember that I changed anything to the software configuration. Why do the old versions work on my laptop though?

tyvm
Erdie

EDIT: I found a hint in the alsa bugtracker that this was caused be a glibc change. I could be that i made a glibc update recently but did not remember o:)

allank
allank's picture
User offline. Last seen 6 weeks 2 days ago. Offline
Joined: 2006-12-07
Posts:

Hi Erdie,

Very likely you have done a glibc update.. This seems to be commonly included with updates (emerge --update --deep world)...

If you have different use flags or keywords (~amd64 keywords against packages in /etc/portage/package.keywords) or if you have simply done your latest emerge on the boxes at different times, this could explain it....

A few tips with Gentoo (i've been using it for about 7 years now)..

a) Use one box as your local portage mirror .. (see Gentoo Documentation list page and look for home router guide for tips on how to do this).. Then only update one of your boxes at a time (the one you use least) and iron out any problems on that first

b) Keep your USE flags consistent across boxes used for the same purpose.

c) minimize optimizations ..

d) Join the gentoo pro-audio mailing list.. (and install the overlay)...

I would probably still recommend sticking with a 32 bit for compatibility sake.. (alot of the overlay ebuilds don't work in 64 bit)... but if you are sticking to a basic ardour with plugins arrangement then 64 bit is fine.

cheers

Allan

Erdie
Erdie's picture
User offline. Last seen 4 days 20 hours ago. Offline
Joined: 2006-03-27
Posts:

Thanks Allan,

yes, I did a glibc update. But, as you now, normally you never have trouble with that and it runs between coffee and toast without thinking about. Therefore I did not keep it in my mind.
My strategy is to use 2 laptops on the road and update the 1st one and if it works, continue with the 2nd one. These machines are higher priority because I am using them on the road. If the desktop at home has a issue I will normally have the time to fix it. The second laptop is just laying around, i will have to prepare it. It is an old CoreDuo machine with 1Gig RAM so 32bit could be the better choice. Anyway i will think about your suggestion.

Cheers
Martin

mcgruff
User offline. Last seen 1 year 3 weeks ago. Offline
Joined: 2008-08-30
Posts:

Thanks cajmere :)

Another gentoo / pro audio overlay user here. I just received an old Multiface I today and couldn't get a sound out of it until I followed your advice in post #2. Working fine now.

Erdie
Erdie's picture
User offline. Last seen 4 days 20 hours ago. Offline
Joined: 2006-03-27
Posts:

Hi,
I know the reason exactly now.
I wasn't the glibc update. It was the switch from gcc 4.4 to gcc 4.5.3. On another computer I made the same update first and hdspmixer worked even the update was done. After a rebuild the whole system with gcc 4.5.3-r1, the hdspmixer did not work anymore and i needed to use the git version.

Just FYI

-Erdie

calimerox
calimerox's picture
User offline. Last seen 14 hours 13 min ago. Offline
Joined: 2007-10-19
Posts:

@ cajmere:

I have the same problem getting hdspmixer to run on linux mint debian 64bit.
I followed your advice but when i try:
$./gitcompile --prefix=/usr

I get " stat for „/usr/share//install-sh“ not possible: file or directory not found.

any idea?

Erdie
Erdie's picture
User offline. Last seen 4 days 20 hours ago. Offline
Joined: 2006-03-27
Posts:

I would prefer just to compile hdspmixer without installing. You can then just copy the binary "hdspmixer" from your source tree to /usr/bin/ or whatever your stuff ist located. Make sure that the original package is still available and just update this file. This will make sure that the dependencies are existing on your system.

calimerox
calimerox's picture
User offline. Last seen 14 hours 13 min ago. Offline
Joined: 2007-10-19
Posts:

thanks erdie, i ll give it a try monday when im back on my desktop pc....