Problem with GLIBCXX_3.4.11

5 replies [Last post]
chapolin
chapolin's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2006-04-26
Posts:

Hello,

I try to install ardour 2.8.12 on my system but I have a problem.

There is a part of the message error:

"Ardour_x86_64-2.8.12_10146/bin/ardour-2.8.12: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by Ardour_x86_64-2.8.12_10146/bin/ardour-2.8.12)"

However when I do

locate libstdc++.so.6

it tell

chapolin@pgo:~$ locate libstdc++
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.9

Can you help me ?

Thank you by advence

paul
paul's picture
User offline. Last seen 2 days 22 hours ago. Offline
Joined: 2006-03-16
Posts:

@chapolin: you are using a version of Linux that doesn't have a new enough version of libstdc++. This was reported on IRC the other day by a user of Red Hat Enterprise Linux. The relevant version of libstdc++ has been out for some considerable time, so your distribution's version must be rather old. What distribution is it, and what version of it does your package manager say is installed?

chapolin
chapolin's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2006-04-26
Posts:

Thank you for the answer.
My distribution is Ubuntu Hardy 8.04 and my package manager say it is libstdc++ 4.2.4 .
Currently I have installed ardour 2.8.11.

paul
paul's picture
User offline. Last seen 2 days 22 hours ago. Offline
Joined: 2006-03-16
Posts:

@chapolin: I'm afraid that this is way too old. I may release 2.8.13 with less "current" requirements, but until then you'll need to either (a) wait for Ubuntu to package 2.8.12 for 8.04 (b) build it yourself (c) find someone who has an upgrade for libstdc++. Note that (a) seems unlikely because Hardy's support on the desktop ended in April of this year.

chapolin
chapolin's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2006-04-26
Posts:

Arf ... ok I will try to update my ubuntu !
Thanks a lot for your work with Ardour !!

chapolin
chapolin's picture
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2006-04-26
Posts:

I udpdated my ubuntu 8.04 to 10.04 and now it work fine !