Ardour and Mixbus not showing up in ALSA tab in Jack?

7 replies [Last post]
LeatusPenguin
User offline. Last seen 3 days 4 hours ago. Offline
Joined: 2010-12-16
Posts:

I have my main computer working on Ubuntu 10.04 with no problems but have been testing out how Ardour and Mixbus on Xubuntu 11.10 to see how it is working. Works very well from what i can see although one thing has me confused. I tried to do midi binding only to find that in the ALSA tab of jack (whatever version comes in the 11.10 repos) neither Ardour or Mixbus show up, making it not possible to do my bindings. Is this to do with newer versions of Ubuntu or is this something in Jack or even a change in functionality that i have yet to figure out how to use?

LeatusPenguin
User offline. Last seen 3 days 4 hours ago. Offline
Joined: 2010-12-16
Posts:

Any suggestions?

Edward Diehl
User offline. Last seen 1 day 23 hours ago. Offline
Joined: 2007-02-01
Posts:

I would suspect something is screwed up with your Alsa configuration. I would examine the QJackCtl messages window for errors, and also start Ardour/Mixbus from the command line and look for error messages on the terminal screen. Also you could start some other Alsa midi application and see if it shows up in the Alsa tab. Another check is to run the command "aconnect -i" from a terminal which will list the alsa midi connections. Possibly, QJackCtl is not displaying them for some reason. For example, when I run ardour2 I see this:
$ aconnect -i
client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
client 130: 'ardour' [type=user]
0 'control '
1 'mcu '
2 'seq '

LeatusPenguin
User offline. Last seen 3 days 4 hours ago. Offline
Joined: 2010-12-16
Posts:

Tried starting Mixbus from the terminal -

loading default ui configuration file /home/conor/.ardour2//ardour2_ui.conf
loading user ui configuration file /home/conor/.ardour2//ardour2_ui.conf
Loading ui configuration file /opt/Mixbus-2.0.5_10657/etc/ardour2_ui_dark.rc
ardour: [INFO]: Mixbus will be limited to 4096 open files
loading system configuration file /opt/Mixbus-2.0.5_10657/etc/ardour_system.rc
loading user configuration file /home/conor/.ardour2//ardour.rc
ALSA lib conf.c:3272:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib seq.c:935:(snd_seq_open_noupdate) Unknown SEQ default
ardour: [WARNING]: The ALSA MIDI system is not available. No ports based on it will be created
ardour: [WARNING]: No MMC control (MIDI port "default" not available)
ardour: [INFO]: Using SSE optimized routines
/home/conor/.ardour2/lv2/:/opt/Mixbus-2.0.5_10657/etclv2/:/opt/Mixbus-2.0.5_10657/lib/surfaceslv2/:/opt/Mixbus-2.0.5_10657/lib/pannerslv2/
Scanning folders for bundled LV2s: /home/conor/.ardour2/lv2/:/opt/Mixbus-2.0.5_10657/etclv2/:/opt/Mixbus-2.0.5_10657/lib/surfaceslv2/:/opt/Mixbus-2.0.5_10657/lib/pannerslv2/
/home/conor/.ardour2/lv2/:/opt/Mixbus-2.0.5_10657/etclv2/:/opt/Mixbus-2.0.5_10657/lib/surfaceslv2/:/opt/Mixbus-2.0.5_10657/lib/pannerslv2/
VST_PATH not set, defaulting to /home/conor/vst:/usr/local/lib/vst:/usr/lib/vst
ardour: [INFO]: looking for control protocols in /opt/Mixbus-2.0.5_10657/lib/surfaces
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
ardour: [INFO]: Mackie: No MIDI port called mcu
ardour: [INFO]: Control protocol Mackie not usable
Checking for Announcements from www.harrisonconsoles.com ...

Checked midi ports in the preference window and none are showing up. I clicked on add midi port. It comes up with a dialogue box. I tried adding a port but when i clicked add nothing happened.

LeatusPenguin
User offline. Last seen 3 days 4 hours ago. Offline
Joined: 2010-12-16
Posts:

Also this -

$ aconnect -i
client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
client 20: 'M Audio Delta 1010' [type=kernel]
0 'M Audio Delta 1010 MIDI'

LeatusPenguin
User offline. Last seen 3 days 4 hours ago. Offline
Joined: 2010-12-16
Posts:

I don't have this problem with Ardour 2.8.11. It's with Ardour 2.8.12 and Mixbus 2.0.4. I started up Ardour 2.8.11 from the terminal and got this if it helps -

loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/conor/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 4096 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/conor/.ardour2/ardour.rc
ardour: [INFO]: No H/W specific optimizations in use
VST_PATH not set, defaulting to /home/conor/vst:/usr/local/lib/vst:/usr/lib/vst
ardour: [INFO]: looking for control protocols in /home/conor/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
ardour: [INFO]: Control protocol Tranzport not usable
ardour: [INFO]: Control surface protocol discovered: "Mackie"

Edward Diehl
User offline. Last seen 1 day 23 hours ago. Offline
Joined: 2007-02-01
Posts:

You can clearly see that your problem is here:
ALSA lib conf.c:3272:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so

Looks like an Alsa/pulse issue. Many people suggest removing pulse if you want to do pro audio. However, supposedly they can be run together. With Ubuntu I suggest installing the kxstudio packages which will give you a much better audio set up.

LeatusPenguin
User offline. Last seen 3 days 4 hours ago. Offline
Joined: 2010-12-16
Posts:

@ Edward Diehl

Thanks for the help. If I disable pulse audio on start up i don't have this issue so it appears that is indeed the issue.