'jack_latency_callback_mode_t' error when building from source

7 replies [Last post]
cflor
User offline. Last seen 2 years 17 weeks ago. Offline
Joined: 2011-12-13
Posts:

I followed the instructions to build ardour with vst support from source under Ubuntu 11.04.

after getting a bunch of unexpected dependencies straightened out, scons seemed to be configuring fine until this:

libs/ardour/audioengine.cc: In member function ‘int ARDOUR::AudioEngine::start()’:
libs/ardour/audioengine.cc:182:87: error: invalid conversion from ‘void (*)(jack_latency_callback_mode_t, void*)’ to ‘int (*)(jack_latency_callback_mode_t, void*)’
libs/ardour/audioengine.cc:182:87: error: initializing argument 2 of ‘int jack_set_latency_callback(jack_client_t*, int (*)(jack_latency_callback_mode_t, void*), void*)’
libs/ardour/audioengine.cc: In member function ‘int ARDOUR::AudioEngine::reconnect_to_jack()’:
libs/ardour/audioengine.cc:1329:79: error: invalid conversion from ‘void (*)(jack_latency_callback_mode_t, void*)’ to ‘int (*)(jack_latency_callback_mode_t, void*)’
libs/ardour/audioengine.cc:1329:79: error: initializing argument 2 of ‘int jack_set_latency_callback(jack_client_t*, int (*)(jack_latency_callback_mode_t, void*), void*)’
scons: *** [libs/ardour/audioengine.os] Error 1
scons: building terminated because of errors.

I don't have a clue on how to solve this.
i am also frustrated, since I paid $20 for the download of the source, and am not able to get this build done. Any advice would be appreciated

thanks, chris

seablade
User offline. Last seen 7 hours 23 min ago. Offline
Joined: 2007-01-22
Posts:

Well first things first, you don't need to pay to download the source. You can either download from the website, or you can checkout from SVN.

Second, is this Ardour2 or Ardour3? I am assuming A2 since you are building with scons, but want to make sure.

Beyond that I will leave it to Paul to comment on this one as I am not sure how what I am seeing could happen though I probably should know.

Seablade

paul
paul's picture
User offline. Last seen 31 min 1 sec ago. Offline
Joined: 2006-03-16
Posts:

cflor: the most likely issue is that you don't have a new enough version of JACK. This should have been checked for during the configuration part of the build. What does jackd --version say? Also: a warning - many (not all) people find Ubuntu 11.04 totally unsuitable as a platform for doing low latency, realtime audio work. You may find more issues with this later (or you may not).

Finally, there's little reason to build Ardour from source unless you want to track SVN. You're attempting to build Ardour 2, which is now in maintainance mode, and will not change much in SVN at all. Is there a reason you're building the source from the tarball rather than just using the ready-to-run bundle?

cflor
User offline. Last seen 2 years 17 weeks ago. Offline
Joined: 2011-12-13
Posts:

thanks for the quick reply seablade, paul.

- I am building v 2.8 from source, since I want to integrate VST support, and the instructions I found mentioned that was necessary. is there a bundle that supports VST out of the box?
- if there is, how do i get around paying again, since i already paid for the tar ball ;)

- I tried this with both versions of jackd available through synaptec, but it looked like the build failed earlier on in the game when using jack version 2. this error happened with jack 1.9.7

and thanks for the advice on ubuntu 11.04. i have switched to gnome desktop to have unity not eat up too many resources, but i will switch to a different distro. i was thinking about using avlinux anyway.

cheers, chris

paul
paul's picture
User offline. Last seen 31 min 1 sec ago. Offline
Joined: 2006-03-16
Posts:
@cflor: this looks like a compiler problem to me. It has not been reported before and does not happen on any of the 2.X builds that I perform. http://ardour.org/download_full describes how to get the source from SVN.
rpatros
rpatros's picture
User offline. Last seen 1 year 9 weeks ago. Offline
Joined: 2008-05-30
Posts:

@cflor,

I would try installing AVLinux 5.0.2 distribution which should already have Ardour with VST support. This is more optimized for audio workflow than straight ubuntu.

As Paul mentioned you might still run into other issues.

Rony P.

cflor
User offline. Last seen 2 years 17 weeks ago. Offline
Joined: 2011-12-13
Posts:

thank you rony, paul.

i think i will give AVLinux a try tonight. seems like that could be the easiest way to go about this.
i am still early in the process of setting up this box, so i might as well do it right from the start.

cheers, chris

linuxdsp
linuxdsp's picture
User offline. Last seen 4 days 16 hours ago. Offline
Joined: 2009-02-04
Posts:

if you try AVLinux, you'll also get a lot of plugins pre-installed, including the linuxDSP plugins:

http://www.linuxdsp.co.uk

so you might find you don't need Windows VST support at all :)