BR800 control surface

14 replies [Last post]
murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

Hi all

I am trying to use my BR800 as a control surface in Ardour. I have selected Control Surface in the BR800, then opened Ardour and selected Mackie control, but I get no movement on the mixer when I use the slide controls on the BR800. What am I doing wrong? Any tips/advice welcomed
Cheers

paul
paul's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

@murph847: Did you connect the BR800 to the Ardour "mcu" MIDI port?

murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

No, I don't think so. Will check, cheers.

murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

I have found the midi port preferences, and have highlighted the buttons along side mcu, and trace input. Is this correct? Am new to all of this!!

seablade
User offline. Last seen 5 hours 58 min ago. Offline
Joined: 2007-01-22
Posts:

No trace is not what you want, but let me stop you now and ask a question.. Looking at the site for the roland br800 it seems very unlikely this supports the mackie or logic control protocols, are you certain it does? If it doesnt you should be using the generic midi protocol anyways.

paul
paul's picture
User offline. Last seen 3 hours 7 min ago. Offline
Joined: 2006-03-16
Posts:

there's substantial evidence if you google for "roland br800 mackie control" that this thing emulates a mackie control. its not clear how well - i saw some reports from users of other DAWs that had some issues, but it could have been the users :)

seablade
User offline. Last seen 5 hours 58 min ago. Offline
Joined: 2007-01-22
Posts:

Hmm I stand corrected, that would he the first I know of that doesn't have motorized faders, which by the way I make no promises about how well Ardour will work with that as a result, it has never been tested without motorized faders to my knowledge.

murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

Hmm ok thanks for your help anyway. I will have a play about and dig around and no doubt be back here for help again!!

seablade
User offline. Last seen 5 hours 58 min ago. Offline
Joined: 2007-01-22
Posts:

Ok now that I am on an actual computer instead of a tablet...

Are you on OS X or Linux? What you need to do is patch from the mcu ports to your Roland and vice versa. How this is accomplished varies depending on the platform. If you use QJackCTL on Linux, you could use that to patch the MIDI ports(It can be set to allow patching of ALSA midi). On OS X you will need Pete Yandell's MIDI Patchbay or similar, which is a free download, and can use that to patch the ports.

I will be interested to hear how well this works for you, as I said I can't make any promises on how well Ardour will work with the Logic protocol and a surface that doesn't have motorized faders, it might make some rather interesting problems.

Seablade

murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

I am using a Macbook Pro on Lion. I have Jackpilot installed and have followed guidance to use the BR800 as an Aggregate device as the MIDI input. From looking around a few people have had the same problems as me, but they are using Cakewalk Sonar on PC which is even supplied with the unit! I will try again over the weekend to see if I can get it working. I will have a look at MIDI Patchbay as well to see if it's much different to JackPilot.
Thanks again for your tips and help, I will keep you informed as I progress. If (when) I get it working i will let you know how I did it!

seablade
User offline. Last seen 5 hours 58 min ago. Offline
Joined: 2007-01-22
Posts:

JackPilot does nothing for Patching MIDI ports, you will need to use MIDI Patchbay as I mentioned above. Also the aggregate device thing is only for Audio I/O it does not apply or is recommended for MIDI devices. Otherwise no standalone control surface would work very well in OS X without being an aggregate device(And the reasoning behind the aggregate device aspect of things would never apply to MIDI unless someone REALLY broke things).

Seablade

murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

Ah I see, ok I will have to download Patchbay and take it from there then. Many thanks for helping me out here!!

murph847
User offline. Last seen 2 years 13 weeks ago. Offline
Joined: 2011-12-31
Posts:

Limited success!! I can now play my guitar through my BR800 and get a waveform etc on the screen!! However I still cannot get the sliders to do anything! Thanks again for your help so far!

nardelli
User offline. Last seen 1 year 32 weeks ago. Offline
Joined: 2012-02-08
Posts:

Hello,

I have the same issue of Murph but I'm using Linux :/
My BR-800 doesn't appear on the QjackCTL Alsa MID tab.

Any Idea?

Thanks!

nardelli
User offline. Last seen 1 year 32 weeks ago. Offline
Joined: 2012-02-08
Posts:

Any Idea on how can I make the QjackCTL to recongnize the BR-800?