Best computer settings?

7 replies [Last post]
Russ
Russ's picture
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2011-05-09
Posts:

To begin, I'm not a recording or computer guru by any stretch of the imagination but I'm trying to configure my computer as best for "My computer" ;). I've been reading alot on these, and other, forums about limits.conf, cpu performance, and killing pulseaudio. I've read so much my head is swimming and I just need someone,if possible, to tell me what I need to set my computer/software to have it at its peak performance. I bought this computer as mainly for recording.
I have AMD Phenom(tm) II X4 955 Processor, 12Gigs memory, Western Digital 250Gig hd, Asus motherboard(ASUS M4A89GTD PRO/USB3 AM3 AMD 890GX SATA 6Gb/s USB 3.0 HDMI ATX), running ubuntustudio 11.04 with 3.0.0-13-lowlatency kernel. When I record I use a USB 2.0 microphone cable straight to my computer with a SM58 mick- http://www.amazon.com/LightSnake-STUSBXLR10-USB-Microphone-cable/dp/B000H7O9ZI. I know this is not the "ideal" way to record, but it records o.k.(I'm on a tight,tight budget so it's what I have, for now). I mainly just record guitar or vocals from my amp into the mic to the computer. The sound is not bad at all. I just want to get the best performance as possible with this set up. What I'm running into are x-runs, like every 8sec or so. I have tried all sorts of different settings ex.frames/periods 128-1024(thru), sample rate -48k- 32k, periods/buffer 2-4. Of course, some of the higher settings(ALOT, more latency,upwards of 84ms). I record, while listening to the recording(duplex, I guess), but if the latency is off, it doesn't work well. Plus, I have x-runs.
I've read that I should try and kill pulseaudio before I run jack. I guess because two audio servers trying to run my give x-runs(again, I'm not a guru) My settings for limits.conf(pulseaudio) I have:
; autospawn = no
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

When I try and kill pulseaudio(pulseaudio -k) it comes back immediately. I'll play aqualung,after I kill pulse, and it shows Output: pulseaudio.Do I need to kill Pulseaudio? How can I really kill it?

I'm not sure about "user groups" settings. I'm going to sys>adm>users/groups>manage groups and then it lists"groups available on this system". My name(group member) is checked for audio,admin,pulse,pulse-access,my name(russell),sudo. I'm guessing this is what is meant for being in "user/groups".
I know this is alot of info on one fail swoop, but I'm just at a loss. I think this computer can handle what I'm throwing at it. I guess........... If anyone thinks not, please let me know and I'll try a different route. I don't know what that would be ;), but I'd figure something.
I've also thought about using 64 studio OS or AV linux for this computer. What are some thoughts on that?
Again, thanks for any help.

Russ
Russ's picture
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2011-05-09
Posts:

Also, when I try to run Ardour with frames:128, sample rate: 48000,periods/buffer:3,port max:512, Lantency=8sec,force 16bit(checked),unlock memory(checked),realtime(checked), it won't run:

ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 3 periods for playback
18:45:15.893 Could not connect to JACK server as client. - Overall operation failed. - Server communication error. Please check the messages window for more info.
18:45:15.954 JACK is stopping...
JackProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
JackSocketClientChannel read fail
Cannot create new client
Cannot open qjackctl client
jackd: ../common/JackGraphManager.cpp:45: void Jack::JackGraphManager::AssertPort(jack_port_id_t): Assertion `port_index < fPortMax' failed.
18:45:15.968 JACK was stopped successfully.
18:45:15.982 JACK has crashed.
But if I change the settings to frames:512, sample:41000, buffer:4,port:512(all else checked,again), Latency=46.4sec it runs.
It will run in the lower latency settings if I run in just playback or capture but not in duplex. How can I record other parts without hearing what is recorded?

nowhiskey
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2006-09-30
Posts:

hallo,

i think there is nothing wrong with pulseaudio. if pulse wuld be running, jack just would not start. that's all...

i am the most sceptical about your usb-to-mic-cable. never saw one like this, but obviosely it has the function of a soundcard / ad-converter.

would you mind opening a terminal and typing:

cat /proc/asound/cards

while the cable is pluged in and than copy+paste the output here.

the other thing which could cause problems is your distribution. i am not using any flavor of ubuntu but in this and other forums too i heard that people often having troubles with it. but before reinstalling the os, perhaps there is someone else who can give you a better advice.

cheers,

doc

Russ
Russ's picture
User offline. Last seen 1 year 5 weeks ago. Offline
Joined: 2011-05-09
Posts:

Thank you nowhiskey for the reply. This is my output.

russell@ubuntu:~$ cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfcff8000 irq 16
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfe67c000 irq 19
2 [U0x19400xac02 ]: USB-Audio - USB Device 0x1940:0xac02
USB Device 0x1940:0xac02 at usb-0000:00:13.0-2, full speed
russell@ubuntu:~$

Also, if I do change my OS(which I would like some feed back as to the best for my computer) can I keep the recordings I've already done. I really want to keep the files and just put them back into ardour. Is it as simple as putting the audio files on cd or flash drive and putting them back into ardour?
Sorry I'm giving so much info, I'm just trying to find out what is best. I also rewatched an ardour tutorial @http://vimeo.com/2867399 and he said to set my server path to "jackdmp" because it's better for multicore processors. I tried this and now ardour won't open.

nowhiskey
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2006-09-30
Posts:

hallo,

you can backup your hole ardour session (folder) where ever you want and after reinstalling your os start it from there or copy it back to the hard drive where you usually want to save your ardour sessions. that's all easy.

i used to work with jackdmp some years ago, but since them i am on jack1 back again, so i am really not experienced enough to tell you why jack does not start in later case.

obviosly, looking at the output of cat, your cable is well recognised. the question remains, how well is it supported by alsa. no idea...

wait and see what other people may say.

cheers,
doc

Benjamin Scherrer
User offline. Last seen 1 day 11 hours ago. Offline
Joined: 2006-07-27
Posts:

Hi Russ,

I've found this thread about your usb-cable:

http://ubuntuforums.org/showthread.php?t=1763633

and it seems to be very complicated. My guess is that this usb-soundcard-cable is not capable of running at low latency, at least not very stable. Additionally, it's only a capture device, so jack needs to use your usb-cable as capture and your onboard soundcard as playback device at the same time. This setup does not feel low-latency safe to me, although I have never run something like that and it's theoretically possble.

Maybe someone knows a solution, but I think the best way is to avoid low latency: In most situations, you don't need it. If you play your guitar, you hear it through your amp anyway, so you don't need Ardour to play it back at all. After you have recorded one guitar, you can play it back and play another guitar part on top of it. You will hear the recorded guitar through your speakers and the guitar you are playing through your amp. Ardour will compensate the latency, so both guitar parts will play back correct afterwards.

About jackdmp: I think this is dated, I use jack2 and it doesn't even come with the jackdmp command anymore, simply use "jackd".

Best
Benjamin

nowhiskey
User offline. Last seen 4 weeks 6 days ago. Offline
Joined: 2006-09-30
Posts:

perhaps staring jackd in 'capture only' mode and see if it is running any better, with less xruns?

cheers,

doc

Benjamin Scherrer
User offline. Last seen 1 day 11 hours ago. Offline
Joined: 2006-07-27
Posts:

It probably will, but with capture only, you cannot play back anything at all, so it's pretty much useless for him.

Benjamin