How do I hook up a mic/configure jack/start recording?

9 replies [Last post]
ninjaraptorbaby
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: 2012-03-05
Posts:

I'm running Ubuntu Studio. I have no idea how jack even works at all. I'm trying to use a rockband usb mic to record in ardour, but I have no idea how to get jack to put the mic as an input to ardour. All the tutorials and what not I've seen assume I'm not a noob and know how to use jack, so I'm asking you guys to explain step by step what to do from the time I plug in the mic to the time I hit record. Help is GREATLY appreciated.

paul
paul's picture
User offline. Last seen 6 hours 51 min ago. Offline
Joined: 2006-03-16
Posts:

@ninjaraptorbaby: if you have not read it (which seems possible) i strongly suggest that you read the Tutorial Manual linked at http://ardour.org and within Ardour itself under the "Help" menu item.

Regarding the use of a USB mic, this is not something we recommend. Please read http://jackaudio.faq/multiple_devices for more information on why its not a good idea. Ardour isn't targetting the kind of work where USB microphones are appropriate input devices (though you can use them, its just not very good idea and is more complex than using the right equipment).

LeatusPenguin
User offline. Last seen 1 week 6 days ago. Offline
Joined: 2010-12-16
Posts:

If you have left any of these steps out, give them a try -

Launch Qjackctl and click set up. There are two buttons beside "interface". Click the right arrow one and select your device. You should recognise it by name. Click OK and then start Jack.

Next start up Ardour. Add your tracks. Whichever track you want to record to, click the record/arm button. On the top of the track (mixer view) click on the button above "record" (it should be numbered) and make sure your input is selected. Your track should now be recieving a signal.

As paul said though, Ardour isn't really intended for that kind of use. If you're serious about recording you'd be better off getting a decent audio interface which you could fully utilise with Ardour. If doing so, make sure to read up about what's compatible. Best of luck.

ninjaraptorbaby
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: 2012-03-05
Posts:

I realize that Ardour is meant to be used with a decent external audio interface, but I'm working with what I have available right now. If it can be done with a usb mic, I need to do it that way for now. I did what Penguin said, but when i click on the numbered button above record, the microphone doesn't show up. It just says "1/2", and when I click that no signal is put through at all. Any other suggestions?

Pablo Fernández
User offline. Last seen 50 weeks 5 hours ago. Offline
Joined: 2007-02-20
Posts:

@ninjaraptorba

Yes, 1/2 are the "system" inputs, i.e., the audio card capture ports. Which audio card, though?: The one you told jack to use.

I suspect that jack is using the onboard card instead of the USB mic for input. I think you will need to use jack in "only capture" mode on the usb mic, and then use alsa_out on the onboard card for the playback ports. Or use jack in playback only on the onboard, and then alsa_in on the usb mic.

Anyway, the following are informative commands. If you wish, paste them here for better help

cat ~/.jackdrc
arecord -l && aplay -l

ninjaraptorbaby
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: 2012-03-05
Posts:

Noob question, but can you walk me through setting up the only capture mode and using the also_out? I'm sorry to be such a bother, but I'm learning, lol. I'll enter those commands and paste them when i get home.

Edward Diehl
User offline. Last seen 20 hours 49 min ago. Offline
Joined: 2007-02-01
Posts:

Look at: http://trac.jackaudio.org/wiki/WalkThrough/User/AlsaInOut. You could connect Jack to your USB mic (which if USB1.1 audio compliant will work in Linux) and then to playback to your regular soundcard using alsa_out (which will cause this device to be connected to Jack, and visible in the QJackCtl connections panel, for example). Use command "aplay -l" to list your sound cards (presumably the USB mic and the built-in soundcard).

AudioPhlake
User offline. Last seen 1 year 30 weeks ago. Offline
Joined: 2012-05-07
Posts:

I'm a Ardour newbie as well and struggled with my USB mic- Paul is correct in that Jack is where to go for your connections. Confusing at first, but I get the beauty of the method and the power that goes with it. Go to Jack's setup and find your device in the “Input Device >”, in my case “hw:2,0 USB Audio”. I hope that helps! I've not spent much time yet with Ardour, but am a noise and vibration engineer, so I have some overlap, much new, and in short, am impressed. Nice program, rock stable on my Ubuntu laptop. Gibson time...

theoB
User offline. Last seen 1 year 31 weeks ago. Offline
Joined: 2012-06-06
Posts:

I've done a bit of Ardour before, but would still definitely class myself as a newbie. I am now attempting to record on a different machine, using two mics plugged into a mixer plugged into the mic port of my laptop. How would I set this up for recording?
Help would be greatly appreciated.

troonatnoor
User offline. Last seen 1 year 37 weeks ago. Offline
Joined: 2012-04-19
Posts:

This link and advice looks useful, I will try it when I get home...let me know if you try it and it works as this guy claims... TROONATNOOR.WEBS.COM

https://lists.ubuntu.com/archives/ubuntu-studio-users/2011-February/007286.html

Dear friends/ubuntu-studio-users,

I am writing with great pleasure to inform you that my newly bought T.Bone
guitar-usb cable (the cheapest in the market audio-interface!) works out-of-
the-box!

The solution was only 2 clicks before my eyes! Thanks to all of you who shared
your information and experience with Jack use, I just had to open the setup of
QJack and in the settings tab I just selected the C-Media Electronics usb
device (hw:1) from the Input Device which was recognized by Jack out-of-the-
box. Also in the Output Device I selected my onboard HDA NVIDIA (hw:0) and
there it was!

The sound of my guitar was coming through Rakarack first and then the outputs
of Rakarrak to the System playback_ 1 & 2 (as Tim adviced).
For the record,
those connections were automatically done from Jack anyway.

Thank you all!

Special thanks to Tim who guided me closer to the solution by urging me to
search in Jack for the correct configuration!

To Teza for the record:
Teza wrote: ..."You won't see you usb card or plug in jack...". Surprisingly,
the T.Bone usb was eventually there at the Interface and Input Devices
options!!

https://lists.ubuntu.com/archives/ubuntu-studio-users/2011-February/007286.html