Debian Sid build requirements

2 replies [Last post]
mzilikazi
User offline. Last seen 6 years 50 weeks ago. Offline
Joined: 2006-10-26
Posts:

I *think* this *should* work for Sarge too. YMMV
From a fresh bootstrap assuming you already have X and your favorite WM installed:


# apt-get install alsa-base alsa-tools jackd
qjackctl alsa-tools-gui scons python2.4 gettext
pkg-config libtool autoconf libjack0.100.0-dev
libxml2 libxml2-dev raptor-utils liblrdf0
liblrdf0-dev libsamplerate0 libsamplerate0-dev
libglib2.0-0 libglib2.0-dev libgtk2.0-0
libgtk2.0-dev libsndfile1 libsndfile1-dev
libgnomecanvas2-0 libgnomecanvas2-dev liblo0
liblo0-dev libboost-dev libasound2-dev unp bzip2
unzip zip

Easiest way to get started:

$ wget http://ardour.org/files/releases/ardour-2.0beta6.2.tar.bz2
$ unp ardour-2.0beta6.2.tar.bz2
$ cd ardour-2.0beta6.2
$ scons
$ su
# scons install

No this doesn't create an ardour2.deb for you but it's easy to uninstall w/ scons:

$ cd ardour-2.0beta6.2
$ su
# scons -c install

mzilikazi
User offline. Last seen 6 years 50 weeks ago. Offline
Joined: 2006-10-26
Posts:

Hmm looks like the formatting went to hell. It was fine in the preview....
Can I not edit my own post?

Debian Sid
2.6.18-rt7-k8
AMD64 3200+
2x512M Mushkin PC3200

paul
paul's picture
User offline. Last seen 1 day 5 hours ago. Offline
Joined: 2006-03-16
Posts:

not sure why you can't edit it, but i fixed it for you. the <code> tag in drupal's handling has no automation line wrap, and your apt-get line was rather long.