howto: m-audio fast track pro - 4 simultaneous in/out (44,1/48 khz - 16bit)

4 replies [Last post]
mo_kinky
User offline. Last seen 2 years 3 weeks ago. Offline
Joined: 2008-04-07
Posts:

EDIT: Updated, see Below.

mo_kinky
User offline. Last seen 2 years 3 weeks ago. Offline
Joined: 2008-04-07
Posts:

not sure if somebody posted a similar howto somewhere... at least i didnt find anything...
i was looking to have 4 outputs at the same time which was kind of tricky since the fast track pro natively delivers only two stereo outputs (A and B) to choose from.
with a little alsa hack it worked for me :)

put this to .asoundrc in your local folder
be aware that your hardware address might be different (according to the ouptput of "cat /proc/asound/cards")
the lines marked with ### eventually need to be edited!

pcm.mt4 {
     type multi
     slaves.a.pcm "hw:1,0";       ###
     slaves.a.channels 2;
     slaves.b.pcm "hw:1,1";       ### 
     slaves.b.channels 2;

     bindings.0.slave a;
     bindings.0.channel 0;
     bindings.1.slave a;
     bindings.1.channel 1;
     bindings.2.slave b;
     bindings.2.channel 0;
     bindings.3.slave b;
     bindings.3.channel 1;
}
 
ctl.mt4 {
     type hw; 
     card 1;       ###
}

pcm.multi4 {
     type route;
     slave.pcm "mt4";
     ttable.0.0 1;
     ttable.1.1 1;
     ttable.2.2 1;
     ttable.3.3 1;
}
 
ctl.multi4 {
     type hw;
     card 1;       ###
}

now start jack with:

jackd -R -d alsa -d multi4 -r 44100 -n 3 -p 1024

and voila... you should now have 4 in and 4 out to choose in qjackctl or ardour :)
and they are even synced (as far as i could find out both stereo outputs use the same "clock")
hope it will help somebody :)

btw: my distro is archlinux with kernel 3.2.11

joegiampaoli
joegiampaoli's picture
User offline. Last seen 22 weeks 1 day ago. Offline
Joined: 2008-02-27
Posts:

I have been having a lot of issues with the digital ins and xruns, I will try this next week when I return home from visiting my hometown and see how it goes.

Here a post:

https://ardour.org/node/4822

I have successfully enabled 4 ins with what Paul explains there, but that persistent xrun I have no been able to track it down from where it comes. If I only use the 2 analog ins everything works great.

Thanks for this tip.

mo_kinky
User offline. Last seen 2 years 3 weeks ago. Offline
Joined: 2008-04-07
Posts:

@joegiampaoli
cool... im curious about your feedback...
best, mo

hick518
User offline. Last seen 2 years 1 hour ago. Offline
Joined: 2012-03-25
Posts:

I found another way to do this today. I got it from the first page of this writeup: http://www.noid.net/hydraplayer/docs/08_README.cloning

Here is a summary:

1) In qjackctl, open the Patchbay

2) Create an Input Socket for your default output (playback_1 and playback_2, in my case)

3) Create another Input Socket for the second set of outputs you want to use (playback_3 and playback_4, in my case)
3b) Create a Forward from Input Socket 1 to Input Socket 2

4) Save the Patchbay configuration

5) Activate the Patchbay configuration

I haven't tried it yet for soundcard inputs, but I imagine it would work the same way (just use Output Sockets instead of Input Sockets).