new tracks inserted at wrong spot

2 replies [Last post]
hick518
User offline. Last seen 2 years 3 days ago. Offline
Joined: 2012-03-25
Posts:

I am adding a track to an existing Ardour session. I arm my track for recording, and play along while playing back the already-existing tracks. While recording, my new track appears correctly lined up with the existing material. But when I hit "stop", my new track gets inserted / moved to the playhead location -- which is at the end of the already-existing tracks.

1) How can I make the new track get inserted at the point where recording started?

2) If I can't get an answer to #1, how to I move my new track to be perfectly aligned with the other tracks? The other tracks don't begin at the beginning of the session, and the new track does not start recording exactly at the beginning of the already-existing tracks/regions (because there was a lot of dead space at the beginning of those tracks). If I could move my new track so that it ends at the current playhead location, that would work for me. But so far I can only figure out how to "nudge" the track by a fixed amount.

Thanks for any advice you can give.

seablade
User offline. Last seen 8 hours 43 min ago. Offline
Joined: 2007-01-22
Posts:

It sounds like you might not be in SLIDE edit mode. This is the mode that 90+% of users of Ardour will want to be in most of the time, so confirm this first.

For reference:
http://ardour.org/files/reference/dsy141-ARDOUR.html#dsy33-ARDOUR

Seablade

hick518
User offline. Last seen 2 years 3 days ago. Offline
Joined: 2012-03-25
Posts:

That was it. Thanks for the quick help.

Now that I'm in slide mode, I can move the new tracks easily but they don't seem to want to snap to the marker I created. Snap mode is "magnetic" and snap units is "marks". Edit point is "playhead", but I don't think that's important for what I'm trying to do (but correct me if I'm wrong).

For now I've just zoomed in a lot and manually lined up the end of my new tracks with the marker. But I think there is probably a better way.

By the way, I tried recording another new track in slide mode, and it gets inserted where I expect it to. Thanks again!