Wrong ELF Class

3 replies [Last post]
illusionistlynx
User offline. Last seen 1 year 50 weeks ago. Offline
Joined: 2012-05-01
Posts:

Hello!

Just getting started with Ardour. I'm trying to add some plug-ins for additional functionality and receiving the error, "Wrong ELF Class: ELFCLASS32" which I'm guessing means that the plug-ins are (.so files) are 32-bit and not loading properly. I have the x86_64 version of Ardour. so far, I've been putting the .so files in usr/lib/ladspa and then opening the Plug-in Manager to do a refresh. Not sure if that's the official procedure either, since I'm still learning the ropes.

If anyone knows for sure what the error is or how to properly add plug-ins the help would be much appreciated.

Thanks,
-lynx

Ricardus
Ricardus's picture
User offline. Last seen 6 hours 11 min ago. Offline
Joined: 2009-05-31
Posts:

At 190 cm, I was always too tall for Elf Classes.

GMaq
GMaq's picture
User offline. Last seen 4 days 2 hours ago. Offline
Joined: 2007-12-11
Posts:

Hi

Good one Ricardus!

@illusionistlynx

What distro are you using and why are you manually placing the plugins in their directories? Almost every major distro out there has repository packages of various plugins especially ladspa. The package management should sort out the proper plugins for your architecture.

linuxdsp
linuxdsp's picture
User offline. Last seen 1 day 18 hours ago. Offline
Joined: 2009-02-04
Posts:

@illusionistlynx: You are trying to use 32Bit plugins on a 64Bit system. You need to either find 64Bit binaries of the plugins or recompile them for 64Bit