Saving connections? Exporting audio through external gear?

No replies
rotoquezada
User offline. Last seen 7 years 3 days ago. Offline
Joined: 2006-07-02
Posts:

Hi people,

I encountered a couple of silly/not so silly problems working with ardour 99.3 and ardour2

a) Ardour is not able to restore all of its connections, even internal ones! I made a setup with several buses with some sends and inserts here and there and if I save the session, when I restore it Ardour is not able to restore all connections (Log window says: "AudioEngine: Cannot connect port bla to port blabla"). I tried the same session with Ardour2 & the problem remains. Good luck I'm a man reader and i found jack_snapshot goin' around which kind of solved my problem, but anyway, shoudln't be ardour capable of doing this by itself?

b) On this setup I'm routing some buses through external gear and when I wanted to export the session for CD burning I sadly discovered that the sends and inserts that go through external ports get deactivated while exporting a range on the master track. Is there a way to get sends and inserts going on on "export range". I solved partly the problem looping back the mix on another track and recording it in order to export later that take.

well, greetings and keep the good workin'

Seba.

paul
paul's picture
User offline. Last seen 1 day 4 hours ago. Offline
Joined: 2006-03-16
Posts:

well, export deliberately exists to do faster-than-realtime export, because so many people want that. as a result, its not possible to include external h/w that cannot run faster than realtime. therefore your current method is the only one that will work at this time. it might be useful to have a "realtime" export option available, i am not sure how much work that would be. please file a report in the bug tracker as a feature request so that we don't forget this idea.

the lost connections issue has been a mystery for a long time. i have to say that i have not noticed it with ardour 2 yet. i wish i had more information for you. if you could get on IRC and if you use the subversion repository, we could do some "realtime" debugging and maybe figure out what causes it.