downloading for mac osx, asking for 11x????

13 replies [Last post]
worldwaits
User offline. Last seen 7 years 24 weeks ago. Offline
Joined: 2006-11-06
Posts:

why does it say that requirments are only osx 10.3 or higher, yet when you try to dl it, it requires 11x?

paul
paul's picture
User offline. Last seen 5 hours 41 min ago. Offline
Joined: 2006-03-16
Posts:

because X11 (not 11x) is a part of OS X 10.3 or higher that for some reason Apple makes an optional component that is not installed by default. it is present on the OS X install disk and available for download from Apple.

worldwaits
User offline. Last seen 7 years 24 weeks ago. Offline
Joined: 2006-11-06
Posts:

do you know why when i go to install X11, there is an error saying it cannot be installed because newer software already exists on my computer? seems like a double edged sword.

taybin
User offline. Last seen 41 weeks 4 hours ago. Offline
Joined: 2006-03-15
Posts:

Are you running 10.3 or 10.4?

notwenders
User offline. Last seen 7 years 23 weeks ago. Offline
Joined: 2006-09-11
Posts:

Yes I just had the same problem (with a new Macbook). The ardour site says that X11 must be installed from the 'Tiger DVD'. Do they mean the OS X 10.4 CD?

sampo
User offline. Last seen 11 weeks 1 day ago. Offline
Joined: 2006-03-16
Posts:

It means the disc you got from apple which contains the operating system you are using.

taybin
User offline. Last seen 41 weeks 4 hours ago. Offline
Joined: 2006-03-15
Posts:

Yes. Tiger is the name for 10.4 and it was distributed by Apple on DVD.

Afinlayv
Afinlayv's picture
User offline. Last seen 7 years 19 weeks ago. Offline
Joined: 2006-12-03
Posts:

I am having this same problem. I installed X11 from the Disc. But now Ardour is telling me that I still need to install it, and the installer says I can't install it because there's already a newer version. Am I doing something wrong? is there a way to uninstall and re install X11 and if so would that help?

I look forward to being able to run Ardour

ganjjjj
User offline. Last seen 7 years 12 weeks ago. Offline
Joined: 2007-01-29
Posts:

I've had the same problem as well, did the recommended diagnostic using console. It originally came up with errors regarding 3 different files in the library > quicktime folder. Divx 5.component Motion.component and LiveType.component. I removed the files, and now i get this:

===== Monday, January 29, 2007 11:42:01 AM US/Eastern =====
button returned:OK

Doesnt seem too helpful.

SPH
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2007-02-03
Posts:

I have had the same problem this morning. I've installed Ardour, JackOX (which appears to be running OK) and have installed X11 from the DVD but when I open Ardour it asked me to install X11 from the DVD. I have restarted my PowerBook G4, I've reinstalled Ardour and X11 but still no joy. Any ideas? I'm running 10.4.8 on a 1.25 PowerPC G4 with 512 SDRAM.

Thanks.

taybin
User offline. Last seen 41 weeks 4 hours ago. Offline
Joined: 2006-03-15
Posts:

Could you try launching X11 manually before launching Ardour? Thanks.

SPH
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2007-02-03
Posts:

Thanks for your comment. I tried many ways of doing it all to no avail. I then found a link from one of the comments in this forum to a Chemistry site about crystallography, http://xanana.ucsc.edu/xtal/xcode.html and that gives a link to an download of X11 which worked immediately and which I was then recognised by Apple as needing updating.
The problem had now been solved. I can see that many have had this problem - the solution appears to be out there!

niko123456
User offline. Last seen 5 years 12 weeks ago. Offline
Joined: 2007-01-05
Posts:

Apple released an updated version of X11 approx 2 months ago. Intriguing that it doesn't let you install the "old" version on your install DVD first.

djtallo
User offline. Last seen 6 years 42 weeks ago. Offline
Joined: 2007-06-30
Posts:

i ave the same problem as well i didnt get any disc with macbook pro :(
Cant install x11 on 10.4.9 can’t install it because there’s already a newer version!!!!