About default skin

29 replies [Last post]
skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

Hi Topic, Users & Ardour Devs,

I compiled the last Beta7.1. It works better version by version. I just have a strange question about the Default Skin. Look at this print screen :

http://img528.imageshack.us/my.php?image=ardour2vo8.png

The GTK2 theme is Human under Ubuntu, but it's half Ardour skin, half Ubuntu skin. The visual is horrible for me. I'm not a big fan of this grey skin, so is it a bug or is it the normal appareance ? :-F

Thanks for your work with Ardour2 ! :-)

Stan.

Reuben
User offline. Last seen 4 years 32 weeks ago. Offline
Joined: 2006-03-30
Posts:

No, that's not normal, and it's probably not an issue with Ardour either. I would suspect that it is an Ubuntu issue.

skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

What should I do to resolve the problem ? Bug report in the Ubuntu website ?

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

We are including the plain clearlooks theme in our codebase to make ardour always use that theme engine. Be sure to check out later releases and report back whether this error is fixed.

skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

Hi, Ok I downloaded the svn version but for the moment I have the same problem like this topic http://ardour.org/node/489

I am waiting for the next Beta.

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

What version of svn do you have? Please, run "svn --version" and paste the output here.

skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

svn, version 1.3.1 (r19032)
compiled May 8 2006, 07:38:44

Copyright (C) 2000-2006 CollabNet.
Subversion is open source software, see http://subversion.tigris.org/
This product includes software developed by CollabNet (http://www.Collab.Net/).

The following repository access (RA) modules are available:

* ra_dav : Module for accessing a repository via WebDAV (DeltaV) protocol.
- handles 'http' scheme
- handles 'https' scheme
* ra_svn : Module for accessing a repository using the svn network protocol.
- handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
- handles 'file' scheme

sampo
User offline. Last seen 11 weeks 2 days ago. Offline
Joined: 2006-03-16
Posts:

Is it possible for you to try upgrading to at least 1.3.2 and then trying again?

skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

Re hi,

svn 1.3.2 installed. Ardour2 compiled.... but same result.

skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

Ohhhhhhhhhh... I am testing under Gnome and Ardour displays perfectly. Again a problem with Fluxbox I suppose. It's not the first software which displays incorrectly with Fluxbox.

It sucks.

tdl
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-11-12
Posts:

Hi,
I'm having the same problem with the GTK-Qt engine on Kubuntu 6.10, and I hope that the latest svn version fixes it.. Anyway, when I try to compile the code I got from svn (never used it before ;-) it exits with the following error:

cd libs/sigc++2 && ./autogen.sh && cd -
Building macros.
./autogen.sh: 10: aclocal: not found
Building makefiles.
./autogen.sh: 13: automake: not found
Building configure.
./autogen.sh: 16: autoconf: not found
/home/tuedel/ardour2
cd libs/sigc++2 && ./configure && cd -
sh: ./configure: not found
scons: *** [libs/sigc++2/sigc++config.h] Error 127
scons: building terminated because of errors.

(I'm not opening a new thread, since I suspect this is a rather trivial problem)

Any suggestions?

Seb
Seb's picture
User offline. Last seen 10 hours 26 min ago. Offline
Joined: 2006-04-07
Posts:

as a ubuntu-edgy user, i have switched away from the "human" and to the "clearlooks" scheme a while ago (actually that was in the breezy-badger days) in order to resolve the visibility issue in ardour. I really liked ubuntu's much poo-pooed brown window borders, I am not ashamed to say, but it's not worth it for me to worry too much about, and i much rather have readable (rather than light grey on white) writing in my ardour dialogues.

Long Live Ardour!

Sebastian

taybin
User offline. Last seen 41 weeks 9 hours ago. Offline
Joined: 2006-03-15
Posts:

You need to install automake and autoconf. Make sure you have pkgconfig installed as well. These are standard tools on unix for compiling software.

tdl
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-11-12
Posts:

Ah, ok.. The sourcecode from the last beta release compiled fine, so I didn't think about missing tools for the svn version. Thanks!

tdl
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-11-12
Posts:

Ardour2 now compiled without errors.
The new version with the included clearlooks theme looks much better than the old beta for me (I couldn't see any text in the beta with GTE-Qt), but some captions are still barely readable (grey on grey, e.g. the drop down menus and some of the buttons) or at least hard to read (white on grey).

See http://img132.imageshack.us/img132/8485/ardour2svneq8.jpg

Will this be fixed, or is it a GTK-Qt problem (and I'll have to switch my engine for ardour2 to display correctly)?

taybin
User offline. Last seen 41 weeks 9 hours ago. Offline
Joined: 2006-03-15
Posts:

That isn't what the Ardour theme looks like at all. That's what Ardour looks like with no theme at all.

tdl
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-11-12
Posts:

Well.. At least the text is readable for the most part ;)
I will try to compile the latest (svn) version of GTK-Qt later, maybe that helps.

skogkatt
User offline. Last seen 6 years 36 weeks ago. Offline
Joined: 2006-11-10
Posts:

Hi, I tested under Gnome and here are my results :

1/ I start with Human Theme (Ubuntu Defaut skin).Ardour diplays with his theme.
2/ I change for a another theme. Ardour take his own value, his
clearlook defaut theme and not the new theme. At this stage, all is
normal.
3/ I change again for Human Theme. Big problem : Ardour diplays with
Human Theme and not the Ardour theme (remember my screenshot).
4/ I change for a gtk theme : same situation like stage 2/.

My conclusion : something is wrong with the Human theme.

Are you Ok with this ? And are you sure Ardour2 doesn't interfere with Human Theme ?
I think to post a bug report on Ubuntu website if you consider it's totaly a Ubuntu bug.

Stan.

tdl
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-11-12
Posts:

Ok, I compiled the newest GTK-Qt from svn, but Ardour2 looked exactly like before with it. I finally decided to install and activate the 'original' clearlooks engine (Kubuntu doesn't install it by default).. Anyway, here is the result:
http://img87.imageshack.us/img87/4799/ardour4svnclearlooksba1.jpg

Is this how Ardour2 is supposed to look?

egag
User offline. Last seen 7 years 20 weeks ago. Offline
Joined: 2006-10-24
Posts:

@tdl:
I had the same look on a Slackware machine where i also used
GTK-qt engine.You don't need GTK-qt.

Install the Clearlooks theme.
Get it here : http://sourceforge.net/project/showfiles.php?group_id=129376

...and make sure to select that theme
for your user.

Then it should look like the frontpage image.

look here --> http://ardour.org

nowhiskey
User offline. Last seen 5 weeks 23 hours ago. Offline
Joined: 2006-09-30
Posts:

hi egag,
i just installed clearlooks following your link, but how i do "select that theme for the user"?

i am on debian + fluxbox here.

cheers,
doc

tdl
User offline. Last seen 7 years 11 weeks ago. Offline
Joined: 2006-11-12
Posts:

As I wrote, I'm now using the clearlooks theme, but Ardour2 doesn't display correctly with it either.

nowhiskey
User offline. Last seen 5 weeks 23 hours ago. Offline
Joined: 2006-09-30
Posts:

strange enough, my last post went into the wrong thread?
can someone repare?
thanks,
doc

egag
User offline. Last seen 7 years 20 weeks ago. Offline
Joined: 2006-10-24
Posts:

i use a little app called "gtk2_prefs" to set
a theme for me. You can get it here :

http://freshmeat.net/projects/gtk2_prefs/

There are more apps to configure gtk themes; i only tried
this one and it worked ok for me.

I believe that, after selecting the theme, you have to log out
and in again for it to take effect. Not sure but it's free.. :)

nowhiskey
User offline. Last seen 5 weeks 23 hours ago. Offline
Joined: 2006-09-30
Posts:

thanks egag, i did not knowed this theme-thing, everything looks better now!

cheers,
doc

funkmuffin
User offline. Last seen 5 years 42 weeks ago. Offline
Joined: 2006-05-03
Posts:

For anyone still having display problems with Ardour2, I just corrected mine!!!

My screen looked much like the screenshots above in this thread, and it was driving me nuts...

The solution in my case was in the KDE Control Center, under Appearance and Themes/Colors. I unchecked the box at the bottom for "Apply colors to non-KDE applications" and Voila! Ardour2 now looks as it should.

I'm a pretty happy camper.

kungfoo
User offline. Last seen 5 years 30 weeks ago. Offline
Joined: 2006-07-04
Posts:

@ funkmuffin:

That is the EXACT solution on KDE!! Thanks. Gnome used to crash on me and now it runs finde in KDE...

NoStar
User offline. Last seen 4 years 14 weeks ago. Offline
Joined: 2006-03-27
Posts:

Unfortunately the addition of the clearlooks engine to ardour2 still wont fix the problem that is resolved by doing the disabling of 'Apply colors to non-KDE applications' for KDE and whatever method there is to disable a given WM from altering GTK app themes. Being even more widget specific (as opposed to just doing magor damage with a few class definitions) in the rc file will fix the WM taking over ardour2 problem.

zoops
zoops's picture
User offline. Last seen 5 years 8 weeks ago. Offline
Joined: 2007-05-12
Posts:

For me, it was as simple as changing the "GTK Styles" option at the top of the module in the KDE control centre under "Appearance/GTK Styles and Fonts". I found that having it set to "Use another style" overrides parts of ardour's theme so I changed it to the option that says "Use my KDE style in GTK applications". Bear in mind that the fix is only useful if you use KDE and have the GTK-QT engine installed since the module won't show up otherwise. You may have to be using a new-ish version of KDE too as I don't think the option has been around for long. Anyway - the simple truth is that ardour should probably have more strict controls on it's user interface that prevent any other program from changing the look - maybe an option to fix/set the UI to the default clearlooks setting on program load. I'm sure it could be done!
-zoops. :)

zoops
zoops's picture
User offline. Last seen 5 years 8 weeks ago. Offline
Joined: 2007-05-12
Posts:

Sorry to double post - but actually I found that keeping it set to "Use another style" but changing the dropdown to 'clearlooks' also works (since that's what ardour uses! - but perhaps other styles work as well?) and looks a whole lot better when applied to other GTK applications than "Use my KDE style in GTK applications". So this fix is preferable to the one above - if it works for you!
-zoops. :)